
Can not be reproduced without permission from Texas Instruments Incorporated 
Copyright Texas Instruments Incorporated   

 Reference Manual 
TI DN 2510448 

July  2009 

 

DLP Discovery™ 4100 Explorer Software User’s Guide 

 
 

 
 

 
 

 
 
 

 
This manual describes the operation of the DLP Discovery 4100 Explorer software. The Discovery 
software provides control and display functions via USB 2.0 for the Discovery 4100 hardware.  
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IMPORTANT NOTICE 

 
BEFORE USING TECHNICAL INFORMATION, THE USER SHOULD CAREFULLY READ THE 
FOLLOWING TERMS. 
 
The term “Technical Information” includes reference designs, drawings, specifications, and other 
information relating to TI DLP® products or applications, contained herein or provided separately in any 
format or via any medium. 
 
TI is providing Technical Information for the convenience of purchasers of DLP® products (“Users”), and 
will not accept any responsibility or liability arising from providing the Technical Information or its use.  
Any use or reliance on Technical Information is strictly the responsibility of the User. 

 
1. No Warranty.  THE TECHNICAL INFORMATION IS PROVIDED “AS IS”.  TI MAKES NO 

WARRANTIES OR REPRESENTATIONS, EXPRESS, IMPLIED OR STATUTORY, INCLUDING 

LACK OF VIRUSES, ACCURACY, OR COMPLETENESS. TI DISCLAIMS ANY WARRANTY OF 

TITLE, ANY IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR 
PURPOSE, QUIET ENJOYMENT, QUIET POSSESSION, AND NON-INFRINGEMENT OF ANY 

THIRD PARTY INTELLECTUAL PROPERTY RIGHTS WITH REGARD TO THE TECHNICAL 

INFORMATION OR THE USE OF THOSE MATERIALS. 

2. Warranty for Products Not Affected. The foregoing exclusion and disclaimer of warranty does not affect 
or diminish any warranty rights with regard to DLP® products.  Such rights are governed exclusively by 

the terms of a written and signed purchase agreement with TI.   

3. Limitations and Exclusion of Damages.  IN NO EVENT SHALL TI BE LIABLE FOR ANY ACTUAL, 
SPECIAL, INCIDENTAL, CONSEQUENTIAL OR INDIRECT DAMAGES, HOWEVER CAUSED, ON 

ANY THEORY OF LIABILITY AND WHETHER OR NOT TI HAS BEEN ADVISED OF THE 

POSSIBILITY OF SUCH DAMAGES, ARISING IN ANY WAY OUT OF THE TECHNICAL 

INFORMATION OR THE USE OF THE TECHNICAL INFORMATION. 

4. No Engineering Services.  User is fully responsible for all design decisions and engineering with regard to 
its products, including decisions relating to application of DLP® products. By providing Technical 

Information TI does not intend to offer or provide engineering services or advice concerning User’s design.  

If User desires engineering services, then User should rely on its retained employees and consultants and/or 

procure engineering services from a licensed professional engineer (“LPE”).  

5. Compliance with Export Control Laws. Unless prior authorization is obtained from the U.S. Department 
of Commerce, User may not export, re-export, or release, directly or indirectly, any Technical Information, 

or export, directly or indirectly, any direct product of such Technical Information to any destination or 

country to which the export, re-export or release of the Technical Information or direct product is 
prohibited by the Export Administration Regulations of the U.S. Department of Commerce (“EAR”).  
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1.0 Overview 
 
This manual provides: 

� A general description of the DLP Discovery 4100 Explorer Software 

� Descriptions of menus, toolbars and display windows 

� Operation instructions 
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2.0 Terms and Definitions 
 
DMD Digital Micromirror Device 

GUI Graphical User Interface 

USB Universal Serial Bus 
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3.0 Software Overview 
 

� The DLP Discovery 4100 Explorer Software allows the user to control the DDC4100 Controller 
Board hardware via USB 2.0. The software uses the Discovery 4100 ActiveX control API which is 
documented separately in TI DN 2510142. The software has controls for building and executing a 
command script. 
 

� The GUI provides you with access to the ActiveX™ control’s implementations of the following 
commands: 

o Load individual blocks or entire DMD from image file. 

o Reset individual blocks or global reset. 

o Clear individual blocks or global clear. 

o Float all DMD mirrors. 

o Wait for external global reset input. 

o Timed delay. 

o Loop iteration control – Loop for N times or until break. 

o General purpose digital output control. 
 

3.1 DMD Image Control 

 
Images are controlled and displayed in blocks on the DMD.  The organization of the DMD blocks varies 
for different DMD types as shown in Table 1. Blocks can be loaded and displayed individually, or as an 
entire image (all 16 blocks). Section 6.0 will explain the commands to control the different ways an image 
can be displayed. 
Section 7.0 describes how to run a script of commands to control the displaying of an image. There are 
numerous combinations of display options available and this manual is not designed to cover them all. 
This user’s guide will present an overview of how each command can be used to control an image. 
 

Table 1 DMD Characteristics 

TYPE #COLS #ROWS #BLKS #ROWS/BLK 

.9 1080p Type A 1920 1080 15 72 

.7 XGA Type A 1024 768 16 48 

.55 XGA Type A 1024 768 16 48 

.55 XGA Type X 1024 768 16 48 

     
 
 
3.2 Image Commands 

• Load – Loads image blocks into memory. 

• Load and Reset – Loads image blocks into memory and displays the contents on the DMD. 

• Reset – Displays the contents of memory on the DMD. 

• Clear – Clears (zeroes) the contents of memory. 

• Clear and Reset – Clears (zeroes) the contents memory and displays the contents of 
memory on the DMD. 

• Float Mirrors – Sets the mirrors to an unbiased or flat condition. 
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4.0 Software User Interface  
 
The Explorer Software user interface consists of a multiple display interface containing a menu bar, 
toolbar and three display windows: Commands Window, Script Window and Status Window. The function 
of each item is described in the following sections. 
 

 

Figure 1 Graphical User Interface Layout 

4.1 Menu Bar 

 
The menu bar commands provide standard menu access to software commands as shown in Figure 2 
Menu Bar 
 

 

Figure 2 Menu Bar 
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4.1.1 File Menu 

 
The File menu contains the standard New, Open, Save and Exit menu items with options to open a script 
or a status, and to save a script or a status. 
 

 

Figure 3 File Menu 

4.1.2 View Menu 

 
The View menu allows you to show or hide any of the display windows.  
 

 

Figure 4 View Menu  

4.1.3 DMD Menu 

 
The DMD menu is used to select the DDC4100 Control operation mode. 
 

 

Figure 5 DMD Menu 

 
4.1.4 Execution Menu 

 
The Execution menu contains script commands and configuration options : 

 

• Run - Executes all the commands in the list without interruption, repeating script until 
Stop selected. 

• Run Once- Executes all the commands in the list without interruption for one cycle. 
• Loop Break – Exit Loop Until Break command. 

• Step - Sets the execution of commands to one step at a time mode. 

• Next Step – Executes the next script command. 

• Stop – End execution. 
• Set Start - Sets the start point of command execution within the script. 

• Set End - Sets the end point of command execution within the script. 
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Figure 6 Execution Menu 

4.1.5 Help Menu 

 
The Help menu contains the standard link to the help contents and the command to load the About dialog 
box. 
 

 

Figure 7 Help Menu 

4.2 Toolbar 

 
The Toolbar contains buttons to provide you with shortcuts to perform certain operations. 

 

 

 

 

 

 

 

 

 

Figure 8 Toolbar 

 

 

File Menu Icons 

Run 

Run Once 

Loop Break 

Step 

Stop 
Set Start 

Set End 

Help 
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4.2.1 File Menu Buttons 

 
The first five buttons in the toolbar, New, Open, Save, Save As and Print have the same function as the 
five items in the File menu. 
 
4.2.2 Operational Mode Controls 

 
The next area of the toolbar is a drop down window to select the operational mode for the device. The two 
buttons immediately to the right of the drop down window are for selecting either the USB or Parallel 
operation modes. The current revision of the GUI is limited to ‘USB Mode’ only, therefore the drop down 
window and the Parallel button are disabled and the USB button will remain depressed. 
 
4.2.3 Run, Run Once, Loop Break, Step and Stop Controls 

 
Run, Run Once, Loop Break,  Step and Stop icons control the execution of the list of commands in the 
script window. Command function is as described in Section 4.1.1. 
 
4.2.4 Set Start and End Buttons 

 
Set Start and Set End icons set the start point and end point of command execution within a script. 
 
4.2.5 Help Button 

 
The Help button displays the help contents for the application. 
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4.3 The Script Commands Window 

 
The Script Commands Window, Figure 9, contains a series of Command Tabs with command options for 
building script commands. A script is build by adding commands to execute the desired sequence of 
operations on the DMD. To view and select the options associated with a command, click on the 
corresponding command tab. Once you’ve selected the commands and options, click the Add button to 
add the command options to the script. 
 

 

Figure 9 Script Commands Window 
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4.3.1 Load Tab 

 
Load commands select the image file and specify load operations.  
 
An image file must be selected before the Add button is pressed. To select an image file click the Open 
Image button and select the image file. Supported image file types are .bmp, .jpg, .gif and .bin. A .bin file 
is a binary file containing one bit per DMD pixel. 
 
The image data may be loaded to DMD memory by selecting Load or the image data may be loaded and 
the DMD reset to display the image by selecting Load and Reset. If Load and Reset is not selected the 
image will not be visible until a separate Reset command is executed.  

 
The entire image may be loaded (Global) or individual blocks may be loaded (Block). Block numbers 
may be from 1 to 16. Loading block 16 on the 1080p DMD w will be ignored since this DMD has only 15 
blocks. 
 
The image may be mirrored in the horizontal direction by selecting Mirror Image.  
 
Select the desired options and Add button to add the command to the script 
 

 
 

Figure 10 Load Tab 
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4.3.2 Reset Tab 

The Reset command causes the mirrors to change from the current state to the state of that in memory. 
The contents of memory are determined by the Load or Clear commands. You can choose to reset all the 
blocks (Global), or you can choose to reset blocks individually using the Single Block and Multiple 
Blocks options. Select the option you want to use and click the Add button to add the command to the 
script. 

 

 

Figure 11 Reset Tab 
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4.3.3 Clear Tab 

 

The Clear Tab commands clear the memory contents of all the blocks using the Global or individually 
using the Single Block option by writing zeroes to the contents of DMD memory.  The  Clear option 
clears memory only, the Clear and Reset option clears memory and performs a reset to change the 
display. Select the desired option and click on the Add button to add to script. 

 

Figure 12 Clear Tab 

 

4.3.4 Float Tab 

 
The Float Tab command places the DMD in safe state with the mirrors in the “floated” or flat condition and 
no bias applied to the DMD.  
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Figure 13 Float Tab 

 
4.3.5 Control Tab 

 

The Control commands tab supports commands for script execution control, external reset and digital 
output. 

The Wait for External Reset command will wait 10 seconds for an external global reset triggered by a 
rising edge on input GPIOA.0.  After ten seconds, execution of the script will resume with the next 
command in the script. GPIOA.0 is a 2.5V CMOS input. Refer to TI DN 2509510 for signal location.  
 
The Delay command delays for the specified time in msec. 
 
The Loop Until Break command loops until the Break button is clicked. 
 
The Loop command loops for the specified number of iterations. 
 
The Set GP Output command sets the value of general purpose digital outputs GPIOA.2-4. Value is 
entered in decimal. Bits 4,3,2 of value control the output state. Bits 7,6,5,1,0 of value are not used. 
GPIOA.2-4 are 2.5V CMOS outputs. Refer to TI DN 2509510 for signal location. 

李文康
矩形
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Figure 14 Control Tab 
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4.2 The Status Window 

 

The Status Windows displays the execution status, retrieved information and any responses sent back to 
the host from the Discovery 4100 after a command has been executed.  

 

 Figure 15 Status Window 
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4.4 The Script Window 

 
The Controller Board GUI uses a Script window (Figure ) to keep track of the images to be loaded and the 
commands to be executed on the DMD. Once you’ve added an image and the commands you want to 
execute to the script, you can change the command order, delete and insert commands at a specified 
location within the script. 
 

 

Figure 27.  Script Window 

The application executes commands in the order in which they are entered in the script. In order for the 
application to execute commands, the first command in the script must be the Image command followed 
by the correct path and file name for an existing image. See Inserting an Image to learn how to add an 
image to the script. 
 
4.4.1 Inserting Commands 

 
To insert a command in a specified location on the script, select the command from the Commands window, 
go to the desired location in the script and click the  button at the top of the Script Window. 

 
4.4.2 Moving Commands 

 
To alter the command order, select the command you want to move by clicking on it, then click the  

(up) arrow or the  (down) arrow to move it to the desired location. 

You can also move a command to the first position in the script by using the  button, or move it the 

last position with the  button. 

 
4.4.3 Deleting Commands 

 
To delete a command from the script, click on the command you want to delete and click the  

button at the top of the Script Window. 
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5.0 Script and Status Operations 
 
5.1 Saving Scripts and Statuses 
 
5.1.1 Saving a Script 

 
To save a script, proceed as follows: 

Step 1: Select the Script option from the  (Save) or  (Save As) icon drop down menu on the 

tool bar, or select Save Script or Save Script As from the Save option menu on the File 
menu. 

Step 2: Once the selection is made, a common dialog box will appear. Select or type the name of 
the file you would like to save the script. 

Step 3: Click the OK button and a message box will appear to notify you that the script has been 
saved.  
NOTE:  Scripts are saved with a .txt ending 

 
5.1.2 Saving a Status 

 
To save the contents of the Status Window, proceed as follows: 

Step 1: Select the Status option from the  (Save) or  (Save As) icon drop down menu on the 

tool bar, or select Save Status or Save Status As from the Save option menu on the File 
menu. 

Step 2: Once the selection is made a common dialog box will appear, select or type the name of 
the file you would like to save the status.  

Step 3: Click the OK button and a message box will appear to notify you that the script has been 
saved. 
NOTE:  Status files are saved with a .sts ending 

 
5.2 Printing Scripts and Statuses 

 
5.2.1 Printing a Script 

 
To print a script, select the Script option from the  (Print) icon drop down menu on the toolbar, or select 

the Script item from the Print option menu on the File menu. 
 
5.2.2 Printing a Status 

 
To print the contents of the Status Window, select the Status option from the  (Print) icon drop down 

menu on the toolbar, or select the Status item from the Print option menu on the File menu. 
 
5.3 Opening Scripts and Statuses 

 
You can open scripts [*.txt] or status files [*.sts] that have been previously saved by clicking the  (Open 

File) icon on the toolbar or by selecting the Script or Status option from the Open File menu on the File 
menu. Once you’ve selected the desired file, the file will be opened and the script or status file will be 
displayed in the Script or Status window.  
 
NOTE:  Scripts can be edited with a simple text editor. Therefore, when a script is opened it is checked 
for consistency.  If a command is missing a matching parameter or a parameter is missing a matching 
command, an error dialog will appear and the script will not be opened.  The script must be corrected 
before it can be opened. 
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5.4 Creating New Scripts and Statuses 

 
You can create a new script or status file by clicking the New File icon on the toolbar and then selecting 
the Script or Status option or by selecting the Script or Status option from the New File menu item on the 
File menu. 
 
5.4.1 Creating a New Script 

 
To open a new script, select the Script option from the  (New) toolbar icon drop down menu, or select 

the Script item from the New option menu on the File Menu. 
Once the selection is made, you will be prompted to save the current script and the blank script will be 
inserted. 
 
5.4.2 Creating a New Status 

 
To open a new status, select the Status option from the  (New) toolbar icon drop down menu, or select 

the Status item from the New option menu on the File Menu.  
Once the selection is made, you will be prompted to save the current status and the blank script will be 
inserted. 
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6.0  6.0 Discovery 4100 Operation 
 
The Discovery 4100 is capable of operating at about 10 XGA frames per second or 7 1080p frames per 
second when connected to a host system’s USB 2.0 port.  
 

 
6.1 Quick Start Guide to Operation 

 
The following steps must be followed in order to operate the device: 

Step 1: Install the software by executing setup.exe. Install the software BEFORE connecting the 
Discovery 4100 with USB. The setup program will install the software and drivers 
necessary operation.  
 

Step 2: Connect the Discovery 4100 board with a USB 2.0 mini-B to Type A cable and apply power 
to the Discovery 4100. The operating system will detect the USB device and prompt to 
install the driver. 
 
Select Install from a list or a specific location and click Next. Browse to c:\Program 
File\DMD\Discovery 4100\Drivers and click Next. The drivers will automatically load. 
 
If you see any driver logo testing or verification warnings, ignore them and select 
continue/install anyway: 

Windows XP 

 
 

Windows Vista 

 
 
 

李文康
矩形
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For Windows Vista Driver Installation: 

     Open up the Device Manager (Control Panel -> System -> Device Manager) 
 Right click the Unknown or USB device and select Update Driver 
 Select Browse my computer for driver software 
 Enter: “C:\Program Files\DMD\Discovery 4100\Drivers” 
 Repeat operation for any new devices that appear 
  

 
Step 3: Start the DLP Discovery Explorer  software from the Program Files / DMD menu. 

 
Step 4: The software will start. The USB connection status and DMD type should be displayed in 

the lower left status panel : 
 

 
 

 
 
 
 

 
Step 5: Open an image using the Load Tab / Open Image button. 

 
Step 6: Enter an image command in the script by selecting the desired options in the Load Tab 

button and clicking Add. 

 

李文康
矩形
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Step 7: Select and enter commands in the script. You select commands from any one of the 

command tabs on the Commands Window. Each tab contains a set of related commands 
and the options assigned to each command. Once you have selected the right combination 
of commands and options, enter the command into the script by clicking the Add button at 
the bottom of the command tab. Each tab has an Add button to enter that command into 
the script. 
 

Step 8: Execute the script. Once the desired list of commands has been entered into the Script 
Window, click the  (Run) icon on the toolbar to begin executing commands. You can also 

choose to step through the commands using the  (Step) icon on the toolbar instead of 

running through them all. You can also use the Execution menu to perform the same 
functions. Use the  (Stop) icon on the toolbar to stop executing commands.  
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7.0 DDC4100 Control Window 

The DDC4100 Control window is accessed through the DMD / DDC4100 Control menu and provides 
direct control of the DDC4100 input signals. No script commands are generated, the control is applied 
immediately to the DDC4100 when a Set button is clicked.  

The upper portion of the window supports reading and setting of the DDC4100 signals used in writing 
data to the DMD. The current value for ROWMD, ROWADDR, BLKMD and BLKADDR is displayed in the 
Current Value column. When a new value is entered in Hexadecimal in the Hex column and the Set 
button is clicked the value will be sent to the DDC41000. The Load Row button sends one row with 
repeating values of the 4 digit hex value entered. 

The lower portion of the window supports control of the DDC4100 input signals which are control 
operational modes. Click a button to toggle the current value of the signal. 

Refer to TI DN 2509511 for detailed information on the DDC4100 input signals. 

 

Figure 16 DDC4100 Control Window 

李文康
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8.0 About Box 
 

The About Box provides version information about various software and hardware of the 

Discovery 4100 system. 

 

 

Figure 17 The About Box 

 

 

9.0 Links 
 

For more information about Texas Instruments® DLP® Discovery Systems please visit: 

 

 www.dlpdiscovery.com or www.dmddiscovery.com 

 


