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前言 

阅前必读 

简介： 

本用户指南是 TMS320DM642 视频 DSP 处理模板硬件使用说明书，详细描述了

SEED-VPM642 的硬件构成、原理，以及它的使用方法和编程指导。 

保修： 

所有由北京合众达电子技术有限责任公司生产制造的硬件和软件产品，保修期为从发货

之日起壹年。在保修期内由于产品质量原因引起的损坏，北京合众达电子技术有限责任公司

负责免费维修或更换。当在保修期内软件进行了升级，北京合众达电子技术有限责任公司将

免费提供。 

参考资料： 

TMS320C6000 Technical Brief（文献号SPRU197）：介绍C6000系列DSP的入门知

识及开发工具 

TMS320C6000 Cpu and Instruction Set Reference Guide（文献号SPRU189）：介

绍TMS320C6000系列DSP的CPU结构、指令组、流水线及中断。 

TMS320C6000 Peripherals Reference Guide（文献号SPRU190）：描述C6000系
列DSP片上的通用外设，包括DSP片上数据各程序存储器、外部存储接口（EMIF）、主机

接口（HPI）、串口、DMA/EDMA控制器、扩展总线（XBUS）、时钟和锁相环电路（PLL）
和省电工作方式等。 

TMS320DM642 Video/Imaging Fixed-Point Digital Signal Processor （文献号

SPRS200）：描述 TMS320DM642 定点 DSP 的特点、电气指标、时序、以及引脚封装等。 

TMS320DM642 Technical OverView （文献号 SPRU615）：介绍 TMS320DM642
的各种技术及应用。 

TMS320C6000 DSP External Memory Interface（EMIF）Reference Guide（文献

号SPRU266）：描述DSP的EMIF外设的功能。 
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TMS320C6000 DSP Enhanced Direct Memory Access（EDMA）Controller 
Reference Guide（文献号SPRU234）：描述DSP的EDMA的功能。 

TMS320C6000 DSP 32-Bit Timer Reference Guide（文献号SPRU582）：描述DSP
的定时器的功能。 
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Reference Guide（文献号SPRU629）：描述视频口与VIC口的功能。 

TMS320C6000 DSP Multichannel Audio Serial Port （McASP） Reference Guide 
（文献号SPRU041）：描述外设McASP的功能与使用。 

TMS320C6000 DSP Inter-Integrated Circuit （I2C） Module Reference Guide （文

献号SPRU175）：描述外设I2C的功能。 

TMS320C6000 DSP Ethernet Media Access Controller （EMAC）／Management 
Data Input／Output （MDIO） Module Reference Guide（文献号SPRU628）：描述外

设EMAC与MDIO的功能。 

TMS320C600 DSP Peripheral Component Interconnect （PCI）Reference Guide
（文献号 SPRU581）：描述外设 PCI 的功能。 

TMS320C6000 DSP General-purpose Input／Output （GPIO） Reference Guide
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TL16C752B：描述 TL16C752B 带 64-字节 FIFO 的双路 UART 芯片的特点、电气指标、

时序，以及引脚封装等。 
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第 1 章 

入门 

1.1 特点： 
  采用 TMS320DM642，专用于数字媒体应用的高性能 32-位定点 DSP，工作主频

最高达 720MHz，处理性能可达 5760MIPS 
 片上存贮器： 

 L1P Cache： 16K×8-位 
 L1D Cache： 16K×8-位 
 L2 RAM/Cache： 256K×8-位 

 片上外设： 
 32 位的定时器：  3 通路； 
 McBSP：      2 通路； 
 McASP：   1 通路； 
 Video Port：      3 通路； 
 VIC：         1 通路； 
 PCI：    1 通路； 
 IIC：    1 通路； 
 GPIO：    8 通路； 
 EMAC&MDIO：  1 通路； 
 16/32 位 HPI：  1 通路； 

  外扩 SDSRAM ，容量为 4M×64 位 
  外扩 Flash，容量为 4M×8 位 
  4 路 PAL/NTSC 标准模拟视频输入（CVBS 或 Y/C 可选），1 路 PAL/NTSC 标准

模拟视频输出（CVBS + Y/C） 
  4 路立体声音频输入／输出（Microphone 输入或 Line In 可选） 
  8 路数字量输入，8 路数字量输出，用于状态和报警信号的输入／输出 
  2 路 UART 接口，接口标准 RS232／RS422／RS485 可配置 
  实时时钟 RTC + 512×8-位 EEPROM 
  32 位、33MHz，支持主／从模式的 PCI 2.2 标准 
  10M/100Mbase-TX 标准以太网接口 
  标准的 ATA 硬盘接口 
  ESAM 硬件加密模块，支持 DES／3DES 密钥算法，2K×8-位加密保护的

EEPROM，可存放密钥、设备序列号、或其他重要的代码或数据 



 2 

1.2 功能框图 
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 1.3 概述 

SEED-VPM642 是一款专为各种视频应用而开发的 PCI 插卡或带 10/100M 以太网接口

的独立的模板，其上包含：专用于数字媒体应用的高性能 32-位定点 DSP TMS320DM642，
其工作主频高达 720MHz，处理性能可达 5760MIPS，可实时实现多路数字视频／音频的编

码运算，如：MPEG4、H.264、G.729 等；多路视／音频接口：4 路 PAL/NTSC 制标准复

合或 Y/C 模拟视频输入，1 路 PAL/NTSC 制标准复合或 Y/C 模拟视频输出，4 路标准的

Microphone 输入或 Audio Line In 立体声输入，4 路标准的 Audio Line Out 立体声输出；2
路可编程切换的 RS232/RS422/RS485 异步接口，8 路数字输入、8 路数字输出，用于云台

控制和环境监控；大容量本地存储：标准的 ATA 硬盘接口，方便本地存储，实现数字视频

录像机功能；高速数据传输接口：标准的 32-位、33MHz、支持主／从模式的 PCI 2.2 总线、

或 10/100M 以太网接口，方便实现数字视频服务器功能；实时时钟，为数字视频／音频提

供实时时基信息；软／硬件加密功能，更好地保护产品开发者的知识产权。 

SEED-VPM642 结构紧凑、布局合理，标准的半长 PCI 插卡（175mm×107mm），4
路视频输入／1 路视频输出和 4 路音频立体声输入、8 路开入／8 路开出和 2 路

RS232/RS422/RS485 异步串口分别由 2 个高密度 DB-26 连接器从 PC 机后面板引出，+5V
电源输入、RJ45 以太网接口则从对边引出，ATA 硬盘接口位于右上方，而 1 路 Y/C 视频输

出和 4 路立体声音频输出则位于左上方。 

SEED-VPM642 系统主要包含两部分，分别为 SEED-VPM642 的硬件系统与相应的测

试软件。 

在 SEED-VPM642 中主要集成了 DSP、SDRAM、FLASH、VIDEO、AUDIO、UART、
IO、RTC、ESAM、ATA 与网络接口等外设。这样使其能够应用在视频与语音的处理及其

相关的领域。 

相应的测试软件包括以下几个部分： 

  DSP 对 VIDEO 的操作的示例程序； 
  DSP 对 AUDIO 的操作的示例程序； 
  DSP 对 IO 的操作及 UART 与计算机通讯的示例程序； 
  DSP 对 ESAM 的操作的示例程序； 
  DSP 对 RTC 的操作的示例程序； 
  DSP 对 SDRAM 与 FLASH 的操作示例； 
  DSP 对 ATA 的操作的示例程序； 
  DSP 对网络接口的操作的示例程序； 
  PCI 的操作示例程序； 
  DSP 的 Bootloader 示例程序； 
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1.4 技术指标 
  主处理器： TMS320DM642，工作主频高达 720MHz，处理能力可达

5760MIPS 
  SDRAM： 4M×64-位，工作时钟 133MHz 
  Flash： 4M×8-位，70ns（20 年数据保存，1,000,000 次擦写） 
  视频输入： 4 通道，DB-26 连接器，PAL/NTSC 标准模拟视频信号（CVBS

或 Y/C 可选），最大输入范围：0～1 VPP 
NTSC： 720×525@30 帧／秒 
PAL： 720×625@25 帧／秒 

  视频输出： 1 通道，DB-26 连接器，PAL/NTSC 标准模拟视频信号（CVBS 
+ Y/C 可选），最大输出范围：CVBS：0～1.23 VPP，Y：0～1 
VPP，C：0～0.89 VPP 
NTSC： 720×525@30 帧／秒 
PAL： 720×625@25 帧／秒 

  音频输入： 4 通道，DB-26 连接器，Microphone 输入（支持驻极体

Microphone，并提供偏置电压）、或 Line In 输入（输入范围：

2VRSM） 
支持 8KHz～96KHz@16/20/24/32-位采样 

  音频输出： 4 通道，标准 3.5mm Audio Jack 连接器，Line Out 输出（输出

范围：1VRSM @10KΩ／50pF 负载 
支持 8KHz～96KHz@16/20/24/32-位采样 

  异步串口： 2 通道，DB-26 连接器，RS232/RS422/RS485 可编程配置 
 传输率：RS232：1Mbaud；RS422/RS485：1.92Mbaud 

  数字 I/O： 8 路开入、8 路开出，DB-26 连接器 
开入：VIH：2.0V～5.5V，VIL：-0.5V～0.8V 
开出：VOH：2.4V@-4mA，VOL：0.5V@8mA 

  实时时钟： 提供年、月、日、星期、时、分、秒等实时信息（±30ppm） 
 提供 512×8-位 EEPROM（100 年数据保存，100,000 次擦写） 
 IIC 总线 400KHz 数据传输率 

  PCI 接口： 32 位、33MHz，支持主／从模式的 PCI 2.2 标准 
  以太网接口： 10M/100Mbase-TX 标准，标准的带绿、黄 2 个 LED 指示灯的

RJ45 连接器，绿灯指示连接状态，黄灯指示数据传输或传输速

度 
  ATA 接口： 带围墙的 40-芯 IDC 针式插座，实现 ATA 的 PIO 4.0 传输方式 
  工作温度： 0～70℃ 
  机械尺寸： 标准 PCI 半长卡（175mm×107mm） 
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第 2 章 

TMS320DM642 基本系统 

2.1 TMS320DM642 简介 

TMS320DM642 是美国德州仪器公司（TI）推出的一款面向数字多媒体应用的 DSP，
它在 TI 的 C64x DSP 内核基础上进一步集成了完备的视频／音频输入／输出接口、以太网

接口、PCI-66 总线等片上外设，不仅能使用户很方便地对音频／视频等各种复杂的运算进

行高速处理，还能为方便、无缝地接口视频／音频编解码器件和以太网／PCI 总线等数据传

输接口。非常适用于 VoIP、数字视频服务器、多通道数字视频录像机（DVR）、多通道数

字视频监控等应用，提供高质量的视频编／解码解决方案。 其功能框图如下： 
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2.2 TMS320DM642 存贮空间的配置 

TMS320DM642 的程序／数据空间以字节为单位进行统一编址，整个寻址空间为 4G-
字节。其片上存储器、片上外设、及外部存储器接口（EMIF）均映射到此 4G-字节空间中。 

TMS320DM642 的存贮空间映射如下图所示： 

Memory Block Description 
Block Size

（Bytes）
HEX Address Range 

Internal RAM (L2) 256K 0000 0000 ～ 0003 FFFF 

Reserved 768K 0004 0000 ～ 000F FFFF 

Reserved 23M 0010 0000 ～ 017F FFFF 

External Memory Interface A (EMIFA) Registers 256K 0180 0000 ～ 0183 FFFF 

L2 Registers 256K 0184 0000 ～ 0187 FFFF 

HPI Registers 256K 0188 0000 ～ 018B FFFF 

McBSP 0 Registers 256K 018C 0000 ～ 018F FFFF 

McBSP 1 Registers 256K 0190 0000 ～ 0193 FFFF 

Timer 0 Registers 256K 0194 0000 ～ 0197 FFFF 

Timer 1 Registers 256K 0198 0000 ～ 019B FFFF 

Interrupt Selector Registers 256K 019C 0000 ～ 019F FFFF 

EDMA RAM and EDMA Registers 256K 01A0 0000 ～ 01A3 FFFF 

Reserved 512K 01A4 0000 ～ 01AB FFFF 

Timer 2 Registers 256K 01AC 0000 ～ 01AF FFFF 

GP0 Registers 256K - 4K 01B0 0000 ～ 01B3 EFFF 

Device Configuration Registers 4K 01B3 F000 ～ 01B3 FFFF 

I2C0 Data and Control Registers 16K 01B4 0000 ～ 01B4 3FFF 

Reserved 32K 01B4 4000 ～ 01B4 BFFF 

McASP0 Control Registers 16K 01B4 C000 ～ 01B4 FFFF 

Reserved 192K 01B5 0000 ～ 01B7 FFFF 

Reserved 256K 01B8 0000 ～ 01BB FFFF 

Emulation 256K 01BC 0000 ～ 01BF FFFF 

PCI Registers 256K 01C0 0000 ～ 01C3 FFFF 

VP0 Control 16K 01C4 0000 ～ 01C4 3FFF 

VP1 Control 16K 01C4 4000 ～ 01C4 7FFF 

VP2 Control 16K 01C4 8000 ～ 01C4 BFFF 

VIC Control 16K 01C4 C000 ～ 01C4 FFFF 

Reserved 192K 01C5 0000 ～ 01C7 FFFF 

EMAC Control 4K 01C8 0000 ～ 01C8 0FFF 

EMAC Wrapper 8K 01C8 1000 ～ 01C8 2FFF 

EWRAP Registers 2K 01C8 3000 ～ 01C8 37FF 

MDIO Control Registers 2K 01C8 3800 ～ 01C8 3FFF 
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Reserved 3.5M 01C8 4000 ～ 01FF FFFF 

QDMA Registers 52 0200 0000 ～ 0200 0033 

Reserved 928M – 52 0200 0034 ～ 2FFF FFFF 

McBSP 0 Data 64M 3000 0000 ～ 33FF FFFF 

McBSP 1 Data 64M 3400 0000 ～ 37FF FFFF

Reserved 64M 3800 0000 ～ 3BFF FFFF

McASP0 Data 1M 3C00 0000 – 3C0F FFFF

Reserved 64M - 1M 3C10 0000 – 3FFF FFFF

Reserved 832M 4000 0000 – 73FF FFFF

VP0 Channel A Data 32M 7400 0000 – 75FF FFFF

VP0 Channel B Data 32M 7600 0000 – 77FF FFFF

VP1 Channel A Data 32M 7800 0000 – 79FF FFFF

VP1 Channel B Data 32M 7A00 0000 – 7BFF FFFF

VP2 Channel A Data 32M 7C00 0000 – 7DFF FFFF

VP2 Channel B Data 32M 7E00 0000 – 7FFF FFFF

EMIFA CE0 256M 8000 0000 – 8FFF FFFF

EMIFA CE1 256M 9000 0000 – 9FFF FFFF

EMIFA CE2 256M A000 0000 – AFFF FFFF

EMIFA CE3 256M B000 0000 – BFFF FFFF

Reserved 1G C000 0000 – FFFF FFFF

TMS320DM642 通过外部存贮器接口（EMIF）访问片外存储器，EMIF 由 64-位数据线

D[63:0]、20-位地址线 A[22:03]、8-位字节使能线 BE[7:0]、4-位片选线 ～ 和各类

存储器的读／写控制信号 、 、 、

ARDY、SDCKE、 、 、 、ECLKIN、ECLKOUT1、ECLKOUT2 组成，每

个 空间有 256M-字节寻址空间，并且可配置为与 SRAM、Flash、SDRAM、ZBTSRAM
等各类存储器接口。 

SEED-VPM642 上 EMIF 的外部输入时钟 ECLKIN 设计为 133MHz，因此 EMIF 以

133MHz 时钟进行工作。 

关于 TMS320DM642 的 EMIFA 的设计与应用，请参看文档：TMS320C6000 DSP 
External Memory Interface（EMIF）Reference Guide（文献号 SPRU266）。 

2.2.1 SEED-VPM642 存储空间的具体配置 

SEED-VPM642 视频处理模板上，通过 EMIF 扩展的外部存储资源如下： 

  Flash 最大 4M×8-位，8-位异步静态存储器接口； 
  SDRAM 最大 4M×64-位，64-位同步动态存储器接口； 
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  状态／控制寄存器 8×8-位，8-位异步静态存储器接口。这些寄存器位于

SEED-VPM642 模板的 CPLD 中实现； 
  UARTA 8×8-位，8-位异步静态存储器接口； 
  UARTB 8×8-位，8-位异步静态存储器接口； 
  ATA 16×16-位，16-位异步静态存储器接口； 

这些外扩的存储资源将被映射到’DM642 的 EMIF 的 4 个 存储空间中，分配时将相

同类型、相同数据宽度的存储器接口组合到同一个 存储空间中，存储空间的具体分配如

下。 

2.2.1.1 空间 

TMS320DM642 的 子空间被配置为 64-位 SDRAM 接口，分配给外扩的 SDRAM 使

用。SDRAM 的工作时钟由’DM642 的 ECLKOUT1 提供，其可由软件配置为 EMIF 的

ECLKIN、或 CPU 时钟/4、或 CPU 时钟/6，最高为 133MHz。一般情况下，配置为 ECLKIN，

即 133MHz。 

SDRAM 在 子空间的具体定位为：0x8000 0000～0x81FF FFFF。 

SDRAM 的读／写时序参看《MT48LC4M32BPG Data Sheet》。 

2.2.1.2 空间 

TMS320DM642 的 子空间被配置为 8-位异步具体存储器接口，分配给了

SEED-VPM642 模板上的 Flash、状态／控制寄存器、UARTA、UARTB 等使用， 子

空间的具体划分如下：  

2.2.1.2.1 Flash 

 SEED-VPM642 模板上最大可以配置 4M×8-位的 Flash，’DM642 将 EMIF 的 子空

间配置为 8-位异步静态存储器接口来接口 Flash，Flash 的读／写时序参见《Am29LV033C  
Data Sheet》。Flash 在 子空间占据的具体空间定位为 0x9000 0000～0x9007 FFFF。 

TMS320DM642 外部地址总线只有 A[22:3]，总共 20 根，所以 子空间最大的寻址

范围为 1M×8-位。SEED-VPM642 板上 子空间除了分配给 Flash 以外，还分配给状态

／控制寄存器、UARTA、UARTB 等资源使用，其中 Flash 只占据 子空间的前一半的寻

址空间，即最大的可寻址范围为 512K×8-位，而 Flash 的设计容量为 4M×8-位，所以为了

寻址到 Flash 所有的地址空间，在 SEED-VPM642 模板上采用分页技术来实现对 Flash 的

访问，即将整个 4M×8-位的 Flash 分成 8 个 512K×8-位的页，而页地址 PA21、PA20、
PA19 则由页地址寄存器提供（页地址寄存器位于 CPLD 中）。 

Flash 页寄存器（FLASHPAGE）： 

地址：0x9008 0011（只写） 
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D07 D06 D05 D04 D03 D02 D01 D00 
× × × × × PA21 PA20 PA19 

PA[21:19]： FLASH 的页地址 

2.2.1.2.2 状态／控制寄存器 

SEED-VPM642 模板上共有 7 个控制寄存器，用于设置板上各个外设的状态，其控制

寄存器列表如下： 

  DIOOUT 寄存器 8-位，用于控制 8-位数字量输出； 
  FLASHPAGE 寄存器 3-位，用于给出 Flash 的页地址 PA[21:19]； 
  UARTSET 寄存器 4-位，用于设置 UART 的工作方式； 
  AUDIOPLL 寄存器 3-位，用于设置 音频锁相环 PLL1708； 
  ESAMCNTL 寄存器 3-位，用于与嵌入式加密模块（ESAM）进行通信； 
  WATCHDOG 寄存器 1-位，用于使能看门狗； 
  WDUP 寄存器 0-位，用于刷新看门狗。 

SEED-VPM642 模板上共有 3 个状态寄存器，用于采集当前模板上各个外设的运行状

况，其列表如下：  

  DIOIN 寄存器 8-位，用于读取 8-位数字量输入； 
  ATASTATUS 寄存器 1-位，用于读取 ATA 的工作状态； 
  ESAMSTATUS 寄存器 1-位，用于与嵌入式加密模块（ESAM）进行通信。 

SEED-VPM642 状态／控制寄存器的地址列表如下： 

寄存器 地址 读与写 
DIOOUT  0x9008 0010 只写 

FLASHPAGE 0x9008 0011 只写 
UARTSET 0x9008 0012 只写 
AUDIOPLL 0x9008 0013 只写 
ESAMCNTL  0x9008 0014 只写 
WATCHDOG 0x9008 0015 只写 

WDUP 0x9008 0016 只写 
DIOIN 0x9008 0010 只读 

ATASTATUS 0x9008 0011 只读 
ESAMSTATUS 0x9008 0014 只读 

SEED-VPM642 状态／控制寄存器的详细说明参见附录 A。 
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2.2.1.2.3 UART 

SEED-VPM642 模板上选用 TL16C752B 实现 2 路异步串口，’DM642 将 EMIF 的 子

空间配置为 8-位异步静态存储器接口来接口 TL16C752B，每路异步串口占用 8 个 8-位存储

单元，TL16C752B 在 子空间的具体定位如下表： 

串口 字节地址 
UART A 0x9008 0000 ～ 0x9008 0007 
UART B 0x9008 0007 ～ 0x9008 000F 

TL16C752B 的读／写时序参见《TL16C752B Data Sheet》。 

有关 SEED-VPM642 的 2 个异步串口的详细描述参见第 3 章《UART 接口》。 

2.2.1.3 空间 

TMS320DM642 的 子空间被配置为 16-位异步静态存储器接口，分配给外扩的 ATA
标准硬盘接口，以 PIO 方式来实现硬盘的读／写操作。ATA 有 2 个片选空间 CS0 和 CS1，
每个空间占用 8 个 16-位存储单元，ATA 在 子空间的具体定位如下表： 

串口 字节地址 
ATA_CS0 0xA000,0000 ～ 0xA000,0007 
ATA_CS1 0xA000,0010 ～ 0xA000,0017 

有关 SEED-VPM642 的硬盘接口的详细描述参见第 4 章《ATA 接口》。 

2.2.1.4 空间 

此空间在 SEED-VPM642 模板上未使用。 

2.3 Video Port和McASP 

TMS320DM642 共有三个视频口，分别为 VP0、VP1 和 VP2。其中 VP2 为单一功能

的视频口。VP0 与 VP1 则与 McBSP、McASP 复用引脚的，其功能选择由’DM642 上的外

设配置寄存器（PERCFG）进行配置的。PERCFG 寄存器的位域定义如下： 
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其中将相应的位置“1”，则使能该功能，置“0”，则禁止该功能。其操作方法参看

TMS320DM642 Video/Imaging Fixed-Point Digital Signal Processor （ 文 献 号

SPRS200）。这些功能模块的配置情况如下图所示： 

 

SEED-VPM642 模板上，将 PERCFG 设置为 0x79，使能 3 个视频口和 McASP 口，

具体配置如下： 

  VP2： 配置为 VP2A 和 VP2B 二个 8-位 BT.656 视频输入口，用于分别接口

2 路 BT.656 标准数字视频输入（分别对应第 3、第 4 路视频解码器

的输出）； 
  VP1： 配置为 VP1A + McASP 数据口； 
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 VP1A 配置为 8-位 BT.656 视频输入口，用于接口 1 路 BT.656
标准数字视频输入（对应第 2 路视频解码器的输出）； 

 McASP 数据口用于接口 4 路数字立体声音频输入／输出（对应

第 1～4 路立体声音频 Codec 的数据口）。 
  VP0： 配置为 VP0A + McASP 控制口。 

 VP0A 配置为 8-位 BT.656 视频输入或输出口，用于接口 1 路

BT.656 标准数字视频输入或输出（对应第 1 路视频解码器的输

出或对应视频编码器的输入）。 
 McASP 控制口用于为 4 路数字立体声音频提供控制信号。 

2.4 PCI、HPI和网络接口（EMAC与MDIO） 

TMS320DM642 支持多种外部接口：PCI 接口、HPI 接口和以太网 MAC 接口，这些接

口信号复用相同的引脚，它们的功能选择和配置是在上电复位时通过检测 TMS320DM642
上的特殊引脚（PCI_EN、MAC_EN、HD5、PCI_EEAI）的状态来实现的，具体情况如下

表所示： 

 

  PCI_EN 引脚： 内部下拉，PCI 接口使能。 
  PCI_EEAI 引脚： 内部下拉，使能通过外部EEPROM对PCI进行初始化。 
  HD05 引脚： 内部既不上拉，也不下拉。通过外部上拉或下拉来选择

HPI16／HPI32。 
  MAC_EN 引脚： 内部下拉，EMAC 和 MDIO 接口使能。 
  PCI66 引脚： 内部下拉，决定 PCI 总线工作在 66MHz 频率下还是

PCI 工作在 33MHz 频率下。 

SEED-VPM642 模板设计成根据模板安装的情况自动配置接口类型，可以自动配置成

下列 3 种接口中的一种： 

  32-位 PCI 接口 
  32-位 HPI 接口 
  16-位 HPI 接口 + 以太网接口 
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所以，SEED-VPM642 模板既可当作 PC 机的 PCI 插卡来使用（可多板同时使用）；

也可当作一个 32-位 HPI 接口设备来使用（也可多板同时使用）；也可独立使用，通过以太

网接口实现远程通讯。 

注：当用作 32-位 HPI 接口时，应将 PCI 连接器 J14 的 B10 接+3.3V、B3 接 GND。 

2.5 IIC 

TMS320DM642 上集成有一条 IIC 总线， ’DM642 为此 IIC 总线的主设备。

SEED-VPM642 模板上用此 IIC 总线连接了下列从设备： 

  4 路视频解码器 TVP5150PBS 的控制口 
  1 路视频编码器 SAA7121H 的控制口 
  4 路音频编解码器 TLV320AIC23B 的控制口 
  1 路实时时钟 RTC 

每个 IIC 总线的从设备均对应一个从设备地址，IIC 总线以此从设备地址来区分所访问

的是哪个从设备。TVP5150PBS 与 TLV320AIC23B 均只能配置为 2 个不同的从设备地址，

所以一条 IIC 总线中是不能同时连接 4 个 TVP5150PBS 或 TLV320AIC23B 的。

SEED-VPM642 模板上，将 IIC 总线作总线切换，分为 IIC 1 与 IIC 0，如下图所示： 

 

IIC 0 总线上连接： 

  第 1 路和第 2 路视频解码器 TVP5150PBS 的控制口 
  第 1 路和第 2 路音频编解码器 TLV320AIC23B 的控制口 

IIC 1 总线上连接： 

  第 3 路和第 4 路视频解码器 TVP5150PBS 的控制口 
  视频编码器 SAA7121H 的控制口 
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  第 3 路和第 4 路音频编解码器 TLV320AIC23B 的控制口 
  实时时钟 RTC 

IIC 的总线切换由’DM642 的 GP0[0]口来控制。对 IIC 总线各从设备的具体操作说明详

见相关从设备的章节。 

2.6 系统时钟 

TMS320DM642 片上时钟电路如下图所示： 

 

时钟电路由 PLL、分频器和多路切换器组成，给’DM642 的 CPU 内核、EMIF 和片上外

设提供时钟。 

SEED-VPM642 模板上输入时钟 CLKIN 为 50MHz，CLKMODE[1:0]上拉或下拉为 10，
即片内 PLL 设置为×12，CPU 内核频率为 50×12 = 600MHz。ECLKIN 为 133MHz，
AEA[20:19]上拉或下拉为 00，即 EMIF 时钟 ECLKOUT1 配置为来自 ECLKIN，为 133MHz。
而片上外设总线、EDMA 传输和 L2 存储器的工作频率为 CPU 内核频率的 1/2，即 300MHz；
片上定时器的工作频率为CPU内核时钟频率的 1/8，即 75MHz；片上外设McASP和McBSP
的工作频率为 CPU 内核时钟频率的 1/4，即 150MHz。 
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2.7 定时器 

TMS320DM642 片上有三个 32-位的定时器，其功能框图如下图所示： 

 

SEED-VPM642 模板上没有使用’DM642 的定时器硬件资源，这 3 个定时器可供用户软

件编程使用。需要注意的是 Timer1 与 Timer0 的输出 TOUT1 与 TOUT2 与 TMS320DM642
的两个运行状态 LENDIAN 与 MACEN 复用管脚。在 SEED-VPM642 模板上将’DM642 配置

为 Little Endian，即已将 TOUT1/LENDIAN 引脚上拉；而以太网接口是根据 SEED-VPM642
模板的安装情况自动配置的，所以 TOUT/MACEN 引脚将会根据安装情况自动上拉或下拉。 

2.8 McBSP和VIC 

在 SEED-VPM642，模板上未使用这 2 个外设的硬件资源。 

2.9 复位与中断 

TMS320DM642 除了片上外设产生的中断请求以外，还有 5 个外部中断引脚 INT[7:4]
和 。其中断时序如下图所示： 

 

这些信号在 SEED-VPM642 板上均已上拉。 

由上图可以看出 TMS320DM642 是以沿方式触发中断的，其中低电平（即 1）最少保

持 128ns，而高电平（即 2）亦最少要保持 128ns。 

SEED-VPM642 模板上有下列多个中断源： 

  INTA、INTB：  UART 通道 A 和 B 产生的中断； 
  RTCINT：   实时时钟产生的中断； 
  ATAINT：   硬盘接口产生的中断； 
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  ESAMINT：   ESAM 模块产生的中断； 

这些中断源与 TMS320DM642 的外部中断引脚的对应关系如下所示：  

  ： 系统未使用。 
  INT4： 对应 ESAM 模块的中断 ESAMINT。 
  INT5： 对应 UART 模块的中断 INTA 与 INTB。 
  INT6： 对应 ATA 模块的中断 ATAINT。 
  INT7： 对应 RTC 模块的中断 RTCINT。 

SEED-VPM642 模板上有下列 4 个复位源，其中任何一个复位有效，将导致整个系统

复位： 

  上电复位： 系统上电后自动产生 200ms 复位信号，使系统从初始状态开始

执行 
  手动复位： 按动复位按钮时，产生复位信号，主要用于系统调试 
  看门狗复位： 当看门狗使能时，系统如果没有在规定的时间间隔内（最小值为

0.9s、典型值为 1.6s、最大值为 2.5s）对看门狗电路进行刷新，

则产生复位信号，使系统重新开始，提高系统抗干扰能力。看门

狗电路在上电复位后，处于禁止状态，看门狗电路通过将系统控

制寄存器 0（WATCHDOG）中的 WDEN 控制位置 1 来使能。

看门狗电路使能后，通过对看门狗刷新口（WDUP）作写操作

来刷新看门狗。 
  电源监测复位： 监测+3.3V 主电源，如果其下跌至 2.93V（典型值），产生复位

信号，提高系统的可靠性。 

TMS320DM642 复位时的一些关键引脚的设置决定了’DM642 工作状态选择或配置， 
SEED-VPM642 模板上这些关键引脚的默认配置总结如下： 

  AEA[22:21]＝11B：  用于选择上电自举方式，为 8-位的 Flash 自举方式。 
  CLKMODE[1:0]＝10B:  CPU 的时钟为 CLKIN×12； 
  AEA[20:19]＝00B：  ECLKOUT1 为 EMIF 外部时钟输入 AECLKIN； 
  TOUT1/LENDIAN 上拉： 系统工作在 Little Endian； 

2.10 上电自举方式的配置 

TMS320DM642 有多种上电自举方式，通过复位时 AEA[22:21]引脚的状态来选择，引

脚状态与上电自举方式的对应关系如下所示： 

  00 无自举模式。 
  01 HPI 或 PCI 自举。 
  10 此设置被禁止。 
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  11 EMIFA 通过 8-位的 Flash 自举。 

在 SEED-VPM642 模板上实现了以上的 Flash、HPI 或 PCI 三种自举方式，默认方式

为 EMIFA 通过 8-位的 Flash 自举。 

2.11 TMS320DM642 的输入与输出 

TMS320DM642 中共有 16 个通用的输入与输出 GP0[15:00]。但除了 GP0[0]以外，其

它的 GP0 管脚均与其它的功能复用。列表如下： 

  GP0[15:9]与 PCI 功能的控制引脚复用； 
  GP0[8]与 PCI66 和 VDAC 功能复用； 
  GP0[7:4]与外部中断 INT[7:4]功能复用； 
  GP0[3]与 PCIEEAI 功能复用； 
  GP0[2]与 CLKOUT6 功能复用； 
  GP0[1]与 CLKOUT4 功能复用。 

在 SEED-VPM642 模板上，GP0[3]与 GP0[8]用来做指示灯使用，而 GP0[0]用来控制

IIC 总线的切换。 

2.12 JTAG 

TMS320DM642 的仿真接口为 JTAG 形式，它能与各种形式的 JTAG 仿真器相连接，

实现对’DM642 的仿真与调试。 

注：当使用者使用 SEED 的并口仿真器时，应为仿真器接+5V 电源。 
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第 3 章 

视频接口 

在 SEED-VPM642 系统中共实现了四通路的视频输入接口与一个通路的视频输出接

口，四通路的视频输入接口可以同时完成对四路视频信号的采集。视频解码电路选用

TVP5150PBS，视频编码电路选用 SAA7121H。视频的解码与编码均支持 NTSC 和 PAL
制式。 

3.1 TMS320DM642 的VP口 

TMS320DM642 上集成了三个 Video Port（简称 VP）口，每个视频口由 20-位数据线、

2 个时钟信号 VPxCLK0（输入）和 VPxCLK1（输入／输出）、3 个控制信号 VPxCTL0、
VPxCTL1 和 VPxCTL2 组成。时钟信号作为视频源的时钟信号输入／ 输出，控制信号作为

视频源的同步信号输入／ 输出（行同步、帧同步、场标志，视频采集使能等）。 

每个视频口被分为上（B）、下（A）2 个通道，VP0 的 A 通道与 McBSP0 复用，VP1
的 A 通道与 McBSP1 复用，VP0 和 VP1 的 B 通道与 McASP 复用，VP2 则为单功能引脚。 

每个视频口可被配置为视频输入口或视频输出口，但是上（B）、下（A）2 个通道只

能同时被配置为输入口，或同时被配置为输出口，不能一个通道配置为输入口，另一个通道

配置为输出口。 

VP0 和 VP1 可配置为单通道视频输入／输出口 + McBSPx 或 McASP 口，VP2 可配置

为双通道视频输入／输出口。在 SEED-VPM642 中 VP0 和 VP1 被配置成为单通道视频输

入／输出口 + McASP 口，VP2 配置成为双通路的视频输入口。VP0 A 口接口第 1 通道视

频输入或视频输出、VP1 A 口接口第 2 通道视频输入、VP2 A 口接口第 3 通道视频输入、

VP2 B 口接口第 4 通道视频输入。 

当 VP0 与 VP1 配置为单通道视频输入口时，VPxCLK0 作为视频源的输入时钟，

VPxCLK1 未 用 。 而 VPxCTL0 、 VPxCTL1 和 VPxCTL2 则 分 别 作 为 视 频 源 的

CAPEN/AVID/HSYNC、VBLNK/VSYNC、FID 输入同步信号。 

当 VP2 配置为双通道视频输入口时，VPxCLK0 和 VPxCLK1 分别作为 2 个视频源的输

入时钟，而 VPxCTL0 和 VPxCTL1 分别作为 2 个视频源的采集使能信号，VPxCTL2 未用。 

双通道 BT.656 视频输入时，视频数据的行／场同步，通过各自的 BT.656 视频流中的

时基信号来控制。BT.656 视频数据流的采样受 CAPEN 信号控制或受 BT.656 视频数据流
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中的时基码控制。当 CAPEN 信号无效或在 EAV 和 SAV 时基码之间将不对视频数据流进行

采样。 

BT.656 视频数据流采集的起始、水平同步、垂直同步等，受输入信号 CAPEN 和视频

通道控制寄存器 VCxCTL（x = A、B）中的 VCEN、EXC、HRST、VRST、FLDD 等控制

位组合控制。 

当配置为单通道视频输出口时，VPxCLK1 作为视频源输出时钟，VPxCLK0 作为输入

时 钟 。 而 VPxCTL0 、 VPxCTL1 和 VPxCTL2 分 别 作 为 输 出 视 频 的

HSYNC/HBLNK/AVID/FLD、VSYNC/VBLNK/CSYNC/FLD、CBLKN/FLD。 

DM642 的视频口作为 8-位视频口时，其使用 10-位数据总线中的高 8-位，即 VPxD[9:2]
或 VPxD[19:12]。 

更加详细的说明，参看文档 TMS320C64x DSP Video Port/VCXO Interpolated 
Control (VIC) Port Reference Guide（文献号 SPRU629）。 

3.2 TVP5150PBS 

TVP5150PBS 是一款高性能视频解码器，可将 NTSC、PAL 视频信号转换成数字色差

信号 (YUV4:2:2)，支持两个复合视频或一个 S 端子输入。输出格式为 ITU-R BT.656，并

支持 Macrovision™ 复制保护以及高级的 VBI 功能。不仅如此，TVP5150 还具备了封装

小（32 脚的 TQFP）、功耗小的特点（<150mW），因此，非常适用于便携、批量大、高

质量和高性能的视频产品。 

详细的说明用户参阅文档 TVP5150PBS。 

3.2.1 TVP5150 视频输入 

视频解码器 TVP5150PBS 可以接受 2 路复合视频信号（CVBS）输入和 1 路超级视频

信号（S-Video = Super-Video，Y/C）输入。输入电路如下图所示： 
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视频解码器 TVP5150PBS 视频信号输入范围为 0.75VPP，而外部视频信号输入范围一

般为 1 VPP，所以外部视频输入与 TVP5150APBS 视频输入之间串接 18Ω和 56Ω到地分压

电阻网络，以达到 TVP51500PBS 所需的输入电平。使用前一定要将视频信号输入的范围

调整到 1 VPP。 

外部视频信号输入可以采用复合视频和超级视频的形式，其接法如下： 

  当使用复合视频信号输入时，CVBS/Y 作为复合视频输入，CVBS/C 接模拟地； 
  当使用超级视频信号时，CVBS/Y 作为亮度分量 Y 和 CVBS/C 作为色度分量 C。 

在随 SEED-VPM642 系统自带的视频输入连接器中采用复合视频信号输入。 

3.2.2 TVP5150 的配置 

TVP5150PBS 的配置是通过标准的 IIC 总线来完成的。TVP5150PBS 的 IIC 标准总线

是由串行数据输入／输出线（SDA）和时钟输入／输出线（SCL）组成的。TVP5150 只做

为从设备，不能做为主设备。 IIC 总线的数据传送速率最高可达 400Kbits/s。在

SEED-VPM642 中我们采用 100kbits/s 的速率进行对 TVP5150 的配置。 

详细的寄存器说明用户参阅文档 TVP5150PBS 中关于这部分的描述。 

3.2.2.1 TVP5150 配置的写 

TMS320DM642 做为一个 IIC 总线的主设备初始化 TVP5150 配置的写操作时，按如下

程式进行： 

  DSP 产生一个起始条件； 
  DSP 发出一个 TVP5150 的地址（0xBA 或 0xB8），并标明写操作，等待 TVP5150

响应； 
  接收到 TVP5150 的响应后，DSP 发出要配置寄存器的地址，等待 TVP5150 响应； 
  接收到 TVP5150 的响应后，发送要配置的数据，等待 TVP5150 响应； 
  接收到 TVP5150 的响应后，发送停止位，结束一次配置。 

整个写的过程列表如下： 
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 在进行配置寄存器（0x00～8F）时，TVP5150 需要一段延时来完成当前的配置，此时

TVP5150 保持 SCL 为低，通知 DSP 配置尚未完成。在编程时，一般不用查询当前的 SCL
的状态，而是延时配置需要的最大延时 64us。示例如下： 

 

3.2.2.2 TVP5150 状态的读 

当 TMS320DM642 要读取当前 TVP5150 的状态时，需通过 IIC 总线启动对 TVP5150
的寄存器的一个读操作。读操作分两部分进行，说明如下： 

  由 DSP 向 TVP5150 写入要读取的寄存器的地址； 
  由 DSP 向 TVP5150 发送读取寄存器数据的命令。 

整个过程列表如下： 
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3.2.2.3 DSP与TVP5150 配置连接 

TVP5150 作为 IIC 总线的从设备，最多可配置为 2 个不同的从设备地址，一条 IIC 总线

只能同时访问 2 个 TVP5150 配置口，而 SEED-VPM642 模板上有 4 个 TVP5150，所以用

总线切换的方法将 IIC 分成二组，如下图所示： 
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由上图可见，’DM642 用通用 I/O 口 GP0[0]来控制 IIC 总线的切换，GP0[0]为“0”时，

选通第 1 和第 2 通道 TVP5150，而 GP0[0]为“1”时，则选通第 3 和第 4 通道 TVP5150。
每个通道的 TVP5150 的 IIC 总线从设备地址如图所示。 

3.2.3 DSP与TVP5150 数字视频流的连接 

TMS320DM642 支持 BT.656 格式的视频数据流的输入格式，能与 TVP5150 的视频数

据流进行无缝连接。TMS320DM642 共有三个 VP 端口，最多可以支持 6 路 8-位 BT.656
数字视频接口。在 SEED-VPM642 模板上用其中的四路来支持视频输入，余下的 2 路选择

McASP 功能，实现四路的音频输入／输出（关于音频部分详见第四章）。VP 端口具体的

配置如下： 

  VP0 的 A 通道与第 1 通路的 TVP5150（U20）相连接； 
注：此 A 通道同时与 SAA7121H 相连接（参看有关 SAA7121H 的说明）。 

  VP1 的 A 通道与第 2 通路的 TVP5150（U21）相连接； 
注：VP0 的 B 通道与 VP1 的 B 通道合起来做 McASP 功能（参看第四章）。 

  VP2 的 A 部与第 3 通路的 TVP5150（U22）相连接； 
  VP2 的 B 部与第 4 通路的 TVP5150（U23）相连接； 

其原理框图如下所示： 
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 由上图可见，TVP5150 的 GPCL 引脚用来作 VP 口的 CAPEN，来控制视频数据流的

采集。当 GPCL 为“1”时，允许 VP 口对输入的视频数据流进行采集；GPCL 为“0”时，

则禁止 VP 口对输入的视频数据流进行采集。 

GPCL 状态可以通过对 TVP5150 的 Miscellaneous Control Register 寄存器（地址为

0x3）中的 GPCL 位进行设置来置“1”或清“0”。 

除了 VP0A 外，其余的 VP 端口均为单一的视频输入的功能。即在使用时将 VP 口设置

成为 Capture 模式。VP0A 在 SEED-VPM642 系统中，还与视频输出 SAA7121H 相连接，

因而 VP0A 需要工作在 Capture 与 Display 两种工作模式。关于 VP0A 如何实现这两种工作

模式的切换，将在 SAA7121H 的说明中作详细的描述。 

3.3 SAA7121H 

视频编码器 SAA7121H 支持 PAL 与 NTSC 格式的视频编码。其输入支持 BT.656 格式

的数字视频。SAA7121H 有 1 路复合视频（CVBS）输出和 1 路超级视频（S-Video，Y/C）

输出。在 SEED-VPM642 模板上复合视频（CVBS）输出由连接器 J2 引出，超级视频输出

由连接器 J7（S 端子）引出。其视频信号输出电路如下图所示： 
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3.3.1 SAA7121H的配置 

SAA7121H 的配置是通过标准的 IIC 总线来完成的。SAA7121H 的 IIC 总线只支持 7-
位地址的格式，并只能做为从设备。它支持寄存器的地址自动加一的功能。其数据交换的最

高速度为 400kbits/s。除了可读的状态寄存器外，其它的寄存器只写。其读写的数据格式如

下图： 

 

每一个 SAA7121H 根据 SA 管脚的状态可以配置 IIC 的地址，说明如下： 

  当 SA 为高时，其地址为 0x8C； 
  当 SA 为低时，其地址为 0x88；。 

SEED-VPM642模板上将SAA7121H的 IIC从设备地址配置为0x88，并将其接口到 IIC1
（见 3.2.2.3 章节的说明）上。在配置时需按如下步骤进行： 

1. GPEN 寄存器的 GP0EN 置“1”使能 GP0[0]；GPDIR 寄存器的 GP0DIR 置“1”
将 GP0[0]配置为输出；GPVAL 寄存器的 GP0VAL 清“0”使 GP0[0]输出低电平； 

2. 按上图格式将 TMS320DM642 的 IIC 设为 7-位格式，并初始化； 
3. 进行寄存器的读写。 

3.3.2 DSP与SAA7121H的数据口连接 

TMS320DM642 的 VP 口支持 BT.656 格式的数字视频流的显示功能，能与 SAA7121H
的数据口进行无缝连接。在 SEED-VPM642 模板上，四个 VP 口已经均被 TVP5150 所使用，

因此，SAA7121H 只能与其中的一 TVP5150 复用一个 VP 端口了，这里我们选择的是 VP0A
端口。TVP5150（U20）、SAA7121H 与 VP0A 的连接原理如下图： 
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从原理框图上可以看出，VP0A 即要做视频输入口，也要支持视频输出口，但这两种工

作模式不能同时使用，下面将这两种情况下做详细说明。 

当 VP0A 做为 8-位的 BT.656 视频采集口时，仅需视频数据流串行时钟和采集使能控制

信号，串行数据流串行时钟由 TVP5150 的 SCLK，采集使能控制信号则由 TVP5150PBS
的 INTREQ/GPCL/VBLK 引脚配置为通用输出引脚来控制。此时 SAA7121H 不起作用。 

当 VP0A 做为 8-位的 BT.656 视频显示口时，SAA7121H 需要 HSYNC（行同步信号）、

VSYNC（场同步信号）、LLC（27MHz 的行锁存号）。这三个信号均由 VP0A 进行提供。

分别说明如下： 

  LCC 信号是由 VPO_CLK1 提供的，其输入由 TVP5150（U20）的 SCLK 输出提

供。那 SCLK 既作为视频输入时钟信号，也作为视频输出时钟信号，还作为音频

主时钟的锁相输入。所以，为了视频输出和音频采集能正常工作，第 1 路视频输

入，必须保证有信号，而且 SCLK 必须总是配置为输出有效。 
  HSYNC 信号是由 VP0CTL0 提供，连接到 RC2。但此时这个管脚也连接了

TVP5150的 INTREQ/GPCL/VBLK引脚，因此，TVP5150的 INTREQ/GPCL/VBLK
引脚配置为输入。（操作寄存器 Miscellaneous Control Register） 

  VSYNC 信号是由 VP0CTL1 提供的，连接到 RC1。此管脚不复用。 

此时的 VP0D[9:2]处于输出状态，会与 TVP5150 的 Yout[7:0]产生总线冲突，因此

TVP5150APBS 的数据总线 YOUT[7:0]通过杂项控制寄存器（Miscellaneous Control 
Register）的 Bit3 控制位配置为高阻状态。  
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第 4 章 

音频输入与输出 

SEED-VPM642 采用 4 片 TLV320AIC23B 实现 4 路立体声音频的输入／输出，

TLV320AIC23B 是一种音频 Codec 器件，他的基本功能为：48KHz 带宽、96KHz 采样率，

双声道立体声 A/D、D/A，音频输入包括：麦克风输入（提供麦克风偏置输出和前置放大器）

和立体声输入（提供可编程放大器），音频输出包括：立体声输出（提供耳机功率放大器，

能提供 30mW 输出功率，驱动 32Ω负载）。 

TLC320AIC23B 与微处理器的接口有二个，一个是控制口，用于设置 TLV320AIC23B
的工作参数，另一个是数据口，用于传输 TLV320AIC23B 的 A/D、D/A 数据。在

SEED-VPM642 模板上，使用 DSP 的 IIC 总线进行 TLC320AIC23B 的配置，利用 DSP 的

McASP 与 4 片 TLC320AIC23B 进行数据的交换。 

4.1 TMS320DM642 的McASP接口 

TMS320DM642 的 Multichannel Audio Serial Port（McASP）主要应用在多通路的音

频处理中，McASP 数据的接收与发送两个部分，这两部分可以进行同步操作，也可以完全

独立的进行工作。 

McASP 主要包括以下几组功能引脚： 

  位时钟：ACLKX，ACLKR 
  帧同步：AFSX，AFSR 
  高频主时钟：AHCLKX，AHCLKR 
  数据的接收与发送：AXR[7:0] 
  静音输入与输出：AMUTEIN，AMUTE 

McASP 同步串行通信协议简单说明如下： 

  McASP 串行数据流起始时刻称为帧同步事件。帧同步事件由位时钟采样帧同步信

号给出。 
  McASP 串行数据流长度：串行传输的数据流位数达到设定的长度后，结束本次传

输，等下一个帧同步信号达到，再发起另一次串行传输。 
  McASP 串行数据流传输速度：即每一个串行位的持续时间，由位时钟决定。 
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  McASP 帧同步事件与何时采样与输出串行数据位流，即 AFSR（FSX）、ACLKR
（CLKX）、AXR[7:0]三者之间的关系。确定 McASP 可支持的外部器件的协议，

主要有以下三种： 
 I2S 数据格式，及相似的位-流格式； 
 从 2 到 32 通路的 TDM 格式的数据流； 
 S/P DIF、IEC60958-1、AES-3 格式。 

McASP 的基本框图如下所示： 

 

更加详细的说明请参看文档：TMS320C6000 DSP Multichannel Audio Serial Port 
(McASP) Reference Guide （文献号 SPRU041）。 

在 SEED-VPM642 系统中，McASP 将同时接入 4 路音频输入与 4 路音频输出。其协

议采用 Burst Frame Sync Mode。 
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4.2 TLV320AIC23B 

TLV320AIC23B（以下简称 AIC23B）是 TI 推出的一款高性能的立体声音频 Codec 芯

片，内置耳机输出放大器，支持 MIC 和 LINE IN 两种输入方式（二选一），并且输入和输

出都具有可编程增益调节。AIC23B 的模数转换（ADC）和数模转换（DAC）部件高度集成

在芯片内部，采用了先进的 Sigma－delta 过采样技术，可以在 8K 到 96K 采样率范围内提

供 16-位、20-位、24-位和 32-位采样，ADC 和 DAC 的信噪比分别可以达到 90dB 和 100dB。
同时，AIC23B 还具有很低的能耗，回放模式下功率仅为 23mW，省电模式下更是小于 15uW。

AIC23B 的管脚和内部结构框图如下： 
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4.3 TLV320AIC23B与’DM642 的接口 

TLV320AIC23B 与微处理器的接口有二个，一个是控制口，用于设置 TLV320AIC23B
的工作参数，另一个是数据口，用于传输 TLV320AIC23B 的 A/D、D/A 数据。SEED-VPM642
模板上将 TMS320DM642 的 McASP 配置成 Burst Frame Sync Mode 方式，与 4 片的

TLV320AIC23B 的数据口接口；使用 IIC 总线与 TLV320AIC23B 的控制口接口。 

4.3.1 AIC23B的数据口 

TLV320AIC23B 的数据口有四种工作方式，分别为： 

  Right justified 
  Left justified 
  IIS Mode 
  DSP Mode 

其中后两种可以很方便的与 DSP 的 McBSP 串口相连接。下面我们以 DSP Mode 模式

来说明数据口的连接。其硬件上的管脚说明如下： 

  BCLK：数据口位-时钟信号，当 AIC23B 为从模式时（通常情况），该时钟由 DSP
产生；AIC23B 为主模式时，该时钟由 AIC23B 产生； 

  LRCIN：数据口 DAC 输出的帧同步信号（IIS 模式下左／右声道时钟） 
  LRCOUT：数据口 ADC 输入的帧同步信号  
  DIN：数据口 DAC 输出的串行数据输入 
  DOUT：数据口 ADC 输入的串行数据输出  

这部分可以和’DM642 的 McASP 接口无缝连接，可以方便的实现主模式与从模式两种

工作方式。当 McASP 为从模式时，McASP 的接收时钟与帧同频信号都由 AIC23B 来提供；

当 McSP 为主模式时，McASP 产生所有的信号。连接示意图如下：  



 31

 

 从上图可以看出，McASP 是如何与四片 TLC320AIC23B 进行连接的。描述如下： 

  第一通路（U25）的输入与输出与 McASP 的 AXR[1:0]连接，其中 AXR1 为数据输

入，AXR0 为数据输出； 
  第二通路（U28）的输入与输出与 McASP 的 AXR[3:2]连接，其中 AXR3 为数据输

入，AXR2 为数据输出； 
  第三通路（U26）的输入与输出与 McASP 的 AXR[5:4]连接，其中 AXR5 为数据输

入，AXR4 为数据输出； 
  第四通路（U27）的输入与输出与 McASP 的 AXR[7:6]连接，其中 AXR7 为数据输

入，AXR6 为数据输出； 
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  四个通路的帧同步信号、发送与接收时钟均是共用的。因而，当 McASP 工作在从

模式时，只能有且只能有一片 AIC23B 工作在主模式，其它三片工作在从模式。

当 McASP 工作在主模式时，其发送与接收模块的时钟中，须有一个选择为外部

方式，一般选择发送时钟为 McASP 产生，接收时钟为外部（即 ACLKX）。 

‘DM642 与 AIC23B 的数据交换的协议可以采用 DSP 模式与 IIS 模式，区别仅在于 DSP
的 McBSP 帧同步信号的宽度。后者的帧同步信号宽度必须为一个字（16 位）长，而前者

的帧宽度可以为一个位长，比如在字长 16 位（即左右声道的采样各为 16 位），帧长为 32
位的情况下，如果采用 IIS，帧同步信号宽度应为 16 位；而采用 DSP Mode 帧信号宽度 1
位即可。在 SEED-VPM642 系统中采用 DSP 模式与 McASP 相连接。其时序如下图： 

 

4.3.2 AIC23B的控制口 

TLV320AIC23B 的控制接口有两种工作方式，分别为： 

  2 线制的 IIC 方式（MODE 为低）； 
  3 线制的 SPI 方式（MODE 为高）。 

在 SEED-VPM642 模板上采用 IIC 方式控制 TLV320AIC23B。其硬件管脚的说明如下： 

  SDIN：AIC23B 控制口串行数据输入； 
  SCLK：AIC23B 控制口的位-时钟； 

当使用 IIC 总线对 AIC23B 进行配置时，IIC 总线选择 7 位地址的寻址方式，并由于

AIC23B 的寄存器只有写操做无读操作，因而，其通讯协议为每个 WORD 的前 7-Bit 为寄存

器地址，后 9-Bit 为寄存器内容。其时序如下图所示： 



 33

 

每个 AIC23B 只有两个不同的 IIC 总线从设备地址 0x1A（CS 为低）与 0x1B（CS 为

高）可供选择。因而一个 IIC 总线只能配置 2 个 AIC23B。在 SEED-VPM642 中，我们采用

将 DM642 的 IIC 总线切换成两路 IIC 总线（IIC0 与 IIC1）的方法实现对四片 AIC23B 的配

置，每一路 IIC 总线上可以连接 2 个 AIC23B。其硬件连接原理如下图： 

 

AIC23B 的控制寄存器见下表： 

地址 需要初始化的寄存器 
0000000 左声道的音量控制寄存器 
0000001 右声道的音量控制寄存器 
0000010 左声道耳机的音量控制寄存器 
0000011 右声道耳机的音量控制寄存器 
0000100 模拟音频的路径控制寄存器 
0000101 数字音频的路径控制寄存器 
0000110 省电方式控制寄存器 
0000111 数字音频的接口格式寄存器 
0001000 采样率的设置寄存器 
0001001 数字接口设置寄存器 
0001111 复位寄存器 
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4.3.3 TLC320AIC23B的位时钟实现 

在 SEED-VPM642 系统中，音频的采集与图像的采集、音频的播放与图像的播放必须

保持同步。因而 4 片 AIC23B 的时钟输入是由第一片视频解码器 TVP5150 的 SCLK 经过

PLL1708 经过适当分频后的 SCLKO3（384fs）提供。另外为了保证获得合适的位时钟与帧

同步信号配合，AHCLKx 与 AHCLKr 分别与 PLL1708 的 SCKO2（256fs）连接。其原理图

如下所示： 

 

 从图中可以看出，PLL1708 是一可编程的锁相环，将 TVP5150 的 27MHz 的时钟输出

做为输入，从而保证了图像与音频的同步；其可以分频出： 

  SCKO1 输出可编程的 768fs、512fs、384fs、256fs（fs = 48KHz，倍频系数可编

程）时钟，SEED-VPM642 系统未用； 
  SCKO2 输出可编程的 256fs（fs = 16、22.05、24、32、44.1、48、64、88.2、

96KHz，音频采样率 fs 可编程）时钟，提供给 AIC23 的 MCLK； 
  SCKO3 输出可编程的 384fs（fs = 16、22.05、24、32、44.1、48、64、88.2、

96KHz，音频采样率 fs 可编程）时钟，提供给 AHCLKX(R)； 
  PLL1708 其它的时钟输出在 SEED-VPM642 系统中未使用。 

 PLL1708 输出时钟的可编程特性由串口和引脚设置，用于编程的串口有 3 个信号，MC
（位-时钟）、MD（数据位）和 MS（片选信号），这 3 个信号在 VPM642 中由 CPLD 产

生，PLL1708还有一个编程引脚CSEL，其与串行控制数据中的CFG1位一起来选择SCKO1
的输出频率。下图说明 MC/MP/MS 控制由 CPLD 的寄存器 AUDIOPLL（地址为 0x9008 
0013）产生，其说明如下： 

地址：0x9008 0013（只写） 

D07 D06 D05 D04 D03 D02 D01 D00 
× × × × × MD MC MS 
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MD： PLL1708 串行配置的数据位； 
MC： PLL1708 串行配置的位-时钟； 
MS： PLL1708 串行配置的片选信号。 

在进行 PLL1708 编程时，用户可在 TMS320DM642 定时器的驱动下使 MC/MP/MS 产

生如下的逻辑即可完成对 PLL1708 的编程（注意数据是在上升沿保持有效）： 

 

在 PLL1708 中总其有两个寄存器： 

  Mode Register：用于控制各个时钟的使能及采样率的设置； 
MD 每位代表的含义如下： 

 

CE6： MCKO2 输出使能／禁止控制 
0： MCKO2 输出禁止 
1： MCKO2 输出使能（缺省） 

CE5： MCKO1 输出使能／禁止控制 
0： MCKO1 输出禁止 
1： MCKO1 输出使能（缺省） 

CE4： SCKO1 输出使能／禁止控制 
0： SCKO1 输出禁止 
1： SCKO1 输出使能（缺省） 

CE3： SCKO3 输出使能／禁止控制 
0： SCKO3 输出禁止 
1： SCKO3 输出使能（缺省） 

CE2： SCKO2 输出使能／禁止控制 
0： SCKO2 输出禁止 
1： SCKO2 输出使能（缺省） 

CE1： SCKO0 输出使能／禁止控制 
0： SCKO0 输出禁止 
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1： SCKO0 输出使能（缺省） 

SR[2:1]： 音频采样率分频选择 
00： ×1（缺省） 
01： ×2 
10： ×1/2 
11： 保留 

FS[2:1]： 音频采样率 fs 的选择 
00： 48KHz（缺省） 
01： 44.1KHz 
10： 32KHz 
11： 保留 

 
  Configuration Register：与 CSEL 组合，选择 SCKO1 的输出。每位代表的含义如

下： 

 

CFG1： SCKO1 配置 
0： SCKO1 输出频率为 768fs 或 512fs（fs = 48KHz）（缺省） 
1： SCKO1 输出频率为 384fs 或 256fs（fs = 48KHz） 

CFG1、CSEL：  SCKO1 配置 

00： 768fs 
01： 512fs 
10： 384fs 
11： 256fs 
 

在 SEED-VPM642 中 SCKO1 未用。 

4.4 TLV320AIC23B的模拟接口 

TLV320AIC23B 的模拟接口主要包括以下两个部分： 

  立体声输入与 MIC 输入； 
  立体声输出。 
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4.4.1 立体声输入与麦克风输入 

立体声输入口包括左右声道的输入，其管脚为 ： 

  LLINEIN：左声道 LINE IN 输入 ； 
  RLINEIN：右声道 LINE IN 输入。 

麦克风输入主要是用来通过无源的麦克进行现场声音的采集。其中由于麦克是无源元器

件，所以要为其提供偏置电源。其主要管脚如下： 

  MICBIAS：提供麦克风偏压，通常是 3/4 AVDD ； 
  MICIN：麦克风输入，由 AIC 结构框图可以看出放大器默认是 5 倍增益 

SEED-VPM642 中的音频输入的连接示意图如下： 

 

 从上图可以看出在 SEED-VPM642 中 LINE_IN 与 MIC_IN 是不能同时使用的，每次只

能使用其中的一种功能。其切换是由两个电阻完成的。以上图为例： 

  当 R53 焊接，R54 不焊时，使用 MIC_IN 功能，此时 LINEINR 未用，也没有连接。 
  当 R53 不焊，R54 焊接时，使用 LINE_IN 功能。 

在 SEED-VPM642 上共有四路电路完全相同的音频输入前端，它们的配置如下所示： 

  第一通路（U25）： 
 当 R53 焊接，R54 不焊时，使用 MIC_IN 功能； 
 当 R53 不焊，R54 焊接时，使用 LINE_IN 功能。 

  第二通路（U28）： 
 当 R65 焊接，R66 不焊时，使用 MIC_IN 功能； 
 当 R65 不焊，R66 焊接时，使用 LINE_IN 功能。 

  第三通路（U26）： 
 当 R78 焊接，R79 不焊时，使用 MIC_IN 功能； 
 当 R78 不焊，R79 焊接时，使用 LINE_IN 功能。 

  第四通路（U27）： 
 当 R91 焊接，R92 不焊时，使用 MIC_IN 功能； 
 当 R91 不焊，R92 焊接时，使用 LINE_IN 功能。 
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在 SEED-VPM642 中，默认情况下音频的输入将配置成为 LINE_IN 功能。 

4.4.2 立体声与耳机输出 

AIC23B 总共有两种输出方式： 

  立体声输出，其管脚为： 
 LOUT：左声道输出； 
 ROUT：右声道输出。 

  耳机输出，可以直接驱动 32Ω的耳机，不需要外部再进行功率驱动了。其输出管

脚为： 
 LHPOUT：左声道耳机放大输出； 
 RHPOUT：右声道耳机放大输出。 

在 SEED-VPM642 中采用标准的立体声输出，从 AIC23B 框图可以看出，LOUT 和

ROUT 没有经过内部放大器，是标准的 AC97 的接口，共连接示意图如下：  
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第 5 章 

UART & 数字I／O接口 

在 SEED-VPM642 上配置有二个通用异步串口，接口标准可由软件配置为 RS232／
RS422／RS485，它可以用于控制云台或与其它设备通讯。 

在 SEED-VPM642 上还配置有一定数量的数字 I／O 口线，用于系统报警和状态指示。 

5.1 数字I／O 

在 SEED-VPM642 模板上配置有 8-位数字量输入，8-位数字量输出，对应的输入／输

出口如下所示： 

  数字量输入口： 
SEED-VPM642 模板上数字量输入口映射到’DM642 存贮空间的 0x9008 0010，是
一个 8-位只读寄存器 DINR，该寄存器位域定义如下： 

地址：0x9008 0010（只读） 

D07 D06 D05 D04 D03 D02 D01 D00 
DIN7 DIN6 DIN5 DIN4 DIN3 DIN2 DIN1 DIN0 

DIN[i]： 连接器 J1 上的 DI[i]（i = 0、1、……、7）信号的当前状态 
 0： DI[i]当前状态为低电平； 

1：     DI[i]当前状态为高电平。 

  数字量输出口： 
SEED-VPM642 模板上数字量输入口映射到’DM642 存贮空间的 0x9008 0010，是
一个 8-位只写寄存器 DOUTR，该寄存器位域定义如下： 

地址：0x9008 0010（只写） 

D07 D06 D05 D04 D03 D02 D01 D00 

DOUT7 DOUT6 DOUT5 DOUT4 DOUT3 DOUT2 DOUT1 DOUT0 
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DOUT [i]： 直接输出给连接器 J1 上的 DO[i]（i = 0、1、……、7）信号； 
 0： DO[i]当前输出为低电平； 

1：     DO[i]当前输出为高电平。 

5.2 TL16C752B 

SEED-VPM642 采用 TL16C752B 通用异步收发器 UART，其上包含二路相互独立的异

步收发器，接收和发送各带 64-字节 FIFO，并各自带有 Modem 接口信号。对于 RS232，
SEED-VPM642 板卡最高传输率可达 1Mbaud；对于 RS422/RS485，SEED-VPM642 板卡

最高传输率可达 1.92Mbaud。 

5.2.1 TL16C752BPT与DSP的连接 

TL16C752B 采用 8-位异步并行存储器接口，并采用+3.3V 电源供电，可以与

TMS320DM642 的外部存储器接口（EMIFA）直接连接。TL16C752B 每个通道包含 18 个

寄存器，通过地址 A2～A0 及寄存器位对它们进行寻址，A、B 二通道分别由片选信号选通。

SEED-VPM642 将 TL16C752B 配置在 TMS320DM642 的 CE1 空间，A、B 二个通道所占

的地址范围如下： 

 地址 
UART A 0x9008 0000～0x9008 0007 
UART B 0x9008 0008～0x9008 000F 

另外，TL16C752B 还提供二个中断请求信号 INTA、INTB 分别用于通道 A 和 B 申请

TMS320DM642 的中断。在 SEED-VPM642 中，INTA 和 INTB 相与，复用 TMS320DM642
的 INT5。 

5.2.2 UART的寄存器说明 

TL16C752B 每个通道均有 18 个寄存器，用于控制串行异步通信的工作方式，以及反

馈相应的状态，这些寄存器总结如下： 

A2 A1 A0 读方式 写方式 
0 0 0 接收保持寄存器（RHR） 发送保持寄器（THR） 
0 0 1 中断使能寄存器（IER） 中断使能寄存器（IER） 
0 1 0 中断标志寄存器（IIR） FIFO 控制寄存器（FCR） 
0 1 1 线路控制寄存器（LCR） 线路控制寄存器（LCR） 
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1 0 0 MODEM 控制寄存器（MCR） MODEM 控制寄存器（MCR） 
1 0 1 线路状态寄存器（LSR）  
1 1 0 MODEM 状态寄存器（MSR）  
1 1 1 暂存寄存器（SRP） 暂存寄存器（SRP） 
0 0 0 低位除数寄存器（DLL） 低位除数寄存器（DLL） 
0 0 1 高位除数寄存器（DLH） 高位除数寄存器（DLH） 
0 1 0 增强功能寄存器（EFR） 增强功能寄存器（EFR） 
1 0 0 Xon-1 word Xon-1 word 
1 0 1 Xon-2 word Xon-2 word 
1 1 0 Xoff-1 word Xoff-1 word 
1 1 1 Xoff-2 word Xoff-2 word 
1 1 0 发送控制寄存器（TCR） 发送控制寄存器（TCR） 
1 1 1 触发等级寄存器（TLR） 触发等级寄存器（TLR） 
1 1 1 FIFO 就绪寄存器  

黑体的部分的寄存器为二次寻址的寄存器。 

线路控制寄存器 

D7 D6 D5 D4 D3 D2 D1 D0 

DLAB BREAK SPB EPS PEN STB WL1 WL0 

WL1 WL0： 设置数据长度 
00 5 位 
01 6 位 
10 7 位 
11 8 位 

STB： 设置停止位个数 
0 1 个停止位 
1 1.5 个停止位（5 位数据长度时），2 个停止位（6、7、8 位数据长

度时） 

PEN： 奇偶校验使能 
0 奇偶校验无效 
1 奇偶校验有效 

EPS： 奇偶校验选择 
0 奇校验 
1 偶校验 

  SPB： 选择强制校验功能（如果 PEN=1） 
0 非强制校验 
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1 强制校验 
 如果此位置 1，并且 EPS＝0；在发送与接收的数据后置 1 
 如果此位置 1，并且 EPS＝1；在发送与接收的数据后置 0 

BREAK： 间隔控制位 
0 正常操作； 
1 强迫输出为低，以警告通讯中止 

DLAB： 寄存器访问选择 
0 访问其余寄存器 
1 访问除数和功能切换寄存器与 EFR 寄存器 

MODEM 控制寄存器 

D7 D6 D5 D4 D3 D2 D1 D0 
x1 or  
x1/4 
CLK 

TCR 
&TLR 

EN 

0\Xon 
Any 

LOOP IRQE FRE RTS DTR 

DTR： 数据终端准备好信号 
0 管脚 DTR 输出为低 
1 管脚 DTR 输出为高 

RTS： 发送请求信号 
0 管脚 RTS 输出为低 
1 管脚 RTS 输出为高：  

FRE： FIFO 的 Rdy 使能信号 
0 禁止 FIFO 的 Rdy 
1 使能 FIFO 的 Rdy 

IRQE： 中断管脚使能及 OP 脚管的输出 
0 中断管脚 INTA、INTB 为三态，OP 输出为低 
1 中断管脚 INTA、INTB 使能，OP 输出为高 

LOOP： 自闭环 
0 正常工作方式 
1 自闭环工作方式，用于串口自检 

0\Xon any： 此位仅在 EFR[4]置 1 时有效 
0 禁止 Xon any 功能 
1 使能 Xon any 功能 

TCR&TLR EN： 此位仅在 EFR[4]置 1 时有效；使能 TCR 和 TLR 寄存器 
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0 无操作 
1 使能 TCR 和 TLR 寄存器 

x1 or x1/4 CLK： 此位仅在 EFR[4]置 1 时有效； 
0 时钟输入除 1 
1 时钟输入除 4 

复位时，MODEM 控制寄存器清零。 

中断使能寄存器 

D7 D6 D5 D4 D3 D2 D1 D0 
0\CTS 

interrupt 
0\RTS 

interrupt 
0\Xoff 
sleep 

0\X 
Sleep EMSI ELSI ETHREI ERDAI 

ERDAI： 接收中断使能 
1 接收中断使能 
0 接收中断禁止 

ETHREI： 发送中断使能 
1 发送中断使能 
0 发送中断禁止 

ELSI： 接收错误中断使能 
1 接收错误中断使能 
0 接收错误中断禁止 

EMSI： MODEM 中断使能 
1 MODEM 中断使能 
0 MODEM 中断禁止 

0\X Sleep： 此位仅在 EFR[4]置 1 时有效 
1 使能省电模式 
0 禁止省电模式 

0\Xoff sleep： 此位仅在 EFR[4]置 1 时有效 
1 使能 Xoff 中断 
0 禁止 Xoff 中断 

0\RTS interrupt： 此位仅在 EFR[4]置 1 时有效 
1 使能 RTS 中断 
0 禁止 RTS 中断 

0\CTS interrupt： 此位仅在 EFR[4]置 1 时有效 
1 使能 CTS 中断 
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0 禁止 CTS 中断 

中断标志寄存器 

D7 D6 D5 D4 D3 D2 D1 D0 

FCR(0) FCR(0) 0\CTS,RTS 0\Xoff INTC2 INTC1 INTC0 INTS 

INTS： 中断状态位 
0 有中断 
1 无中断 

INTC[2:0]： 中断编码，见下表 

0\Xoff： Xoff 或特殊字符被检测到的中断状态 

0\CTS,RTS： CTS 与 RTS 从低变高的状态。 

FCR(0)： FCR[0]的内容的镜像。 

TL16C752B 中有 7 个中断源，它们分别是：接收错误中断；接收中断；FFIO 超时中

断；发送中断；MODEM 中断；Xoff 或特殊字符被检测到的中断；CTS 与 RTS 从低变高的

状态中断；这 7 个中断有相应的优先级。中断标志寄存器功能如下表： 

中断标志寄存器 中 断 设 置 与 清 除 
D5 D4 D3 D2 D1 D0 中断优先级 中断类型 中断源 中断清除 
0 0 0 0 0 1 － 无中断 无中断  

0 0 0 1 1 0 最高 接收错误
溢出、奇偶、帧错

误、间断 
溢出中断读线路状态寄

存器，其它的读接收FIFO

0 0 1 1 0 0 第二 接收超时
接收 FIFO 中有无

效数据 
读接收缓冲器 

0 0 0 1 0 0 第二 RHR 中断
接收缓冲器有数

据 
读接收缓冲器 

0 0 0 0 1 0 第三 发送 
发送寄存器空/发
送 FIFO 超过触发

设定 

读 IIR 或写发送保持寄存

器 

0 0 0 0 0 0 第四 MODEM MODEM 状态 读MODEM状态寄存器 

0 1 0 0 0 0 第五 Xoff 中断
接收到 Xoff 或特

殊字符 
接收Xon字符/读IIR 

1 0 0 0 0 0 第六 CTS,RTS
CTS 与 RTS 管脚

从低变高 
读IIR 
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5.2.3 波特率的设置 

TL16C752B 包含一个可编程的波特率寄存器，它可以在输入时钟的基础上进行分频（最

大分频数为 216 - 1），其计算公式如下： 

分频数 = 当前时钟输入（30.72MHz）/（比例系数 x 16  x 期望的波特率） 

其中比例系数为： 

当复位后，寄存器 MCR 的第 7 位设为 0 时，比例系数为 1（默认值） 

当复位后，寄存器 MCR 的第 7 位设为 1 时，比例系数为 4 

当时钟为 30.72MHz 时，常用波特率的设置如下： 

波特率 高位除数寄存器 DLM 低位除数寄存器 DLL 

1200 06H 40H 

2400 03H 20H 
4800 01H 90H 

9600 00H C8H 

19200 00H 64H 
38400 00H 32H 

5.3 异步串口接口电平 

采用 MAX3160 多协议收发器，使得异步串口接口电平可配置为 RS232／RS422／
RS485 多种接口电平标准。TL16C752B 的 Modem 信号没有完全引至串行接口上，只是在

RS232 接口标准时，采用 4 线制（RXD、TXD、RTS、CTS），而在 RS422／RS485 接

口标准时，采用 2 线制（RXD、TXD）。 

MAX3160 上的引脚 用于选择工作在 RS422/RS485 还是 RS232 接口标

准，引脚 HDPLX 则用于选择是 RS422 还是 RS485。它们受系统控制寄存器 0（SYSCNTL0）
的控制，其各位的定义如下： 

串口配置寄存器（UARTSET） 

地址：0x9008 0012，只写 

D07 D06 D05 D04 D03 D02 D01 D00 
× × × × FASTB FASTA
× × × × W-0 W-0 W-0 W-0 
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： 异步串口 0（COM 0）配置为 RS232 方式还是 RS422/RS485
方式 

0 选择 RS232 方式 
1 选择 RS422/RS485 方式 

： 异步串口 1（COM 1）配置为 RS232 方式还是 RS422/RS485
方式 

0 选择 RS232 方式 
1 选择 RS422/RS485 方式 

FASTA： 异步串口 1（COM 1）配置为全速还是慢速运行方式 
0 慢速运行方式 
1 快速运行方式 

FASTB： 异步串口 2（COM 2）配置为全速还是慢速运行方式 
0 慢速运行方式 
1 快速运行方式 

MAX3160 上的引脚 HDPLX 用于控制是否采用全双式模式，异步串口 COM 0 和 COM 
1 的 2 个 HDPLXA 和 HDPLXB 信号分别由 TL16C752B 的引脚 和 配置为输出来

控制，当 FAST 为 0 时，选用全双工模式；当 FAST 为 1 时，选用半双工模式。 

注 1：MAX3160 上的引脚 FAST 用于控制信号转换率。当 FAST 为 0 时，选用较低的

信号转换率，有利于 EMI 抑制；当 FAST 为 1 时，选用较高的信号转换率。 

注 2：在使用 RS485 方式时，一定注意，串行通讯是半双工的，发送与接收共用一对

绞线，发送时，亦同时在已方可接收到，所以发送时一定禁止接收操作。 

注 3：在使用 RS485/RS422 方式时，电阻 R155～R158 焊接 120 欧姆。 
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第 6 章 

PCI、HPI与以太网接口 

在 SEED-VPM642 系统中可以实现 PCI、HPI（16-位或 32-位）、以太网（EMAC+MDIO）

等三种接口。由于在 TMS320DM642 片上这三种外设复用同一组引脚，所以这三种功能除

了 HPI16 与以太网接口可以同时使用外，其它的配置不能同时使用的。SEED-VPM642 将

这三种接口设计成根据模板的安装情况自动进行配置。 

6.1 自动配置的实现 

SEED-VPM642 有下列三种可能的接口形式： 

  32-位 PCI 接口； 
  32-位 HPI 接口； 
  16-位 HPI + 以太网接口。 

SEED-VPM642 模板上采用自动检测来进行自动配置，利用 PCI 总线上 B3（GND）和

B10（保留）分别作为 EMAC_DETECT（上拉）和 HPI_DETECT（下拉）自动检测信号，

检测信号与接口之间的关系如下表所示： 

EMAC_DETECT
（B3） 

HPI_DETECT
（B10） 

接口 

1 0 HPI16 + 以太网接口 
0 0 32-位 PCI 
0 1 32-位 HPI 
1 1 × 

6.2 PCI总线接口 

当用户将 SEED-VPM642 模板插入计算机的 PCI 插槽中时，检测信号 EMAC_DETECT
接地为低电平，HPI_DETECT 下拉为低电平，自动配置成 32-位 PCI 总线，此时’DM642
的配置引脚状态如下： 
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  PCI_EN 为高，MAC_EN 为低，使能’DM642 的 PCI 功能； 
  PCIEEAI 为高，使能 EEPROM 的自动初始化功能； 
  PCI66 为高，使 DM642 的 PCI 总线工作在 33MHz。 

在上电复位后，TMS320DM642 将 PCI 端口按以上的初始条件使能，完成与计算机的

的配置。 

6.2.1 PCI简介 

TMS320DM642 的 PCI 总线由以下几个部分组成： 

  PCI 总线接口单元； 
  EEPROM 控制器； 
  DSP 作为 PCI 从设备时的写传输（PC→’DM642）单元； 
  DSP 作为 PCI 从设备时的读传输（PC←’DM642）单元； 
  DSP 作为 PCI 主设备时的数据传输单元； 
  PCI 的 I/O 接口； 
  DSP 寄存器接口。 

其原理框图如下所示： 
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 PCI 的主要功能如下： 
  支持 PCI2.2 的协议； 
  支持 4 线的 EEPROM 自动初始化功能； 
  支持 PCI 的主、从两种模式的总线传输，通过 EDMA 总线能完成以下四种读／写

方式： 
 从模式写传输，PC 机通过 PCI 总线写数据到’DM642 存储空间中； 
 从模式读传输，PC 机通过 PCI 总线从’DM642 存储空间中读数据； 
 主模式写传输，’DM642 通过 PCI 总线写数据到 PC 机存储空间； 
 主模式读传输，’DM642 通过 PCI 总线从 PC 机存储空间中读数据。 

关于 PCI 的详细的说明参看文档：TMS320C6000 DSP Ethernet Media Access 
Controller (EMAC)/ Management Data Input/Output (MDIO)Module Reference Guide
（文献号 SPRU628）。 

6.2.2 PCI的寄存器 

PCI 总线接口总共有三种寄存器： 

  PCI 配置寄存器，只能被外部的主 PCI 设备访问； 
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  PCI I/O 寄存器，只能被外部的主 PCI 设备访问； 
  PCI 存贮器映射的外设寄存器，可以被 DSP 与 PCI 的主机访问。 

6.2.2.1 配置寄存器 

配置寄存器包含了标准的 PCI 配置信息，包括 vendor ID、device ID、class code、
revision number 等等。这些寄存器的设置可以在上电时从 EEPROM 中被初始化。配置寄

存器的列表如下图： 

 

6.2.2.2 PCI I/O寄存器 

PCI 的 I/O 寄存器位于 PCI 主机端的 I/O 空间。它只能由主机端通过对 I/O 的基址 1 或

基址 2 访问。所有的 I/O 寄存器均为字节寻址的。当处理器不支持 I/O 寻址模式时，对内存

映射的基址 1 进行读写 PCI 的 I/O 寄存器。I/O 寄存器列表如下： 
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6.2.2.3 PCI存贮器映射的外设寄存器 

这些寄存器被映射到了 DSP 的空间内，使 DSP 可以控制与观察 PCI 接口的状态。这

些寄存器均可被 DSP 与 PCI 的主机端访问。列表如下： 
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6.2.3 PCI的初始化 

PCI 的初始化可以由两种方式完成，一为 TMS320DM642 按默认值完成初始化，另一

为通 EEPROM 完成 PCI 接口的初始化。在 SEED-VPM642 系统中是选用后者。 

在 SEED-VPM642 系统中，采用的是 93LC66B 做为自动初始化的 EERPOM，其接口

形式为 4 线的 SPI 方式，详细说明见下表： 
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PCI 的初始化的配置值在 EEPROM 内部位置的映射如下表： 

 

6.2.4 PCI内存的映射 

PCI 总线接口可以通过配置寄存器的二个基址寄存器访问到 DSP 所有的存贮区。这二

个寄存器为： 
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  基址 0（Base 0）寄存器：通过 DSPP（DSP 的页指针寄存器）可以以预取方式

访问所有的以 4M-字节为单位的 DSP 内存。这种映射使用在 DSP 做为一个从设

备的方式中，其地址组织方式如下图： 

 

  基址 1（Base 1）寄存器：使能一个不可预取的 8M-字节的 DSP 空间，其地址范

围为（0x18 0000～0x20 0000）。此空间在 TMS320DM642 中不存在，因此无法

使用此种寻址方式。 

在 SEED-VPM642 中，通过基址 0 完成 PCI 与 DSP 之间的空间映射与数据交换。PCI
总线接口均为字节寻址。 

6.3. HPI 

在 SEED-VPM642 系统中，HPI 接口与 PCI 总线复用引脚，HPI 接口借用 PCI 总线连

接器 J14。HPI 共有两种数据宽度，HPI16：16-位 HPI 和 HPI32：32-位 HPI，它们的读写

逻辑与时序均一致。其原理框图如下： 

 

关于HPI详细的操作，参看TMS320C6000 DSP Host Post Interface（HPI）Reference 
Guide（文献号 SPRU578）。 

当使用 SEED-VPM642 的 HPI 接口时，与 J14 连接的外部接口的 B3、B10 引脚应按

下表连接： 
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接口类型 B3 B10 
HPI16 悬空 悬空 
HPI32 GND +3.3V 

6.4 网络接口 

TMS320DM642 的网络接口由 EMAC（10/100 Mb/s Ethernet MAC）与 MDIO
（Management Data Input/Output）两部分组成的。其中 EMAC 为网路的数据通路，MDIO
为 EMAC 的状态及控制接口。 

6.4.1 网络接口的简介 

TMS320DM642 的网络接口主要用来支持物理层的网络器件（PHY）与 DSP 的连接。

其中 EMAC 控制 PHY 与 DSP 之间的数据包的交换，MDIO 控制 PHY 的配置与状态的监测。

网络接口主要功能有： 

  符合 IEEE 802.3 协议； 
  支持传媒无关接口（MII）； 
  8 个独立的发送与接收通路； 
  同步的 10 / 100Mbit 的数据操作； 
  广播及多帧的传送。 

TMS320DM642 的网络接口的原理框图如下： 
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 上图描述了 EMAC+MDIO 与 DSP 中间有一个 EMAC control module 模块。它主要包

含一些必备的使 EMAC 更加有效的使用 DSP 的存贮空间，控制其复位、中断的一些逻辑。

这些寄存器的地址空间为：0x1C80 0000～0x1c80 3FFF。 

更加详细的内容，参看文档：TMS320C6000 DSP Ethernet Media Access Controller 
(EMAC)/ Management Data Input/Output (MDIO)Module Reference Guide（文献号

SPRU628）。 

6.4.2 PHY设备的连接 

下图为 PHY 设备与网络接口的框图： 

 

在 SEED-VPM642 系统中用 Broadcom 公司的 BCM5221 作为 10/100Base-TX 以太网

收发器，BCM5221 的 MII 接口与 DM642 的 MII 接口对接。DM642 的 MII 不支持 TXER，

它通过求反发送帧 CRC 来指出网络错误，所以 BCM5221 上的 TXER 引脚直接接为无效。 

SEED-VPM642 中只采用 10/100Base-TX 方式，所以 BCM5221 的 SD+和 SD-引脚悬

空。而 TD+、TD-、RD+和 RD-信号则经 Pulse 公司的 H1102 1:1 变压器变换成 TX+、TX-、
RX+和 RX-信号，接口到 RJ45 连接器上。 

RJ45 连接器选用 AMP 公司的 406549-1，其上带 2 个 LED 指示灯，右边的 LED 为绿

色，用作指示连接状态，左边的为黄色，正常情况下，用来指示数据传输。 
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6.4.3 EMAC的数据包 

以太网络中，数据是以网络帧的方式进行传送的。其格式如下： 

 

 从上图可以看出一个 Ethernet Frame 包括以下几个部分： 

  Preamble：引导位； 
  SFD：分隔符； 
  Destination：目的地址； 
  Source：源地址； 
  Len 数据的长度； 
  Data：最长为 1500 个数据； 
  FCS：帧校验。 

其中加粗的部分称为以太网的数据包，在 EMAC 经过 EDMA 后得到的内容为以太网的

数据包，即粗框内的结构。因此，用户在编程时，不用关心粗框外的数据。 
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第 7 章 

ATA硬盘接口 

ATA（Advanced Technology Attachment），是一个流行的存储设备接口，被广泛应

用于 PC 机上，用于主机与硬盘、光盘和可移动储存设备等设备接口。在 SEED-VPM642
系中实现了 ATA 协议的 PIO4 方式，可以挂接硬盘等大容量的存贮设备，完成对图像与音

频的保存与检索。 

7.1   ATA的简介 

ATA 接口标准由 INCITS（ InterNational Committee on Information Technology 
Standards，国际信息技术标准化委员会）下属的 T13 技术委员会管理和制定。为主机与储

存设备实现连接定义一组标准化的总线，并规定了该总线的电气和机械特性，即 ATA 接口

标准的物理层。为主机与储存设备之间进行有效的数据交换定义一组传输和命令协议，即

ATA 接口的传输层。它是一 16-位并行总线，支持 PIO 和多字 DMA 传输协议。 

ATAPI（ATA Packet Interface）为 ATA 分组数据接口。它是在储存设备端增加的数据

分组交换协议，目的是为了有效地解决带复杂参数的命令的交换，以方便与各种储存设备相

连，如硬盘、光盘、可移动储存设备等等。 
  

ATA 总线连接的主机与存储设备之间的数据交换，其原理如下： 
  首先按 ATA 标准规定，对存储设备介质的读／写操作不是直接由主机通过 ATA 总

线完成，而是由集成在存储设备上的控制器完成，主机只是通过 ATA 总线与存储

设备上的控制器进行通信。对于主机来说，主机与存储设备控制器的通信是通过一

组标准化了的寄存器和数据口进行的，主机直接操作这组寄存器和数据口，将命令

参数和操作命令码写入寄存器中，而存储设备上的控制器则对这些命令参数和操作

命令码进行解释，完成对存储设备的实际读／写和控制操作。 
  其次 ATA 标准规定存储设备上的控制器必须实现一组标准化了的寄存器和数据

口，还规定了对这组寄存器和数据口进行操作的一组信号及其时序，即规定了 ATA
标准的物理层。 

  最后 ATA 标准规定存储设备上的控制器必须实现或可选实现的命令集，以及主机

与设备之间进行交互的命令序列的先后顺序和命令码及相应的命令参数的定义，即

ATA 标准的传输层。在 SEED-VPM642 系统中主要是针对此传输层编程。 
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7.2 ATA 硬盘接口的实现 

ATA 硬盘接口的实现，主要是指 ATA 标准的物理层的实现。即实现对物理层各个寄存

器的访问。主要包括两组寄存器： 

  命令块寄存器组（Command Block Registers） 
  控制块寄存器组（Control Block Registers） 

在 SEED-VPM642 系统中，这两组寄存器是通过 CPLD 进行地址译码后，产生各自的

片选信号（CS0 与 CS1）选通，并将之映射在 TMS320DM642 的存贮空间。地址分配如下

表所示： 

 字地址 
ATA_CS0 0xA000 0000～0xA000 001C 
ATA_CS1 0xA000 0020～0xA000 002C 

注：以上地址均是以外部存贮器为 32 位时的地址 

命令块寄存器组（Command Block Register），共有 10 个寄存器组成，其中 2 个只

读寄存器和 2 个只写寄存器，及 6 个读／写寄存器。由于只读和只写寄存器共用 1 个寻址

单元，所以共占 8 个寻址单元，由 CS0 进行片选。详细说明如下： 

状态寄存器（Status Register）： 
地址：0xA000 001C，只读 
作用：包含存储设备的当前状态信息 

7 6 5 4 3 2 1 0 
BSY DRDY DF × DRQ × × ERR 

  
 BSY：  指示设备是否外于空闲状态 
   0: 设备空闲； 
   1： 设备忙。 
 DRDY：  指示设备是否准备好 
   0: 设备未准备好； 
   1： 设备准备好。 
 DF：  指示设备是否出现故障 
   0: 设备未出现故障； 
   1： 设备出现故障。 
 DRQ：  指示设备是否准备开始在 DSP 与设备之间传送数据 
   0: 未准备好； 
   1： 准备好。 
 ERR：  指示设备是否出现错误 
   0: 设备未出现错误； 
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   1： 出现错误。 

命令寄存器（Command Register）： 
地址：0xA000 001C（只写） 
作用：包含命令码。当此寄存器被写时，存储设备控制器开始进行该命令的处理，此时，

某些命令块寄存器中的内容将被作为该命令的参数，而命令寄存器中的值则作为命令编码，

被存储设备控制器解释。 

 
 Command Code：命令代码。 

设备寄存器（Device Register）： 
地址：0xA000 0018（读／写） 
作用：该寄存器中包含一位 DEV 控制位，用于选择位于同一 ATA 总线上的 2 个存储

设备。 

 

 DEV：  选择设备 
   0: 选择设备 0 
   1： 选择设备 1 

LBA 高段寄存器（LBA High Register）： 
地址：0xA000 0014（读／写） 
作用：对存储设备介质的访问是通过 LBA（逻辑块地址）进行寻址，LBA 与实际存储

介质的对应关系由存储设备控制器进行解释。 

 
Data[7:0]：LBA 的高位地址。LBA 一般为 28-位，在可选的扩展时为 48-位。此寄存器

包含了 LBA 28-位地址中的 LBA[23:16]或 48-位地址中的 LBA[23:16]和 LBA[47:40]。在对

命令寄存器进行写操作时，此寄存器将作为其中的一个命令参数。 

LBA 中段寄存器（LBA Mid Register）： 
地址：0xA000 0010（读／写） 



 61

作用：对存储设备介质的访问是通过 LBA（逻辑块地址）进行寻址，LBA 与实际存储

介质的对应关系由存储设备控制器进行解释。 

 
Data[7:0]：LBA 的中间地址。LBA 一般为 28-位，在可选的扩展时为 48-位。此寄存器

包含了 LBA 28-位地址中的 LBA[15:8]或 48-位地址中的 LBA[15:8]和 LBA[39:32]。在对命令

寄存器进行写操作时，此寄存器将作为其中的一个命令参数。 

LBA 低段寄存器（LBA Low Register）： 
地址：0xA000 000C（读／写） 
作用：对存储设备介质的访问是通过 LBA（逻辑块地址）进行寻址，LBA 与实际存储

介质的对应关系由存储设备控制器进行解释。 

 
Data[7:0]：LBA 的低位地址。LBA 一般为 28-位，在可选的扩展时为 48-位。此寄存器

包含了 LBA 28-位地址中的 LBA[7:0]或 48-位地址中的 LBA[7:0]和 LBA[31:24]。在对命令寄

存器进行写操作时，此寄存器将作为其中的一个命令参数。 

扇区计数寄存器（Sector Count High Register）： 
地址：0xA000 0008（读／写） 
作用：用于保存被访问的存储介质的扇区号。 

 
Data[7:0]：存储介质的扇区号。在对命令寄存器进行写操作时，此寄存器将作为其中

的一个命令参数。 

错误寄存器（Error Register）： 
地址：0xA000 0004（只读） 
作用：包含命令执行以后的状态信息。 

 

特征寄存器（Feature Register）： 
地址：0xA000 0004（只写） 
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作用：在对命令寄存器进行写操作时，此寄存器将作为其中的一个命令参数。 

 
 Dayta[7:0]：在进行命令操作时，做为命令的一个参数。 

数据寄存器（Data Register）： 
地址：0xA000 0000111B（读／写） 
作用：在 PIO 传输方式时，作为数据传输口，这是一个 16-位的寄存器。 

 
 Data[7:0]： 传送数据的低 8 位； 
 Data[15:8]： 传送数据的高 8 位； 

控制块寄存器组（Control Block Registers）：共有 2 个寄存器，1 个为只读寄存器，

1 个为只写寄存器，只占 1 个寻址单元，有 CS1 进行片选。 

备用状态寄存器（Alternate Status Register）： 
地址：0xA000 0038（只读） 
作用：此寄存器包含命令块寄存器组中状态寄存器相同的信息。 
设备控制寄存器（Device Control Register）： 
地址：0xA000 0038（只写） 
作用： 对设备进行控制的寄存器。 

 

SRST： 对存储设备进行软件复位； 
        0：  无效操作； 

1：  设备复位。 
nIEN： 屏蔽该存储设备向主机申请中断； 
  0：  不对设备中断进行屏蔽； 

1： 对设备中断进行屏蔽。 
HOB： 用于选择 LBA 的地址为 48-位方式。 
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7.3   ATA数据的传送 

ATA 与 DSP 数据的传送可以 PIO 传输方式和 DMA 传输方式进行，在 SEED-VPM642
系统中，实现了 PIO（可以运行 PIO4 的协议）传输方式，而不能实现 DMA 的传送方式。

下面就 PIO 方式做简单说明。 

PIO 传输方式就是采用通用的异步存储器接口方式进行访问，即以主机为主设备，给出

读／写访问的数据总线、地址线、片选线和读／写控制信号，对相应的存储设备中的单元进

行访问。PIO 传输方式适用于主机对存储设备控制器寄存器的访问，由主机发命令给存储设

备或从存储设备上读取当前的状态信息，也可以通过数据寄存器进行真正意义上的存储数据

的交换。但 PIO 传输方式的效率相对较低。其主要操作为 Data Port 寄存器的读与写。 

PIO 方式传输时，使用到的协议如下： 

  DEVICE CONFIGURATION IDENTIFY 
  IDENTIFY DEVICE 
  IDENTIFY PACKET DEVICE 
  READ BUFFER 
  READ MULTIPLE 
  READ MULTIPLE EXT 
  READ SECTOR(S) 
  READ SECTOR(S) EXT 
  WRITE BUFFER 
  WRITE MULTIPLE 
  WRITE MULTIPLE EXT 
  WRITE SECTOR(S) 
  WRITE SECTOR(S) EXT 

关于以上协议的详细说明参看文档：ATA/ATAPI6.pdf 

7.4 ATA的设备的配置及连接 

ATA 标准要求，每个存储设备均应提供 3 种配置方法： 

  内部配置为设备 0（主设备 Master）； 
  内部配置为设备 1（从设备 Slave）； 
  由电缆来自动将连接在其上的存储设备配置为设备 0 或设备 1。 

当使用片选来进行设备的配置时，与 ATA 连接器的 CSEL 信号有关。由于 ATA 标准对

电缆的装配作了特殊的规定，连接主机与存储设备的电缆有 3 个插头，一头接主机；另一

头有2个插头，位于中间的插头CSEL信号与主机端插头的CSEL相连，而另一个插头CSEL
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信号则与主机端插头的 CSEL 断开，在主机端 CSEL 信号直接接地，在存储设备端 CSEL
信号用 10KΩ上拉，所以中间插头的 CSEL 由于与主机端相连，所以为 0，连接到此插头上

的设备如果选择为由电缆配置，则将被配置为设备 0。相反，另一个插头的 CSEL 由于与主

机端断开，所以被上拉为 1，连接到此插头上的设备如果选择为由电缆配置，则将被配置为

设备 1。在存储设备上有 3 个跳针选择，一个跳针选择由电缆配置，此时 CSEL 信号用 10K
Ω上拉；一个跳针直接接地，内部配置为设备 0；一个跳针直接接 3.3V，内部配置为设备 1。
如下图所示： 
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第 8 章 

实时时钟 

 SEED-VPM642 系统中配置有 X1226 实时时钟 ＋ 串行 EEPROM，可以产生年、月、

日、星期、时、分、秒等实时时间信息，还有 512×8-位的 EEPROM，可以用来存储存定

值。因而适合用于监控系统的记录。 

8.1 X1226 概述 

X1226 主实时时钟 RTC ＋ 串行 EEPROM，采用串行 IIC 总线与 DSP 连接，其原理

框图如下所示： 

 

8.1.1 IIC总线 

TMS320DM642 通过 IIC 总线对 X1226 进行操作，IIC 总线有 2 个信号 SDA 和 SCL，
其时序如下列各个图所示： 

SDA 信号线上数据变化时序如下图所示： 
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IIC 起始与结束时序如下图所示： 

 

IIC 确认时序如下图所示： 

 

8.1.2 X1226 的寻址 

通过 IIC 总线，TMS320DM642 可以访问 X1226 内部 2 个部分，一部分为 CCR（时钟、

控制器），别一部分为 EEPROM 的 512×8-位存储单元。这二部分被作为 2 个 IIC 总线从

设备对待，对应二个 IIC 从设备地址。CCR 包含 29 个 8-位寄存器，以 0x00～0x3F 地址进

行寻址；EEPROM 则有 512×8-位存储单元，以 0x000～0x1FF 地址进行寻址。X1226 的

寻址时序如下图所示： 
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 对 X1226 的读 / 写访问均有二种方式；单字节随机读写和多字节顺序读写。X1226 的

读写时序如下图所示： 

 单字节随机写操作时序如下图所示： 

 

 多字节顺序写操作时序如下图所示： 

 

 单字节随机读操作时序如下图所示： 
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 多字节顺序读操作时序如下： 

 

8.1.3 X1226 片内CCR寄存器的映射 

X1226 片内 CCR 寄存器的映射如下图所示： 



 69

 

8.2 TMS320DM642 与X1226 接口 

TMS320DM642 通过 IIC1 与 X1226 连接。其中 TMS320DM642 做为主设备，X1226
做主从设备。X1226 的两个部分使用两个不同的 IIC 地址，列表如下： 

  CCR 的 IIC 地址为：0x67； 
  Array 的 IIC 地址为：0x57。 
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第 9 章 

ESAM加密模块 

9.1 ESAM加密模块概述： 

为了更好地保护软件开发者的知识产权，SEED-VPM642 系统中采用嵌入式加密认证

模块 ESAM。ESAM 采用专用的智能卡芯片，芯片内集成有 TimeCOS 嵌入式安全操作系

统，除了具有防检测、抗攻击、自毁等硬件特性外，还具有安全的文件密钥管理，完善的安

全机制、标准的加密运算功能等特性。采用 ESAM 模块的加密认证功能，可以保护

SEED-VPM642 上的软件不被非法拷贝；每块 ESAM 模块，均有一个全球唯一的系列号，

用此系列号可以控制软件生产的数量，以防止无偿额外的生产；ESAM 模块上还有一定容

量的 EEPROM，可用来加密存储重要的数据或代码，进一步提高软件的安全性。ESAM 模

块典型的认证过程如下图所示： 

‘DM642 程序认证模块          
 
SEED-VPM642 模板 

ESAM 

软件： 

1．对 ESAM 做复位取得 ESAM 的 S/N 号 

2．计算分散密钥 CSK=DES（MK，S/N） 

软件： 

1．从 ESAM 中去随机数 RND 

2．将 RND 送回 ESAM 进行加密取认证码 X 

3．计算分散密钥 CSK 

4．对随机数 RND 加密计算认证码 Y 

软件判断 

Y=？X 

ESAM： 

用认证密钥 CSK 对随机数

RND 加密产生认证码 

X=DES（CSK，RND） 

应用软件正常执行 

应用软件 

拒绝执行 

S/N 

RND 

X 

No 

Yes 

ESAM 
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9.2 ESAM模块的硬件设计： 

ESAM 模块的外部接口为半双工的异步串口，接口电平为 TTL，ESAM 模块的半双工

通信协议如下： 

  Mark：“1” 
  起始位：“0” 
  8 位数据 
  1 位偶校验位 
  2 位保护位（Mark） 
  波特率：ESAM_CLK／372 
  当接收方检测到偶校验错误时，应在第 2 个保护位开始，插入至少 1 位，最多 2

位“0”。发送方检测到接收方报告的偶校验错误时，重发上一个数据。 

在 SEED-VPM642 系统中，ESAM 的连接如下： 

  输入时钟频率为 3.57MHz，所以通信波特率为 9600。 
  ESAM 的 I/O 管脚取反后连接到 TMS320DM642 的外部中断 4 
  ESAM 的 I/O 可供 ESAMCNTL 寄存器与 ESAMSTATUS 寄存器操作； 
  ESAM 的复位可供 ESAMCNTL 寄存器操作。 

用户可以使用 TMS320DM642 的一个定时器与外部中断 4 配合来操作 ESAMCNTL 寄

存器与 ESAMSTATUS 寄存器以完成对 ESAM 的控制与数据的通讯。这两个寄存器详细说

明如下： 

ESAM 控制寄存器（ESAMCNTL） 

地址：0x0x9008 0014（只写） 

D07 D06 D05 D04 D03 D02 D01 D00 
× × × × × RST TorR DO 

RST： ESAM 复位控制位。 
0 无复位产生； 
1 产生 ESAM 复位信号。 

TorR：         发送与接收控制位 
0 从 ESAM 的 I/O 管脚接收数据； 
1 向 ESAM 的 I/O 管脚发送数据。 

DO： 向输出 ESAM 的 I/O 管脚发送的电平。 
0 向 ESAM 的 I/O 管脚写 0； 
1 向 ESAM 的 I/O 管脚写 1。 
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ESAM 状态寄存器（ESAMSTATUS） 

地址：0x0x9008 0014（只读） 

D07 D06 D05 D04 D03 D02 D01 D00 
× × × × × × × DI 

DI：  ESAM 复位控制位。 
0 ESAM 的 I/O 管脚状态为低； 
1         ESAM 的 I/O 管脚状态为高。 

9.3 ESAM读写的实现 

通过上节所述的硬件连接，下面说明 ESAM 读与写的具体过程。 

9.3.1 ESAM的读 

ESAM 的读过程如下： 

1. 定时器的初始化，将定时器的周期定为 1/9600 的一半； 
2. 将 ESAMCNTL 的 TorR 置 0，为接收模式。 
3. 等待中断 4 产生； 
4. 中断 4 产生后，关闭中断 4，使定时器开始工作； 
5. 在第一个定时器周期完成之后从 ESAMSTATUS 的 DI（对映的 ESAM 的 I/O 管脚）

位读取一个数据位，以后按 9.2 所述的通讯协议，每两个定时周期读取

ESAMSTATUS 的 DI 数据位，直至读完一个字节的数据。 
6. 打开中断 4，等待 ESAM 发出下一个字节数据。 

9.3.2 ESAM的写 

ESAM 的写过程如下： 

1. 定时器的初始化，将定时器的周期定为 1/9600 的一半；并建立定时器的中断； 
2. 将 ESAMCNTL 的 TorR 位置 1，为发送模式。 
3. 在每隔一个定时器的中断，按 9.2 所述的协议将一个字节数据的每一位写到寄存器

ESAMCNTL 的 DO（即对应的是 ESAM 的 I/O 管脚）。 
4. 等待 3～4 个定时周期，按 3 发送下一个数据。 
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9.4 ESAM卡的复位及相关读／写时序： 

9.4.1 冷复位 

冷复位时序如下图所示，在 Ta 时刻给 ESAM 模块的 CLK 引脚加时钟信号，ESAM 模

块的 I/O 引脚在时钟信号加于 CLK 引脚后的 200 个时钟周期（ta）内被 ESAM 模块置于高

阻态 Z（ta 时间在 Ta 之后）。时钟加于 CLK 引脚后，保持 ESAM 模块 RST 引脚的状态

为 0 至少 400 周期（tb），才能复位 ESAM 模块（tb 在 Ta 之后）。 

 

在时刻 Tb，RST 引脚被置为“1”，I/O 引脚上的应答应在 RST 引脚的上升沿之后的

400～40000 个时钟周期（tc）内开始（tc 在 Tb 之后）。 

在 RST 引脚处于“1”的情况下，如果应答信号在 40000 个时钟周期内仍未开始，RST
引脚上的信号将返回到“0”，且 ESAM 模块的外部接口被释放。 

9.4.2 热复位 

热复位时序如下图所示，当 VCC 和 CLK 保持稳定时，’DM642 将 RST 清为“0”至少

400 时钟周期（时间 te）后，ESAM 模块被热复位。 

RST 

tcta 
未定义 

CLK 

I/O 

tb 

TbTa 
Ta ≤ 200/f 400/f ≤ tb 400/f ≤ tc ≤ 40000/f

应答

VCC 

VPP 
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在时刻 Td，RST 引脚置为“1”，I/O 引脚的应答在 RST 引脚上升沿之后的 400～40000
个时钟周期（tf）之前开始（时间 tf 在 Td 之后）。 

在 RST 引脚处于“1”，如果应答信号未在 40000 个周期之后开始，RST 引脚将返回

“0”，且 ESAM 模块的外部接口被释放。 

9.4.3 读写时序说明 

有关 ESAM 模块的其它物理参数及电气特性可参阅 ISO7816-123 中的相关内容。 

VCC 

VPP 

RST 

CLK 

I/O 

te

未定义 

td tf

应答 

Td ≤ 200/f 400/f ≤ te 400/f≤tf≤40000/f 
Tc Td
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第 10 章 

测试程序 

SEED-VPM642 系统的测试程序包括以下几个方面： 

  测试 SEED-VPM642 的存贮器系统，包括 SDRAM 与 FLASH 
  测试系统的 BOOT 过程 
  测试音频采集与播放 
  测试视频采集与播放 
  测试 UART 
  测试网络接口的收发 
  测试 ATA 硬盘接口 
  测试实时时钟 

 注 1：测试程序的工程调试环境是以合众达公司的 560 仿真器建立的，为了方便起见，

推荐用户使用合众达公司 PCI 接口或 USB 口的 560 仿真器进行测试。 

 注 2：如果 SEED-VPM642 应用模板已经烧写入程序，那么应用模板一上电程序就会

自动运行，从而有可能导致不能直接进入 CCS 开发界面。此时，应该同时按住 CCS 错误

界面的 RETRY 和应用模板上的 reset 按钮，然后再同时释放，操作几次，就可以进入 CCS
开发界面（为了避免此类问题，建议用户将烧写入的程序擦除掉）。 

 注 3：SEED-VPM642 所提供的例程（包括例程所使用到的本公司自行设计的库）都是

基于 CCS3.3 设计的，因此，如果用户采用 CCS3.3 来进行相关开发，那么就不存在兼容性

问题，即所有例程和库都是直接可用的。但当使用其它版本的 CCS 时，请注意以下事项： 
1．使用 CCS2.20.18 时，请用户使用本公司提供的基于 CCS2.20.18 下设计的 CSL 库

（cslDM642.lib 和 cslDM642e.lib）替换 CCS3.3 提供的相应 CSL 库，然后重新编译连接即

可。 
2．使用 CCS3.1 时，遇到如下两种错误的解决建议： 
错误现象 1．通过 CCS3.1 装载例程里面提供的 gel 文件时报错。 
解决方法：请修改 gel 文件如下内容将 
GEL_MapAdd(0x01800000，0，0x00000054，1，1)； /* EMIFA CTL REGS */ 
GEL_MapAdd(0x01A80000，0，0x00000054，1，1)； /* EMIFB CTL REGS*/ 
分别改为 
GEL_MapAdd(0x01800000，0，0x00000058，1，1)； /* EMIFA CTL REGS*/ 
GEL_MapAdd(0x01A80000，0，0x00000058，1，1)； /* EMIFB CTL REGS */ 
错误现象 2．视频相关的例程编译连接或运行错误。 
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解决方法：这是由 CCS3.1 提供的 CSL 库（cslDM642.lib 和 cslDM642e.lib）引起的，请将

CCS3.3 提供的 CSL 库替换掉 CCS3.1 提供的 CSL 库，然后重新编译连接即可。 

10.1 存贮器系统的测试 

SEED-DM642 系统中的 SDRAM 标准配置为 64M×64 位；FLASH 标准配置为 4M×8
位。本程序主要是用来测试 SDRAM 和 FLASH 的读／写操作。并验证 FLASH 的页寄存器

的正确性。 

10.1.1 SDRAM的测试 

SDRAM 的测试主要包括其控制逻辑与读／写操作是否正确。测试步骤如下： 

  将 SEEDVPM642 的目录拷贝到 CCS 集成开发环境下的 myprojects 目录下。 
  在 CCS 中用 Project→Open…命令，加载 SEEDVPM642_mem 目录下的

SEEDVPM642mem.pjt。 
  在 CCS 中用 File→Load Program…命令，加载 SEEDVPM642-Mem\Debug 目录

下的 seedvpm642mem.out。 
  在 CCS 中用 Debug→Go Main 命令执行程序到 C 的 main()函数处。 
  按照程序的说明，进行测试。其主要过程如下： 

按下图所示位置放置断点，测试正常，程序将停在最后，如出现错误，会停在上一

个断点处。 
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10.1.2 FLASH的测试 

FLASH 的测试主要包括 FLASH 的擦除／写入操作，以及其在存储空间中的映射是否

正确。测试步骤如下： 

  将 SEEDVPM642 的目录拷贝到 CCS 集成开发环境下的 myprojects 目录下。 
  在 CCS 中用 Project→Open…命令，加载 SEEDVPM642_flash 目录下的

SEEDVPM642flash.pjt。 
  在 CCS 中用 File→Load Program…命令，加载 SEEDVPM642_flash\Debug 目录

下的 seedvpm642flash.out。 
  在 CCS 中用 Debug→Go Main 命令执行程序到 C 的 main()函数处。 
  将断点设置在下图所示的位置，执行程序到此断点。 
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  配置 FLASHPAGE 寄存器，使 FLASH 的 8 个 512K 空间映射到 TMS320DM642

的存贮器空间内； 
  进行 FLASH 的每个页擦除操作； 
  向 FLASH 中写入以每页的页数开始的顺序数据； 
  通过 CCS 的 MEMORY 窗，观察写入是否正确，其起始地址为 0x90000000。 

详细的程序说明参看测试的源代码。 

10.2 Boot的测试 

SEED-VPM642 共可实现三种 Boot 方式，分别为 FLASH 引导、HPI 引导、PCI 引导。

在此我们测试的为 FLASH 引导。(此种 Boot 方式为系统默认的工作方式) 

10.2.1 FLASH引导的过程 

TMS320DM642 的整个引导过程，一般分成两个过程完成，说明如下： 
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  首先，在系统复位后，TMS320DM642 保持 CPU 处于复位状态，此时 EDMA 控

制器将 0x90000000 开始的 1K-字节程序装入到’DM642 的 0 地址处。然后释放

CPU，使其从 0 地址开始运行程序。也就是说，第一次引导只能引导 1K-字节的程

序。 
  执行第一步引导的程序，将用户自已的程序从 FLASH 中搬到运行的地址中去，然

后进入_cint00，完成整个 BOOT 的过程。 

10.2.2 FLASH引导的测试 

其测试过程如下： 

1． 将 SEEDVPM642 的目录拷贝到 CCS 集成开发环境下的 myprojects 目录下。 
2． 打开 CCS，File→Load GEL…命令，加载 gel 目录下的 SEEDDM642.gel。 
3． 运行 FlashBurn 目录下的 flashburn.exe。 
4． 打开 FlashBurn 目录下的 SEEDVPM642boot.cdd。界面如下图： 
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5． 上述界面中的选择项如下所示： 

  Conversion Cmd 栏用 Browse 命令从 SEEDVPM642_boot 目录下选中

SEEDVPM642_ahex.cmd 文件； 
  File to Burn 栏用 Browse 命令从 SEEDVPM642_boot 目录下选中

SEEDVPM642boot_ahex.hex 为； 
  FBTC Program File 栏用 Browse 命令从 SEEDVPM642_Flashburn 目录下选

中 FBTC642.out 为； 
  Flash Physical 栏设置为 0x90000000， Bytes 栏设置更改为 0x80000。 

6． 打开 Promgram 菜单下的 Esram Flash 选项。在进行这项操作时，由于

SEEDVPM642 的 FLASH 擦除需要 40s，超过了软件擦除的 30s 时间，会报超时

错误，（约等一分钟就可以了）忽略即可。 
7． 打开 Promgram 菜单下的 Progam Flash 选项。 
8． 关掉此程序，关掉 CCS，复位系统。 
9． 可看到 LED 灯 D4、D5 在闪烁，说明程序引导与运行正常 

关于详细的 Boot 过程说明，请参看测试程序的源代码，及相关的技术文档。 

10.3 音频的测试 

音频输入与输出的测试，主要包含了 McASP 的设置与通讯、对 AIC23B 的设置、以及

音频数据的交换。 

10.3.1 AUDIO测试的内容 

在测试音频时，主要有以下几个方面的内容： 

  初始化 McASP； 
  通过 IIC 设置 Codec 的工作模式 
  启动音频采集与回放音频信号。 

10.3.2 AUDIO的测试过程 

音频的测试过程如下： 

1． 将 SEED-VPM642 的音频与视频转接线与 J1 接好，在 Ain0 接入音频，将音箱接

入 J3； 
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2． 将 SEEDVPM642 目录拷贝到 CCS 集成开发环境下的 myprojects 目录下； 
3． 在 CCS 中用 Project→Open…命令，加载 03. Audio Loopback\echo 目录下的

evmdm642_echo.pjt； 
4． 在 CCS 中用 File→ Load Program…命令，加载 echo\release 目录下的

evmdm642_echo.out； 
5． 执行程序，可以听到音箱播放的由 Ain0 输入的音乐。 
6． 按相同方法测试 Ain1 与 J4、Ain2 与 J5、Ain3 与 J6。 

关于 AIC23B 详细的设置与说明，参看测试程序的源代码及相关的文档。 

10.4 图像采集与回放的测试 

图像采集与回放的测试，主要包括了 IIC 总线的配置、TVP5150 的配置、VP 口的配置，

以及 EDMA 的使用等。 

10.4.1  第一路D1 静态图像的采集 

由于第一路的 TVP5150 与 SAA7121H 共用一个 VP 口，所以实现不了同步的采集与播

放。因而我们将利用 CCS 的 View 功能来进行测试静态的图像。 

测试过程如下： 

1. 将 SEED-VPM642 的音频与视频转接线与 J1 接好，将摄像头的输出接入到 Vin0
上；将 S 端子 J7 接入到电视的 S 端子上，接好仿真器； 

2. 将 SEEDVPM642 目录拷贝到 CCS 集成开发环境下的 myprojects 目录下； 
3. 在 CCS 中用 Project→Open… 命令，加载 SEEDVPM642_D1 目录下的

SEEDVPM642d1.pjt； 
4. 在 CCS 中用 File→Load Program…命令，加载 SEEDVPM642_D1\Debug 目录下

的 seedvpm642d1.out； 
5. 执行程序，等程序执行到最后的死循环后，打开 View→Graph→Imag…填写如下

设置。 
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6. 点击 OK，等待 DSP 传送数据，约需 5 分钟，在 CCS 中即可看到一帧图形。 

关于图像程序详细的设置与说明，参看测试程序的源代码及相关的文档。 

10.4.2  第 2～4 通路图像的采集与显示测试 

第 2、3、4 路图像的输入，均能与 SAA7121H 配合，将摄像头的图像显示在电视机上。

其测试过程如下： 

1. 将 SEED-VPM642 的音频与视频转接线与 J1 接好，将摄像头的输出接入到 Vin1
上；将 S 端子 J7 接入到电视的 S 端子上，接好仿真器； 

2. 将 SEEDVPM642 目录拷贝到 CCS 集成开发环境下的 myprojects 目录下； 
3. 在 CCS 中用 Project→Open…命令，加载 SEEDVPM642_loop2 目录下的

SEEDVPM642loop2.pjt； 
4. 在 CCS 中用 File→Load Program…命令，加载 SEEDVPM642_loop2\Debug 目

录下的 seedvpm642loop2.out； 
5. 执行程序，即可在电视上看到运动的图像； 
6. 与上述过程类似，可以测试第 3、4 路，对应目录分别为 SEEDVPM642_loop3 和

SEEDVPM642_loop4。 

关于图像程序详细的设置与说明，参看测试程序的源代码及相关的文档。 
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10.5 UART的测试 

在 SEED-VPM642 系统中配置了两路 UART 接口。进行 UART 测试时，采用 UART
与计算机通讯。测试时，UART 的接口标准应配置为 RS232 方式进行。 

10.5.1 UART的测试内容 

测试 UART 时，需要测试两路的 UART。测试方式采用查询方式进行。 

10.5.2 UART的测试过程 

UART 的测试过程如下： 

1． 将 SEED-VPM642 的 UART 通道 A 和通道 B 均配置为 RS232 方式。 
2． 运行目录 Serial 下的“串口调试器”的软件，设置串口参数，如下： 

 

3． 将目录 SEED-VPM642 拷贝到到 CCS 集成开发环境下的 myprojects 目录下； 
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4． 在 CCS 中用 Project→Open…命令，加载 SEEDVPM642-uartio 目录下的

SEEDVPM642uartio.pjt； 
5． 在 CCS 中用 File→Load Program…命令，加载 SEEDVPM642-uartio\Debug 目录

下的 seedvpm642uartio.out； 
6． 执行程序，先测试 UARTA，即通路 A。此时可以看到 PC 与 SEED-VPM642 之间

的相互串行通讯； 
7． 修改程序，将所有的 UART_A，改成 UART_B，重新编译； 
8． 重新加载程序，执行，测试通道 B。 

关于更多串口的操作，请参看测试程序的源代码及相关的文档。 

10.6 以太网接口的测试 

以太网接口的测试主要是测试 EMAC 与 MDIO 的配置及使用，以及如何设置一个 PHY
设备和 CSL 库中关于网络接口部分程序的应用。在此测试过程中，采用自闭环的方式完成。

其测试过程如下： 

1. 将网络插头与 SEED-VPM642 板上的 J8 相连，接好仿真器。 
2. 将 SEEDVPM642 目录拷贝到 CCS 集成开发环境下的 myprojects 目录下； 
3. 在 CCS 中用 Project→Open… 命令，加载 SEEDVPM642_net 目录下的

SEEDVPM642net.pjt； 
4. 在 CCS 中用 File→Load Program…命令，加载 SEEDVPM642_net\Debug 目录下

的 seedvpm642net.out； 
5. 执行程序，即可在接收区看到发送的数据。 

关于更多关于网络的操作，请参看测试程序的源代码及相关的文档。 

10.7 ATA硬盘接口的测试 

ATA 硬盘接口的测试，主要是用来测试 ATA 的硬件接口。包括 ATA 协议寄存器的读

与写，以及一些 API 协议的实现。其测试过程如下： 

1. 将一硬盘通过 IDE40 的电缆将硬盘与 SEED-VPM642 的 J9 相连，接好仿真器 
2. 将 SEEDVPM642 目录拷贝到 CCS 集成开发环境下的 myprojects 目录下； 
3. 在 CCS 中用 Project→Open… 命令，加载 SEEDVPM642_ide 目录下的

SEEDVPM642ide.pjt； 
4. 在 CCS 中用 File→Load Program…命令，加载 SEEDVPM642_ide\Debug 目录下

的 seedvpm642ide.out； 
5. 执行程序，程序执行硬盘的确认协议，读回硬盘的序列号与控制器的类型，然后将

之显示在 stdio 的显示框内。 
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关于更多关于网络的操作，请参看测试程序的源代码及相关的文档。 

10.8 实时时钟的测试 

实时时钟的测试包含两部分，其一为 RTC 的测试，另一为片上 512×8-bits 的 EEPROM
的测试。 

10.8.1 RTC的测试 

RTC 的测试程序主可包括 IIC 的配置，以及通过 IIC 总线配置与寻问 X1226 的 CCR 寄

存器，其测试过程如下： 

1. 将 SEEDVPM642 目录拷贝到 CCS 集成开发环境下的 myprojects 目录下； 
2. 在 CCS 中用 Project→Open…命令，加载 SEEDVPM642_rtcbios 目录下的

SEEDVPM642_rtcbios.pjt； 
3. 在此工程中保存了两个工程，为 SEEDVPM642rtcw.prj 和 SEEDVPM642rtcr.prj。

首先，在 CCS 中选中 SEEDVPM642_rtcw.prj。 
4. 在 CCS 中用 File→Load Program…命令，加载 SEEDVPM642_rtc\Debug 目录下

的 seedvpm642rtcw.out； 
5. 运行 seedvpm642rtcw.out 的程序。 
6. 当程序结束后，再在 CCS 中选中 SEEDVPM642_rtcr.prj，并用 File→Load 

Program…命令，加载 SEEDVPM642_rtc\Debug 目录下的 seedvpm642rtcr.out； 
7. 运行 seedvpm642rtcr.out 程序，并观察 stdio 输出窗口内的时间显示是否正确，每

隔一秒显示一次。 

关于更多关于 RTC 的操作，请参看测试程序的源代码及相关的文档。 

10.8.2 EEPROM的测试 

EEPROM 的测试程序主要包括 IIC 的配置，以及通过 IIC 总线配置与访问 X1226 的 512
×8-bits 的 EEPROM，其测试过程如下： 

1. 将 SEEDVPM642 目录拷贝到 CCS 集成开发环境下的 myprojects 目录下； 
2. 在 CCS 中用 Project→Open…命令，加载 SEEDVPM642_eeprom 目录下的

SEEDVPM642eepromw.pjt； 
3. 在 此 工 程 中 保 存 了 两 个 工 程 ， 为 SEEDVPM642eepromw.prj 和

SEEDVPM642eepromr.prj。首先，在 CCS 中选中 SEEDVPM642eepromw.prj。 
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4. 在 CCS 中用 File→Load Program…命令，加载 SEEDVPM642_eeprom\Debug
目录下的 seedvpm642eepromw.out； 

5. 运行 seedvpm642eepromw.out 的程序。 
6. 当 程 序 结 束 后 ， 断 电 ， 然 后 重 新 上 电 。 打 开 CCS ， 重 新 装 入

SEEDVPM642eeprom.wks，并选中 SEEDVPM642eepromr.prj，在 CCS 中用 File
→ Load Program… 命 令 ， 加 载 SEEDVPM642_eeprom\Debug 目 录 下 的

seedvpm642eerpmr.out； 
7. 运行 seedvpm642eepromr.out 程序，并观察数据框中的数据是否与写入的一致。 

关于更多关于 EERPOM 的操作，请参看测试程序的源代码及相关的文档。 

10.9  ESAM模块的测试 

ESAM 加密模块的测试，主要是用来测试 ESAM 的硬件接口，包括 ESAM 的读与写，

以及一些 ESAM 协议的实现。其测试过程如下： 

1. 将 SEEDVPM642 目录拷贝到 CCS 集成开发环境下的 myprojects 目录下； 
2. 在 CCS 中用 Project→Open…命令，加载 SEEDVPM642_esam 目录下的

SEEDVPM642esam.pjt； 
3. 在 CCS 中用 File→Load Program…命令，加载 SEEDVPM642_esam\Debug 目

录下的 seedvpm642esam.out； 
4. 执行程序，程序执行复位的确认协议，读回 ESAM 的序列号与相关信息，然后将

之显示在 stdio 的显示框内。 

关于更多关于 ESAM 的操作，请参看测试程序的源代码及相关的文档。 
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第 11 章 

连接器、跳针、机械尺寸 

本章描述 SEED-VPM642 模板的物理布局，说明各连接器的定义、跳针的设置，以及

它们在模板上的位置。 

11.1 物理布局 

SEED-VPM642 为工业标准的 PCI 半长卡，长 174.6mm×宽 106.7mm，采用表面贴

装元器件，元器件双面安装。 

SEED-VPM642 模板正面布局如下图所示： 
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SEED-VPM642 模板的反面布局如下图所示： 

 

11.2 连接器及开关 

SEED-VPM642 模板上有 14 个连接器，如下表所示： 

连接器 引脚数 功能 
J1 26 数字 I/O、异步串口 COM A 和 COM B 
J2 26 模拟视频、音频的输入／输出 
J3 5 第 0 路立体声音频输出 
J4 5 第 1 路立体声音频输出 
J5 5 第 2 路立体声音频输出 
J6 5 第 3 路立体声音频输出 
J7 7 S 端子视频输出 
J8 16 以太网接口 
J9 40 ATA 连接器 

J10 14 JTAG 仿真器接口 
J11 2 +5V 电源输入口 
J12 4 手动复位按钮 
J13 2 外部复位输入 
J14 124 PCI 或 HPI 连接器 
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11.2.1 J1: 数字I/O、异步串口COM A和COM B 

SEED-VPM642 系统中有一 26-芯的高密度 DSUB 型插座，如下图所示： 

 

它包含了异步串口 COM A 和 COM B，及 8 路数字量的输出和 8 路数字量的输入。其

定义如下： 

引脚号 信号 方向 
9 GND － 
8 DI0 输入 
7 DI1 输入 
6 DI2 输入 
5 DI3 输入 
4 DI4 输入 
3 DI5 输入 
2 DI6 输入 
1 DI7 输入 

17 DO0 输出 
16 DO1 输出 
15 DO2 输出 
14 DO3 输出 
13 DO4 输出 
12 D05 输出 
11 DO6 输出 
10 DO7 输出 
26 Z(B) ／TXDA 输入／输出 
25 Y(A) ／RTSA 输入／输出 
24 A／RXDA 输入／输出 
23 B／CTSA 输入／输出 
22 Z(B) ／TXDB 输入／输出 
21 Y(A) ／RTSB 输入／输出 
20 A／RXDB 输入／输出 
19 B／CTSB 输入／输出 
18 GND — 
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2.2 J2: 模拟视频、音频的输入／输出 

在 SEED-VPM642 系统中有一 26-芯的高密度 DSUB 型插座，如下图所示： 

 

它包含了四路视频的输入与一路视频的输出、四路音频的输入。其定义如下： 

引脚号 信号 方向 
1 CVBS_OUT 输出 
2 CVBS／Y0 输入 
3 CVBS／Y1 输入 
4 CVBS／Y2 输入 
5 CVBSY3 输入 
6 AP0_LINEINL／MICIN 输入 
7 AP1_LINEINL／MICIN 输入 
8 AP2_LINEINL／MICIN 输入 
9 AP3_LINEINL／MICIN 输入 
10 AGND － 
11 AGND － 
12 AGND － 
13 AGND － 
14 AGND － 
15 AGND － 
16 AGND － 
17 AGND － 
18 AGND － 
19 CVBS／C0 输入 
20 CVBS／C1 输入 
21 CVBS／C2 输入 
22 CVBS／C3 输入 
23 AP0_LINEINR 输入 
24 AP1_LINEINR 输入 
25 AP2_LINEINR 输入 
26 AP3_LINEINR 输入 
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11.2.3  J3：第 0 路音频立体声输出口Audio Line OUT 

音频立体声输入口 J3 采用工业标准的 3.5mm 音频插座，与其对应的插头的信号分配

如下： 

 

11.2.4  J4：第 1 路音频立体声输出口Audio Line OUT 

音频立体声输入口 J4 采用工业标准的 3.5mm 音频插座，与其对应的插头的信号分配

如下： 

 

11.2.5  J5：第 2 路音频立体声输出口Audio Line OUT 

音频立体声输入口 J5 采用工业标准的 3.5mm 音频插座，与其对应的插头的信号分配

如下： 
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11.2.6  J6：第 3 路音频立体声输出口Audio Line OUT 

音频立体声输入口 J6 采用工业标准的 3.5mm 音频插座，与其对应的插头的信号分配

如下： 

 

11.2.7 J7: 图像的S端输出 

在 SEED-VPM642 系统中，可以将图像通过 S 端子，直接传送给电视机进行显示。其

定义如下； 

 

引脚号 信号 方向 
1 NC － 
2 NC － 
3 AGND － 
4 NC － 
5 AGND  
6 Y_OUT 输出 
7 NC － 
8 C_OUT 输出 
9 NC － 

10 NC － 
11 NC － 
12 NC － 
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11.2.8 J8：网络接口 

在 SEED-VPM642 系统中，有一个 RJ45 的网络接口。可以接标准的网络插头。其定

义如下图： 

 

引脚号 信号 方向 
1 TX＋ 输出 
2 TX－ 输出 
3 RX＋ 输入 
4 § － 
5 § － 
6 RX－ 输入 
7 § － 
8 § － 
9 ＋3.3V － 

10 ACTIVELED 输入 
11 ＋3.3V － 
12 LINKLED 输入 
13 GND － 
14 GND － 
15 NC － 
16 NC － 

注：§：4 与 5 脚相连，与 SEED-VPM642 内部的阻容网络连接。7 脚与 8 脚相连，

与 SEED-VPM642 内部的阻容网络连接。 

11.2.9 J9：ATA硬盘连接器 

在 SEED-VPM642 系统中有一个 40-DIP 芯的插座，用于连接硬盘。其定义如下图： 
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引脚号 信号 方向 
1 RESET  输入 
2 GND － 
3 DD7 输出／输入 
4 DD8 输出／输入 
5 DD6 输出／输入 
6 DD9 输出／输入 
7 DD5 输出／输入 
8 DD10 输出／输入 
9 DD4 输出／输入 

10 DD11 输出／输入 
11 DD3 输出／输入 
12 DD12 输出／输入 
13 DD2 输出／输入 
14 DD13 输出／输入 
15 DD1 输出／输入 
16 DD14 输出／输入 
17 DD0 输出／输入 
18 DD15 输出／输入 
19 GND － 
20 KEYPIN 输入 
21 DMARQ 输入 
22 GND － 
23 DIOW ／STOP 输入 
24 GND － 
25 DIOR／HDMARDY ／HSTROBE 输入 
26 GND － 
27 IORDY／DMACK ／DSTROBE 输出 
28 CSEL 输入 
29 DMACK  输出 
30 GND － 
31 INTRQ 输出 
32 RSV － 
33 DA1 输入 
34 PDIAG / CBLID  输出 
35 DA0 输入 
36 DA2 输入 
37 0CB  输入 
38 1CS  输入 
39 DASP  输出 
40 GND － 
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11.2.10 J10：JTAG仿真器接口 

SEED-VPM642 系统中有一个 14-芯、间距为 100mil 的双排插针 J1，它是一个 JTAG
仿真器标准接口，通过此接口对’VC5416 进行硬件仿真调试。其定义如下： 

 

11.2.11 J11：+5V电源输入口 

+5V 电源输入口 J11 采用 Mini 型直流电源插座，其示意图如下： 

 

11.2.12 J12：复位按钮 

SEED-VPM642 板上提供复位按钮，方便调试。 

11.2.13 J13：外部复位输入 

SEED-VPM642 可以由外部引入复位信号，使整个系统复位。 
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引脚号 信号 方向 
1 GND － 
2 RST_EXT 输入 

11.2.14 J14：PCI或HPI连接器 

在 SEED-VPM642 系统中的 J14 为标准的 PCI 插卡，当系统使用 PCI 功能时，它的信

号为标准的 PCI 信号，当 TMS320DM642 使用 HPI 功能时，它的信号为 HPI 信号。其定义

如下表： 

引脚 PCI HPI32 HPI16 方向 
A1 TRST  × × － 
A2 ＋12V × × － 
A3 TMS × × － 
A4 TDI × × － 
A5 +5V ＋5V ＋5V － 
A6 INTA  GP0[13] GP0[13] 输出 
A7 INTC  × × － 
A8 ＋5V ＋5V ＋5V － 
A9 × × × － 

A10 V（I/O） × × － 
A11 × × × － 
A12 键位 × × － 
A13 键位 × × － 
A14 ＋3.3Vaux × × － 
A15 RST  GP0[15] GP0[15] 输入／输出 
A16 V（I/O） × × － 
A17 GNT  GP0[12] GP0[12] 输入／输出 
A18 GND GND GND － 
A19 PME  × × － 
A20 AD30 HD30 × 输入／输出 
A21 +3.3V(PCI) × × － 
A22 AD28 HD28 × 输入／输出 
A23 AD26 HD26 × 输入／输出 
A24 GND GND GND － 
A25 AD24 HD24 × 输入／输出 
A26 IDSEL GP0[9] GP0[9] 输入／输出 
A27 +3.3V(PCI) × × － 
A28 AD22 HD22 × 输入／输出 
A29 AD20 HD20 × 输入／输出 
A30 GND GND GND － 
A31 AD18 HD18 × 输入／输出 
A32 AD16 HD16 × 输入／输出 
A33 +3.3V(PCI) × × － 
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A34 FRAME  HINT  HINT  输入／输出 
A35 GND GND GND － 
A36 TRDY  HHWIL HHWIL 输入／输出 
A37 GND GND GND － 
A38 STOP  HCNTL0 HCNTL0 输入／输出 
A39 +3.3V(PCI) × × － 
A40 SDONE × × － 
A41 SBO  × × － 
A42 GND GND GND － 
A43 PAR HAS  HAS  输入／输出 
A44 AD15 HD15 HD15 输入／输出 
A45 +3.3V(PCI) × × － 
A46 AD13 HD13 HD13 输入／输出 
A47 AD11 HD11 HD11 输入／输出 
A48 GND GND GND － 
A49 AD09 HD09 HD09 输入／输出 
A50 键位 × × － 
A51 键位 × × － 
A52 0BE  × × 输入 
A53 +3.3V(PCI) × × － 
A54 AD06 HD06 HD06 输入／输出 
A55 AD04 HD04 HD04 输入／输出 
A56 GND GND GND － 
A57 AD02 HD02 HD02 输入／输出 
A58 AD00 HD00 HD00 输入／输出 
A59 V（I/O） × × － 
A60 64REQ  × × － 
A61 +5V +5V +5V － 
A62 +5V +5V +5V － 
B1 －12V × × － 
B2 TCK × × － 
B3 EMAC_DETECT EMAC_DETECT EMAC_DETECT 输入 
B4 TDO × × － 
B5 +5V +5V +5V － 
B6 +5V +5V +5V － 
B7 INTB  × × － 
B8 INTD  × × － 
B9 1PRSNT  × × － 

B10 HPI_DETECT HPI_DETECT HPI_DETECT － 
B11 2PRSNT  × × － 
B12 键位 × × － 
B13 键位 × × － 
B14 RSV × × － 
B15 GND GND GND － 
B16 CLK GP0[14] GP0[14] 输入／输出 
B17 GND GND GND － 



 98 

B18 REQ  GP0[11] GP0[11] 输入／输出 
B19 V（I/O） × × － 
B20 AD31 HD31 × 输入／输出 
B21 AD29 HD29 × 输入／输出 
B22 GND GND GND － 
B23 AD27 HD27 × 输入／输出 
B24 AD25 HD25 × 输入／输出 
B25 +3.3V(PCI) × × － 
B26 3CBE  GP0[10] GP0[10] 输入／输出 
B27 AD23 HD23 × 输入／输出 
B28 GND GND GND － 
B29 AD21 HD21 × 输入／输出 
B30 AD19 HD19 × 输入／输出 
B31 +3.3V(PCI) × × － 
B32 AD17 HD17 × 输入／输出 
B33 2CBE  HR/ W  HR/ W  输入／输出 
B34 GND GND GND － 
B35 IRDY  HRDY  HRDY  输入／输出 
B36 +3.3V(PCI) × × － 
B37 DEVSEL  1HCNTL  1HCNTL  输入／输出 
B38 GND GND GND － 
B39 LOCK  × × － 
B40 PERR  HCS  HCS  输入／输出 
B41 +3.3V(PCI) × × － 
B42 SERR  1HDS  1HDS  输入／输出 
B43 +3.3V(PCI) × × － 
B44 1CBE  2HDS  2HDS  输入／输出 
B45 AD14 HD14 HD14 输入／输出 
B46 GND GND GND － 
B47 AD12 HD12 HD12 输入／输出 
B48 AD10 HD10 HD10 输入／输出 
B49 GND GND GND － 
B50 键位 × × － 
B51 键位 × × － 
B52 AD08 HD08 HD08 输入／输出 
B53 AD07 HD07 HD07 输入／输出 
B54 +3.3V(PCI) × × － 
B55 AD05 HD05 HD05 输入／输出 
B56 AD03 HD03 HD03 输入／输出 
B57 GND GND GND － 
B58 AD01 HD01 HD01 输入／输出 
B59 V（I/O） × × － 
B60 64ACK  × × － 
B61 +5V +5V +5V － 
B62 +5V +5V +5V － 
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11.3 指示灯 

在 SEED-VPM642 系统中共有 3 个发光二极管，分别为 D3、D4、D5。各个二极管的

连接如下所示： 

D3：为+3.3V 电源指示灯，正常情况下 D3 点亮，否则 D3 熄灭。 

D4：与 TMS320DM642 的 GP3 连接，当 GP3 为低电平时，D4 点亮，当 GP3 为高电

平时，D4 熄灭。 

D5：与 TMS320DM642 的 GP8 连接，当 GP8 为低电平时，D5 点亮，当 GP8 为高电

平时，D5 熄灭。 

发光二圾管 D4 与 D5 可以用来显示程序运行的状态。 
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附录 A 

寄存器 

SEED-VPM642 系统中总共有 10 个寄存器，用于设置系统的状态和反馈状态信息。它

们均在 CPLD 中实现。 

A.1 数字量输出寄存器（DOUTR） 

地址：0x9008 0010（只写） 

D07 D06 D05 D04 D03 D02 D01 D00 
DOUT7 DOUT6 DOUT5 DOUT4 DOUTN3 DOUT2 DOUT1 DOUT0

DOUT [i]： 直接输出给连接器 J1 上的 DO[i]（i = 0、1、……、7）信号； 
0： DO[i]当前输出为低电平； 
1： DO[i]当前输出为高电平。 

A.2 数字量输入寄存器（DINR） 

地址：0x9008 0010（只读） 

D07 D06 D05 D04 D03 D02 D01 D00 
DIN7 DIN6 DIN5 DIN4 DIN3 DIN2 DIN1 DIN0 

DIN[i]： 连接器 J1 上的 DI[i]（i = 0、1、……、7）信号的当前状态； 
0： DI[i]当前状态为低电平； 
1： DI[i]当前状态为高电平。 

A.3 Flash页寄存器（FLASHPAGE）： 

地址：0x9008 0011（只写） 
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D07 D06 D05 D04 D03 D02 D01 D00 
× × × × × PA21 PA20 PA19 

PA[21:19]： FLASH 的页地址输出； 

A.4 ATA状态寄存器（ATASTATUS） 

地址：0x9008 0011（只读） 

D07 D06 D05 D04 D03 D02 D01 D00 
× × × × × × × DASP 

DASP： ATA 的 DASP 管脚的状态； 
0： 设备有效或从设备存在； 
1： 设备无效。 

A.5 串口配置寄存器（UARTSET） 

地址：0x9008 0012，只写 

D07 D06 D05 D04 D03 D02 D01 D00 
× × × × FASTB FASTA

：异步串口 0（COM 0）配置为 RS232 方式还是 RS422/RS485 方式 
0： 选择 RS232 方式 
1： 选择 RS422/RS485 方式 

：异步串口 1（COM 1）配置为 RS232 方式还是 RS422/RS485 方式 
0 选择 RS232 方式 
1 选择 RS422/RS485 方式 

FASTA： 异步串口 1（COM 1）配置为全速还是慢速运行方式 
0 慢速运行方式 
1 快速运行方式 

FASTB： 异步串口 2（COM 2）配置为全速还是慢速运行方式 
0 慢速运行方式 
1 快速运行方式 
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A.6 音频锁相环控制寄存器（AUDIOPLL） 

地址：0x9008 0013（只写） 

D07 D06 D05 D04 D03 D02 D01 D00 
× × × × × MD MC MS 

MD： PLL1708 串行配置的数据位； 
0 MD 管脚输出为低电平 
1 MD 管脚输出为高电平 

MC： PLL1708 串行配置的位-时钟； 
0 MC 管脚输出为低电平 
1 MC 管脚输出为高电平 

MS： PLL1708 串行配置的片选信号。 
0 MS 管脚输出为低电平 
1 MS 管脚输出为高电平 

A.7   ESAM控制寄存器（ESAMCNTL） 

地址：0x0x9008 0014（只写） 

D07 D06 D05 D04 D03 D02 D01 D00 
× × × × × RST TorR DO 

RST： ESAM 复位控制位。 
0 无复位产生； 
1 产生 ESAM 复位信号。 

TorR： 发送与接收控制位 
0 从 ESAM 的 I/O 管脚接收数据； 
1 向 ESAM 的 I/O 管脚发送数据。 

DO： 向输出 ESAM 的 I/O 管脚发送的电平。 
0 向 ESAM 的 I/O 管脚写 0； 
1 向 ESAM 的 I/O 管脚写 1。 
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A.8  ESAM状态寄存器（ESAMSTATUS） 

地址：0x0x9008 0014（只读） 

D07 D06 D05 D04 D03 D02 D01 D00 
× × × × × × × DI 

DI： ESAM 复位控制位。 
0 ESAM 的 I/O 管脚状态为低； 
1 ESAM 的 I/O 管脚状态为高。 

A.9 看门狗使能寄存器（WATCHDOG） 

地址：0x0x9008 0015（只写） 

D07 D06 D05 D04 D03 D02 D01 D00 
× × × × × × SST_RST WDEN

WDEN： 看门狗使能位。 
0 禁止看门狗功能； 
1           使能看门狗功能。 

SAA_RST： 看门狗使能位。 
0  SAA7121 处于复位状态（默认状态）； 
1           SAA7121 脱离复位状态。 

A.10 看门狗使能寄存器（WDUP） 

地址：0x0x9008 0016（只写） 

D07 D06 D05 D04 D03 D02 D01 D00 
× × × × × × × × 

当系统控制寄存器中的 WDEN 位为 1 时，对此寄存器作写操作，刷新看门狗电路。 
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A.11 串口中断源寄存器（UARTINIT） 

地址：0x9008 0012，只读 

D07 D06 D05 D04 D03 D02 D01 D00 
× × × × × × UARTBINIT UARTAINIT 

UARTXINIT：异步串口中断源 
0： 对应串口通道无中断 
1： 对应串口通道有中断 
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附录 B 

可编程器件说明 

SEED-VPM642 选用的可编程器件型号为 CY37064VP100。下表是这个芯片的管脚定

义及功能描述。 

管脚 定义 方向 功能描述 
U36.1 TCK IN 器件编程之 TCK 信号 
U36.2 GND GND  
U36.3 EMAC_EN  OUT 网络接口使能信号 
U36.4 EXT_INT5/GP5 OUT DM642 中断 5 
U36.5 PCI_EN OUT PCI 接口使能信号 
U36.6 ESAM_INT IN ESAM 加密中断 
U36.7 TEA4 IN DM642 地址线 
U36.8 TEA3 IN DM642 地址线 
U36.9 TCAS /RE  IN DM642 读使能 
U36.10 TWE  IN DM642 写使能 
U36.11 未使用   
U36.12 +3.3V POWER  
U36.13 未使用   
U36.14 GND GND  
U36.15 未使用   
U36.16 TED7 INOUT DM642 数据信号 
U36.17 TED6 INOUT DM642 数据信号 
U36.18 TED5 INOUT DM642 数据信号 
U36.19 TED4 INOUT DM642 数据信号 
U36.20 TED3 INOUT DM642 数据信号 
U36.21 TED2 INOUT DM642 数据信号 
U36.22 TED1 INOUT DM642 数据信号 
U36.23 TED0 INOUT DM642 数据信号 
U36.24 +3.3V POWER  
U36.25 未使用   
U36.26 TMS IN 器件编程之 TMS 信号 
U36.27 GND GND  
U36.28 TEA5 IN DM642 地址线 
U36.29 2TCE  IN DM642 的片选信号 
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U36.30 1TCE  IN DM642 的片选信号 
U36.31 TEA7 IN DM642 地址线 
U36.32 TEA6 IN DM642 地址线 
U36.33 PA20 OUT FLASH 页地址信号 
U36.34 PA19 OUT FLASH 页地址信号 
U36.35 PA21 OUT FLASH 页地址信号 
U36.36 RESET  OUT 系统复位输出 
U36.37 +3.3V POWER  
U36.38 未使用   
U36.39 GND GND  
U36.40 +3.3V POWER  
U36.41 CS_FLASH  OUT FLASH 片选信号 
U36.42 TEA22 IN DM642 地址线 
U36.43 ATA_DASP IN 硬盘是否存在信号 
U36.44 0CS_ATA  OUT ATA 的片选 0 

U36.45 1CS_ATA  OUT ATA 的片选 1 

U36.46 CS_ATA  OUT ATA 的片选 
U36.47 WDI OUT 系统看门狗时钟输入 
U36.48 F3M57 IN 时钟输入 
U36.49 +3.3V POWR  
U36.50 TDO OUT 器件编程之 TDO 信号 
U36.51 未使用   
U36.52 GND GND  
U36.53 RST_ESAM  OUT ESAM 加密复位信号 
U36.54 ESAM_I/O IN ESAM 加密输入与输出 
U36.55 HPI_DETECT IN HPI 接口选择信号 
U36.56 HPI32_EN OUT 32 位 HPI 接口使能信号 
U36.57 AP_MD OUT PLL1705 控制接口数据信号 
U36.58 AP_MC OUT PLL1705 控制接口时钟信号 
U36.59 AP_MS OUT PLL1705 控制接口使能信号 
U36.60 UART_RST OUT TL16C752 复位 
U36.61 EMAC_DETECT IN 网络接口选择信号 
U36.62 +3.3V POWR  
U36.63 未使用   
U36.64 GND GND  
U36.65 DI7 IN 开关量输入信号 
U36.66 SAA_RST OUT SAA7121 复位信号 
U36.67 DI6 IN 开关量输入信号 
U36.68 DI5 IN 开关量输入信号 
U36.69 DI4 IN 开关量输入信号 
U36.70 DI3 IN 开关量输入信号 
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U36.71 DI2 IN 开关量输入信号 
U36.72 DI1 IN 开关量输入信号 
U36.73 DI0 IN 开关量输入信号 
U36.74 +3.3V POWER  
U36.75 TDI  器件编程之 TDI 信号 
U36.76 未使用   
U36.77 GND GND  
U36.78 DO7 OUT 开关量输出信号 
U36.79 DO6 OUT 开关量输出信号 
U36.80 DO5 OUT 开关量输出信号 
U36.81 DO4 OUT 开关量输出信号 
U36.82 DO3 OUT 开关量输出信号 
U36.83 DO2 OUT 开关量输出信号 
U36.84 DO1 OUT 开关量输出信号 
U36.85 DO0 OUT 开关量输出信号 
U36.86 未使用   
U36.87 +3.3V POWER  
U36.88 未使用   
U36.89 GND GND  
U36.90 +3.3V POWER  
U36.91 FASTB OUT TL16C752 之 B 通路 FAST 使能 
U36.92 CSB_UART  OUT TL16C752 之 B 通路片选 

U36.93 CSA_UART  OUT TL16C752 之 A 通路片选 
U36.94 FASTA OUT TL16C752 之 B 通路 FAST 使能 
U36.95 EN485A OUT TL16C752 之 A 通路 485 使能 
U36.96 EN485B OUT TL16C752 之 B 通路 485 使能 
U36.97 UARTINTA IN TL16C752 之 A 通路中断 
U36.98 UARTINTB IN TL16C752 之 B 通路中断 
U36.99 +3.3V POWER  
U36.100 未使用   
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