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1.  CCSv4概述

Code Composer Studio&amp™（CCS或CCStudio）是一种针对TI的DSP、微控制器和应用处理器的集成开发环境。CCStudio包括一套用于开发和调试嵌入式应用程序的工具。它包括用于各种TI设备系列的编译器、源代码编辑器、项目生成环境、调试程序、探查器、模拟器和其他许多功能。CCStudio提供一个单一用户界面，指导用户完成应用程序开发流程的每一步骤。类似的工具和界面使用户能够比以前更快地开始使用，并且能够向他们的应用程序添加功能，这些都归功于成熟的生产能力工具。 
CCStudio版本4 (CCSv4)以Eclipse开源软件框架为基础。CCSv4之所以以 Eclipse为基础，是因为Eclipse为开发环境提供了一个优异的软件框架，是众多嵌入式软件供应商所使用的标准框架。CCSv4 将Eclipse软件框架的优势和来自TI的高级嵌入式调试功能相结合，为嵌入式程序开发人员生成一个功能丰富的吸引人的开发环境。 

1.1调试程序
CCStudio的集成调试程序具有用于简化开发的众多功能和高级断点。条件断点或硬件断点以全C表达式、本地变量或寄存器为基础。高级内存窗口允许您检查内存的每一级别，以便您可以调试复杂的缓存一致性问题。CCStudio支持复杂的多处理器或多核系统的开发。全局断点和同步操作提供了对多个处理器和多核的控制。 

1.2分析
CCStudio的交互式探查器使快速测量代码性能并确保在调试和开发过程中目标资源的高效使用变得更容易。探查器使开发人员能够轻松分析其应用程序中指令周期内或其他事件内的所有C/C++函数，例如缓存未命中/命中率、管道隔栏和分支。分析范围可用于在优化期间将精力集中在代码的高使用率方面，帮助开发人员开发出经过优化的代码。分析可用于任何组合的汇编、C++或C代码范围。为了提高生产能力，所有分析设备在整个开发周期中都可供使用。 

1.3脚本
某些任务，例如测试，需要运行数小时或数天而不需要用户交互。要完成此类任务，IDE应能自动执行一些常见任务。CCStudio拥有完整的脚本环境，允许自动进行重复性任务，例如测试和性能基准测试。一个单独的脚本控制台允许您在IDE内键入命令或执行脚本。 

1.4图像分析和虚拟化
CCStudio拥有许多图像分析及图形虚拟化功能。其中包括以图形方式在能够自动刷新的屏幕上查看变量和数据的能力。CCStudio还能以本机格式（YUV、RGB）查看主机PC或在目标电路板中加载的图像和视频数据。 

1.5编译器
TI已经开发了专门为了最大程度地提高处理器的使用率和性能而优化的C/ C ++编译器。TI 编译器使用各种各样经典的、面向应用的、成熟的、因设备而异的优化，专为所有支持的结构而优化。其中部分优化包括： 

· 消除公共子表达式 

· 软件流水 

· 强度折减 

· 自动增量寻址 

· 基于成本的寄存器分配 

· 指令预测 

· 硬件循环 

· 函数内联 

· 矢量化 

TI编译器还执行程序级别优化，在应用程序级别评估代码性能。通过程序级别视图，编译器能够像具有完整系统视图的汇编程序开发人员一样生成代码。编译器充分利用此应用程序级别视图，找出能够显著提升处理器性能的折衷。 

TI ARM和Microcontroller C/C++编译器经过专门针对代码大小和控制代码效率的优化。它们具备行业领先的性能和兼容性。 

1.6模拟
模拟器向用户提供一种在能够使用开发板之前开始开发的方式。模拟器还具有更加透彻地了解应用程序性能和行为的优势。提供了几种模拟器，让用户能够权衡周期精确性、速度和外围设备模拟，一些模拟器特别适合算法基准测试，而另一些特别适合更加详细的系统模拟。 

1.7硬件调试（仿真）
TI设备包含高级硬件调试功能。这些功能包括： 

· IEEE 1149.1 (JTAG) 和边界扫描 

· 对寄存器和内存的非侵入式访问 

· 实时模式，用于调试与不得禁用的中断进行交互的代码。实时模式允许您在中断事件挂起后台代码，同时继续执行时间关键中断服务例程。 

· 多核操作，例如同步运行、步进和终止。其中包括跨核触发，该功能可以让一个核触发另一个核终止。 

高级事件触发 (AET)，可在选定设备上使用，允许用户依据复杂事件或序列，例如无效数据或程序内存访问，终止CPU或触发其他事件。它能够以非侵入式方式测量性能及统计系统事件数量（例如缓存事件）。 

CCStudio提供有关选定设备的处理器跟踪，帮助客户发现以前“看不到的”复杂实时缺陷。跟踪能够探测很难发现的缺陷-事件之间的争用情况、间歇式实时干扰、堆栈溢出崩溃、失控代码和不停用处理器的误中断。跟踪是一种完全非侵入式调试方法，依赖处理器内的调试单元，因此不会干扰或更改应用程序的实时行为。跟踪可以微调复杂开关密集型多通道应用程序的代码性能和缓存优化。处理器跟踪支持程序、数据、计时和所选处理器与系统事件/中断的导出。可以将处理器跟踪导出到XDS560跟踪外部JTAG仿真器或选定设备上，或导出到芯片缓存嵌入式跟踪缓存(ETB)上。 

1.8实时操作系统支持

CCSv4 具有两个版本的 TI 实时操作系统： 

· DSP/BIOS5.4x是一种为DSP设备提供预清空多任务服务的实时操作系统。其服务包括ISR调度、软件中断、信号灯、消息、设备I/O、内存管理和电源管理。此外，DSP/BIOS5.x还包括调试诊断和加工，包括低系统开销打印和统计数据收集。 

· BIOS6.x是一种高级可扩展实时操作系统，支持ARM926、ARM Cortex M3、C674x、C64x+、C672x和基于28x的设备。它提供DSP/BIOS 5.x没有的若干内核和调试增强，包括更快、更灵活的内存管理、事件和优先级继承互斥体。 

注意：BIOS6.x包括DSP/BIOS5.x兼容层，从而使应用程序源代码的迁移非常轻松。
2.  CCSv4的安装
（1）双击可执行安装程序<setup_CCS_4.x.x.xxxxx>或<setup_CCS_MC_Core _4.x.xxxxx> （x表示软件版本，实际可能会有所不同）。 

重要说明：需要拥有管理权限才能进行安装。
如果在Windows Vista或Windows7上安装并且用户访问控制(UAC)正在运行，此时UAC将会要求提供运行此安装程序的权限。CCSv4安装程序会建议禁用UAC： 



图2.1 UAC警告
视Windows版本而定，如果未禁用UAC，则有可能出现一些类似于下图中的警告消息。



图2.2  UAC驱动程序安装警告

（2）欢迎屏幕如下图所示。单击“Next（下一步）”。 




图2.3 安装程序欢迎屏幕
（3）安装程序将显示许可协议。必须接受该协议方可继续下一步。



图2.4 许可证

（4）下一步是选择所需的安装位置： 

如果使用64位版本的Windows，默认安装位置将为C:\Program Files (x86)\Texas Instruments。 

提示：除非在Vista或Windows7中运行，否则，强烈建议在默认目录中安装CCSv4，因为在安装时会自动选择对组件（DSP/BIOS、代码生成工具、RTSC 等）的更新。 




图2.5  安装目录
在Windows Vista中安装时会显示以下警告。可以忽略此警告，除非CCSv4将由具有普通（非管理员）权限的用户使用或者目录允许所有用户进行读/写操作。 



图2.6 Vista安装警告
（5）下一步是选择所需的安装版本： 




图2.7 版本
· “Platinum Edition（铂金版）”可用于所有设备的安装。 

· “Microcontroller Edition（微控制器版）”仅支持 MSP430、C2000、Cortex M3 和 Cortex R4 设备。 

· “Scripting Tools（脚本工具）”安装可加载和调试脚本代码所必需的一组工具。 

· “Custom（自定义）”允许配置所需的每台设备。实际上相当于安装“Platinum Edition（铂金版）”。 

（6）下一屏幕显示要安装的设备系列。 

提示：
· 为了获得最佳性能，建议只安装需要的设备系列。 

· 要调试DaVinci或OMAP等系统芯片设备，请同时安装ARM和C6000 DSP设备系列。 




图2.8 铂金版设备系列



图2.9 微控制器版设备系列

（7）显示组件安装屏幕。根据所选择的版本，此屏幕会有所不同。
MSP430用户警告：请注意，在默认情况下不安装MSP430 Parallel FET调试程序。 




图2.10 组件
（8）单击“Next（下一步）”显示所选安装选项的摘要。 




图2.11 摘要
（9）在安装过程中，将显示下图所示的安装程序主屏幕。有时会显示“(Not Responding（无响应））”字样，但这是正常的，因为它在等待每个组件安装程序完成其操作。 



图2.12 安装进度
（10）在安装过程中，某些窗口可能会弹出，要求提供安装仿真设备驱动程序的权限。您可以安全地单击“Install（安装）”。 




图2.13 光谱数字设备驱动程序警告



图2.14  Blackhawk设备驱动程序警告

（11）一段时间之后，安装程序完成其作业，Code Composer Studio 即准备好启动。 




图2.15 结束
3. 首次使用CCSv4

3.1定义工作区目录
CCSv4首先要求的是定义一个工作区，即用于保存开发过程中用到的所有元素（项目和指向项目的链接，可能还有源代码）的目录。 

· 默认情况下，会在C:\Users\<用户>\Documents 或C:\Documents and Settings\<用户>\My Documents目录下创建工作区，但可以任意选择其位置。 

· 每次执行CCSv4都会要求工作区目录。如果计划对所有项目使用一个目录，只需选中“Use this as the default and do not ask again（默认使用此目录且不再询问）”选项。以后随时可以在CCSv4中更改工作区。 




图3.1 选择工作区位置
3.2选择许可证
CCS需要一个激活的许可证，因此下一步就是选择将要使用的许可证。在CCS中有很多不同的许可证选项，下文会说明每个选项的激活过程。 

· 如果CCS具有一块开发板，则许可证已经激活，可以跳过本部分。 

· 如果已经安装许可证文件（通常名为 <license.lic>），则CCS会检测到该文件，可以跳过本部分。 

· 如果不能识别许可证文件，请找到该文件的安装目录，然后按照“免费有限许可证”过程中的步骤9及步骤10所述执行操作。 

3.2.1 30天评估版许可证
30天评估版许可证是在PC上直接激活的，所以借助它从一开始就可以使用CCS。 

· 无需连接Internet。 

· 在30天的评估期中，可以使用CCSv4的全部功能。 

· 可以将评估期再延长90天。请查看“高级主题”部分。 

要使用其他许可证或想延长评估期，可以转到“Help -> Licensing Options（帮助 -> 许可选项）”。 
选中“Evaluate Code Composer Studio for 30 days（对Code Composer Studio进行30天评估）”选项，然后单击“OK（确定）”。 



图3.2 选择评估版许可证
CCS 将在顶部工具栏中显示剩余天数： 




注意：在某些情况下，如果满足以下条件，30天评估选项将不可用： 

· 当前安装版本的30天评估期已过。 

· 之前安装过CCS并已激活30天评估期，目前30天期限已过。请注意，即使卸载了CCS，仍会计算在30天期限内。 

· 始终会提供将评估版许可证再延长90天的选项。请查看“高级主题”部分。 

3.2.2免费有限许可证

通过“免费有限许可证”可以使CCS利用低成本XDS100仿真器来执行调试，这种仿真建立在标准EVM/DSP/eZdsp开发板或模拟器上。 

· 需要一个激活的my.ti.com 帐户（可以立即创建帐户）。 

· 需要连接Internet。 
①选择“Activate License（激活许可证）”，然后在许可证屏幕上单击“Use Free Limited License（使用免费有限许可证）”按钮。 



图3.3激活免费有限许可证
②此时将出现一条过程摘要消息。单击“OK（确定）”。 




图3.4 许可证激活消息框
③此时将打开一个浏览器窗口，显示 my.ti.com 登录页面。然后将打开“myRegistered Software（我的注册软件）”页面，显示待激活产品的详细信息、所选许可证以及激活 ID 代码。单击“Next（下一步）”。 



图3.5 “myRegistered Software（我的注册软件）”屏幕
④在此页面中，输入正装CCS的PC信息：HostID（PC的MAC地址）以及名称。可以在CCS的许可证屏幕中找到HostID，就在“Register（注册）”按钮上方。单击“Next（下一步）”。 

⑤下一个页面包含所选许可证的条款与条件。必须接受这些条款与条件才能继续激活操作。单击“Next（下一步）”。 



图3.6  “myRegistered Software（我的注册软件）”屏幕中的许可证协议
⑥下一个屏幕询问用于接收许可证文件的电子邮件地址。检查该地址，然后单击“E-mail License（以电子邮件发送许可证）”。



图3.7 “myRegistered Software（我的注册软件）”屏幕中的电子邮件选择
⑦最后会出现确认屏幕。 


图3.8 “myRegistered Software（我的注册软件）”屏幕中提示电子邮件已发送
⑧在您的收件箱中应该可以看到两封电子邮件：主题分别为 myTI_license 和 myregistered_software。 

· myTI_License 邮件包含许可证文件。保存该文件，然后将其解压缩。 

⑨返回CCS屏幕，然后单击“Specify a License File（指定许可证文件）”下的“Browse（浏览）”。指向您解压缩许可证文件所在的位置。 

⑩重新启动CCS。顶栏应显示“(Licensed)（已授权）”，而不是“30-day evaluation（30 天评估）”或“Unlicensed（未授权）”。 




3.2.3已注册许可证

“已注册许可证”的激活过程与“免费有限许可证”非常类似。 

· 需要一个激活的my.ti.com帐户（可以立即创建帐户）。 

· 需要连接Internet。 

①选择“Activate License（激活许可证）”，然后在许可证屏幕上单击“Register（注册）”按钮。 



图3.9 许可证注册
②按照“免费有限许可证”过程中的步骤2到步骤10执行操作，其中步骤3有以下不同之处： 

· 找到并插入软件DVD光盘中随附的激活ID。将其插入“myRegistered Software（我的注册软件）”之“Validate（验证）”屏幕中，如下图所示： 



图3.10  “myRegistered Software（我的注册软件）”屏幕中的激活ID页面
3.2.4浮动许可证
“浮动许可证”允许在联网环境中的多台PC之间共享许可证池。它需要网络连接，但不要求是Internet连接（适用于与外界网络断开的实验室）。 

该激活过程与“免费有限许可证”的步骤9及步骤10非常类似。仅在步骤9有些微的不同： 

· 选中“Specify a license server（指定许可证服务器）”选项，然后为安装在服务器上的浮动许可证输入“Address（地址）”和“Port Number（端口号）”信息。 

· 对于浮动许可证的使用，还需要在许可证服务器上执行其他一些步骤以设置许可证。有关更多详细信息，请在高级主题中参阅许可证服务器管理的相关主题。 

3.3欢迎屏幕

完成许可证激活过程后，CCS将显示欢迎屏幕，然后就可以使用了。 



图3.11 欢迎使用 Code Composer Studio v4！
4  CCSv4的基本使用方法

4.1概述

Code Composer Studio上的所有工作都基于项目—— 一个源文件、include 文件和配置文件的集合。 

如果您曾使用过早期版本的Code Composer Studio，包括3.x版、Beta版的CCSv4，以及Code Composer Essentials for MSP430，请阅读本教程第4.2节，或查阅网址：CN_GSG:Importing projects from previous versions 。

如果您对Code Composer Studio 还比较陌生，或者只是想从头开始创建一个项目，请阅读本教程第4.3节或查阅网址：CN_GSG:Creating projects 。

创建项目之后的下一步骤是在调试程序中运行程序。请阅读本教程第4.4节或查阅网址：CN_GSG:Debugging projects 。

4.2导入以前CCS版本的项目
4.2.1 导入CCS3.x版本的项目 
以前版本的Code Composer Studio使用的项目文件(*.pjt) 包含了所有生成选项以及对源文件的引用，而CCSv4使用了新的项目格式，它自动在项目目录下生成每个有效源文件，并将生成选项存储在几个以圆点开头的文件和目录中。 

由于这些差异，CCSv4提供了一个“Import Legacy CCS Project Wizard（导入旧版CCS项目向导）”来帮助完成迁移。 

重要说明！迁移过程并非总是顺利的，有时需要后期手动调整生成的项目文件，以解决迁移过程中产生的问题。下一部分将讨论最常见的一些问题。 

注：如果想要了解CCSv3.3与CCSv4之间的所有差异，请参阅网址：“Migrating to CCSv4（迁移到 CCSv4）” 

操作步骤如下：

①选择“Project->Import Legacy CCSv3.3Project（项目->导入旧版CCSv3.3项目）”，启动向导。 




图4.1 导入旧版 CCS 项目向导菜单

②指定要导入的CCSv3*.pjt文件。单击“Select a Project File:（选择项目文件:）”，再单击“Browse...（浏览...）”，选择要转换的.pjt文件。 

· 选中“Copy projects into workspace（将项目复制到工作区）”复选框可将项目及关联文件复制到CCSv4工作区中。这样做可以依原样保持原始项目。 

· 有些示例项目（安装在C:\tidcs、Stellarisware和NDK中的C2000示例）与原始项目位置相对的目录有一定的相关性。在这种情况下，建议选择“Keep original location for each project（保持每个项目的原始位置）”以保持相对路径不变。 

可选：一次可以转换多个项目。选择“Select Search-directory:（选择搜索目录:）”，再单击“Browse...（浏览...）”选择文件夹，在其中递归查找要导入的CCSv3 项目。任何符合条件、能够导入的项目都将显示在“Discovered legacy projects（已找到的旧版项目）”列表中。 




图4.2 导入单个项目




图4.3 导入多个项目

③在下一个屏幕中可以选择要使用的代码生成工具版本。多数情况下可以保留CCSv4提供的默认版本。单击“Next（下一步）”。 




图4.4 选择代码生成工具版本

④指定要使用的DSP/BIOS版本。多数情况下可以保留CCSv4提供的默认版本。单击“Finish（完成）”。 

重要说明！如果计划使用实时分析 (RTA) 和实时对象查看器 (ROV)（替代内核对象查看器）这两种BIOS调试工具，就必须使用默认版本。 




图4.5 选择 DSP/BIOS 版本

⑤向导完成转换过程后，新生成的CCSv4项目就会出现在工作区内。 

4.2.2导入CCE项目或以前版本的CCSv4项目 

尽管CCE和所有版本的CCSv4都有着相同的项目格式，Eclipse仍然要求导入这些项目，以保持与当前安装版本一致的相关性，例如包含目录、工具版本等。 

重要说明！直接将项目复制到工作区看似是一种不错的方法，但我们不建议这样做。 

操作步骤如下：
①此过程和第一部分介绍的项目导入过程非常类似。转到菜单“File -> Import Existing CCS/CCE Eclipse Project（文件->导入现有的CCS/CCE Eclipse项目）”。 

②有两种导入项目的方法。 

· 要导入某个现有目录下的一个或多个项目，请选中“Select root directory（选择根目录）”选项。单击“Browse（浏览）”选择包含项目目录的目录。任何有效的项目都会显示在“Projects:（项目:）”框中： 




图4.6 选择项目目录

· 要导入某个zip文件中的一个或多个项目，请选中“Select archive file:（选择存档文件:）”选项。单击“Browse（浏览）”选择包含项目的zip文件。选择了文件之后，任何有效的项目都会显示在“Projects:（项目:）”框中： 




图4.7 选择项目存档文件

4.2.3可能需要的其他步骤
有时在迁移过程中向导并不会冒险去改动一些具体的内容，这时可能就需要您多加留意并解决这类问题。 

在大多数情况下，需要执行的更改位于内部的源文件或链接器命令文件中；由于向导在迁移过程中采用了保守的做法，因此不会直接修改这些类型的文件。 

①例如，将会显示如下的消息框，<migration.log> 文件位于项目目录下。强烈建议打开此日志文件检查是否存在任何问题。 




图4.8 迁移警告

②CCSv3.3中有些项目拥有自动导入的隐式包含目录，会引发生成错误。如果遇到这种情况，请务必转到菜单“Project -> Properties（项目-> 属性）”移除这些路径，并在“Compiler -> Include Options（编译器 -> 包含选项）”或“Linker -> File Search Path（链接器-> 文件搜索路径）”下检查包含目录。 

在下面的例子中，编译器的包含目录拥有两个版本的芯片支持库 (CSL)。 



图4.9 项目生成错误 - 控制台
4.3创建项目
4.3.1简介 
本部分说明了在CCSv4中创建项目的一般步骤。标记为教程：的句子会创建示例程序，帮助您了解CCSv4的功能。 

4.3.2创建项目 

欢迎屏幕关闭之后，将会显示下面的工作区，此时可以创建新项目。 

①转到菜单“File -> New -> CCS Project（文件->新建-> CCS项目）”。 



图4.10 创建新项目

②在“Project Name（项目名称）”字段中，键入新项目的名称。若选中“Use default location（使用默认位置）”选项（默认启用），将会在工作区文件夹中创建项目。取消选中该选项可以选择一个新位置（使用“Browse...（浏览...）”按钮）。单击“Next（下一步）”。 




图4.11 命名新项目

教程：将项目命名为 Sinewave，然后单击“Next（下一步）”。 

③在“Project Type:（项目类型:）”下拉菜单中选择要使用的体系结构。单击“Next（下一步）”。 

注意：将在步骤5中选择具体设备。 

· 如果项目针对的是Cortex设备（Stellaris 或 Hercules），请选择“ARM”。 

· 如果项目针对的是SoC设备（DaVinci、OMAP），请根据所使用的芯片核选择“ARM”或“C6000”。 

可选：还可以在此屏幕中为项目选择或添加生成配置。默认情况下，“Debug（调试）”和“Release（发布）”处于启用状态。 




图4.12体系结构选择

教程：选择“C6000”，然后单击“Next（下一步）”。 

④通常可留空，但是如果该项目依赖于需要首先生成的其他项目（例如静态库项目），请在此处选择这些相关项目。单击“Next（下一步）”。 




图4.13 定义项目相关性
可选。“C/C++ Indexer（C/C++ 索引器）”选项卡可配置索引器的级别。索引器是 CCSv4 的一项功能，用于创建源代码信息列表，这些信息可支持编辑器中的自动完成和“转到定义”功能。默认选项为“Full C/C++ Indexer（完整 C/C++ 索引器）”，该选项可提供最多的功能。  
教程：只需单击“Next（下一步）”即可。 

⑤在接下来的这一屏幕中，大部分选项都可保留为默认值。根据所做的选择，将会显示其他屏幕。 

· “Device Variant（设备变量）”：根据步骤 3 中指定的设备系列选择要使用的设备。某些系列（如 C6000）的设备通用性较强，而其他一些系列（如 MSP430）的设备则与具体应用密切相关。第一个下拉框为常规筛选器，而第二个下拉框则为设备选择器本身。 

· “Target content（目标内容）”：启用对 BIOS 实时操作系统的支持。此部分的 GSG 将不使用该选项，但您可跳转到 GSG：使用 BIOS 部分以了解有关此选项的更多信息。 




图4.14 项目选项

教程：选择“Generic C674x Device（通用 C674x 设备）”，然后单击“Finish（完成）”。 

可选。其他选项可保留为默认值。 

· “Output type（输出类型）”：将设置保留为“Executable（可执行）”以生成完整的程序。另一个选项为“Static Library（静态库）”，静态库是其他项目要使用的功能的集合。 

· “Code Generation tools（代码生成工具）”：保留默认设置（除非安装了其他版本的代码生成工具且要使用某个特定版本）。 

· “Output Format（输出格式）”：通常此选项以灰色显示为“legacy COFF（旧 COFF）”。目前只有 ARM 系列还允许选择另外一个选项“eabi (ELF)”。 

· “Linker Command File（链接器命令文件）”：可留空，链接器命令文件可在稍后添加。如果存在可用的有效文件，系统将会预填充该字段。如果项目使用 BIOS，则将自动添加链接器命令文件。 

· “Runtime Support Library（运行时支持库）”：通常将其保留为“<automatic>（<自动>）”，因为代码生成工具会自动选择正确的运行时库。如果需要，可在此处选择其他运行时支持库。 

· “Treat as an Assembly-only project（视为仅汇编项目）”：通常将其取消选中。正如其名称所示，如果项目中没有 C 源代码文件，请选中此复选框。选中此复选框后，系统还将从项目中移除运行时支持库。 

⑥单击“Finish（完成）”创建项目。所创建的项目将显示在“C/C++ Projects（C/C++ 项目）”选项卡中，可随时用于创建或添加源文件。 

⑦要为项目创建文件，请在“C/C++ Projects（C/C++ 项目）”视图中右键单击项目名称，并选择“New -> Source File（新建 -> 源文件）”。在打开的文本框中，键入包含与源代码类型对应的有效扩展名（.c、.C、.cpp、.c++、.asm、.s64、.s55 等）的文件名称。单击“Finish（完成）”。 

可选：CCSv4 附带了一个易用的代码模板，可从编辑器中使用该模板： 

· 如果使用 MSP430，请在刚创建的空白源文件中键入字母“b”。然后同时按 <Ctrl 键>-<空格键>，添加“Blink LED”示例代码。 

· 如果使用其他设备系列，请在刚创建的空白源文件中键入字母“h”。然后同时按 <Ctrl 键>-<空格键>，添加“Hello world!”示例代码。 

代码模板是可使用编辑器“内容辅助”功能引用的代码的模板。也可以创建自定义代码模板。这是快速入门 Code Composer Studio IDE 的一种方式。 

⑧要向项目添加现有源文件，请在“C/C++ Projects（C/C++ 项目）”选项卡中右键单击项目名称，并选择“Add Files to Project（将文件添加到项目）”，将源文件复制到项目目录。:也可以选择“Link Files to Project（将文件链接到项目）”来创建文件引用，这样可以将文件保留在其原始目录中。如果源代码将文件包含在非常特定的目录结构中，则这是十分必要的。

教程：添加位于以下目录的源代码 <sinewave_int.c> 和链接器命令文件 <C6748.cmd>：:C:\Program Files\Texas Instruments\ccsv4\C6000\examples 

4.3.3生成项目 

在创建了项目并且添加或创建了所有文件之后，需要生成项目。 

①只需转到菜单“Project -> Build Active Project（项目 -> 生成活动项目）”。 

“Rebuild Active Project（重新生成活动项目）”选项可重新生成所有源文件和引用的项目。不过如果项目较大，这可能是一个漫长的过程。 

注意：如果遇到生成错误，而且没有创建可执行文件，屏幕底部的控制台窗口将会显示一条错误或警告消息，并且不会启动调试会话。 

4.3.4 配置生成设置 

要配置生成设置，请在“C/C++ Projects（C/C++ 项目）”视图中右键单击项目，并选择“Build Properties...（生成属性...）”。有多个适用于编译器、汇编器和链接器的选项。 

4.4 项目调试

本部分说明了在CCSv4中创建目标配置和调试项目所需的一般步骤。标记为教程:的句子说明了对上一部分中创建的示例程序进行调试的具体步骤。 

4.4.1 启动调试器之前
在启动调试器之前，需要选择并配置代码将要执行的目标位置。目标可以是软件模拟器或与开发板相连的仿真器。 

· 软件模拟器不需要外部硬件，对于执行基准和算法验证十分有用。有关模拟技术的其他信息，请参阅以下链接：http://processors.wiki.ti.com/index.php/Category:Simulation 

· 仿真器是用于直接对硬件进行调试的硬件设备，可以内置到开发板（DSK、eZdsp、EVM 等），也可以采取独立形式（XDS100v2、XDS510 USB、XDS560 等）。有关仿真技术的其他信息，请参阅以下链接：
http://processors.wiki.ti.com/index.php /Category:Emulation 

注意：如果您熟悉CCSv3.3，应该知道目标配置是通过外部程序CCSetup来完成的。而在CCSv4中，这种配置在IDE内部完成，它不仅可以创建整个系统范围的配置，还可以创建各个项目的单独配置。这样做还有一个好处，就是在每个目标配置更改后无需重新启动CCS。

教程: 本例中将使用模拟器。 

以下介绍如何创建目标配置文件：
CCSv4提供了一个十分简单易用的图形目标配置编辑器，它提供多个预配置的设备和开发板，而且还可以在自定义硬件中使用。 

每个项目可以拥有一个或多个目标配置，但只能有一个处于活动状态。 

可选。CCSv4还允许创建一个系统范围的目标配置，以便可以在各个项目之间进行共享。 
①右键单击项目名称，并选择“New -> Target Configuration File（新建 -> 目标配置文件）”。 



图4.15 创建新目标
②为配置文件命名-将会添加扩展名.ccxml。建议根据所使用的目标和仿真器指定一个有意义的名称，例如，如果使用的是F28335设备和XDS510USB仿真器，就可以命名为F28335_XDS510USB。 

可选。如果选中“Use shared location（使用共享位置）”选项，新的目标配置将在所有项目之间共享，并存储在默认的CCSv4目录下。 

教程: 由于将会使用模拟器，因此请将新配置命名为“C6748_sim”。 

③单击“Finish（完成）”。此时将打开目标配置编辑器。 



图4.16 目标配置编辑器
④目标中有两项元素是必须配置的： 

· 通过“Connection（连接）”下拉菜单可以选择是使用一个软件模拟器，还是使用多种内置或独立仿真器。有关如何配置常见目标的说明，请查 GSG：常见目标配置部分。 

· “Device（设备）”部分包含与所选连接兼容的所有设备。上部的框是筛选器，可以帮助在下部框中的浏览表中选择正确设备。 

教程: 选择“Texas Instruments Simulator（Texas Instruments 模拟器）”作为连接，选择“C674x CPU Cycle Accurate Simulator, Little Endian（C674x CPU 周期精确模拟器，小端字节序）”作为设备。 

⑤选择设备后，单击“Save（保存）”按钮。该配置将自动设置为“Active（活动）”。 

每个项目可以拥有多个目标配置，但只能有一个处于活动状态，该配置将会自动启动。 

注意：要查看系统现有的所有目标配置，只需转到菜单“View -> Target Configurations（查看 -> 目标配置）”。 

4.4.2 启动调试器
创建配置之后，可通过转到菜单“Target -> Debug Active Project（目标 -> 调试活动项目）”启动调试器。将会打开“Debug Perspective（调试透视）”，专为调试定制的一组专用窗口和菜单。 

注意：如果对源代码或生成选项进行了修改，启动调试器可能会导致CCSv4生成活动项目。 

（1）加载代码
调试器完成目标初始化之后，项目的输出文件.OUT将自动加载到活动目标，并且默认情况下代码将在main()函数处停止。 

注意：代码将自动写入MSP430、F28x和Stellaris设备闪存中。要配置闪存加载程序属性，请启动调试器并转到菜单“Tools -> On-chip Flash（工具-> 片内闪存）”。 




图4.17 设备连接、调用堆栈和源代码

· “Debug（调试）”视图包含每个芯片核的目标配置和调用堆栈。 

· 源代码视图显示了在 main() 处停止的程序。 

· 基本调试功能（运行、停止、步入/步出、复位）位于“Debug（调试）”视图的顶部栏中。“Target（目标）”菜单还有其他几种调试功能。 

教程: 通过转到菜单“Target -> Debug Active Project（目标 -> 调试活动项目）”启动调试器。 

注意：如果目标配置需要先运行脚本再加载代码，将打开“Console（控制台）”视图。这些脚本采用GEL（通用扩展语言）编写而成，在对包含复杂外部内存时序和电源配置的设备进行配置时尤其需要此类脚本。 



图4.18 GEL输出
教程: 在模拟器中未使用任何GEL文件。 

（2）监视变量和寄存器
在程序加载时还会打开“Local（本地）”和“Watch（监视）”视图，并显示本地和全局变量： 




图4.19 查看变量

教程: 上面的屏幕截图显示了 <sinewave_int.c> 的 main() 函数中的变量。 

默认情况下不会打开寄存器视图，但是可通过转到菜单“View-> Registers（查看->寄存器）”进行查看。 




图4.20 查看寄存器

教程: 上面的屏幕截图显示了典型 C674x 设备的所有外设寄存器，但是本例中所选的模拟器不模拟外设。 

（3）反汇编以及源代码与汇编代码混合模式
默认情况下不会打开反汇编视图，但是可通过转到菜单“View ->Disassembly（查看->反汇编）”查看。 

反汇编窗口中一个极其有用的功能是源代码与汇编代码混合模式查看器，如上面的屏幕截图所示。要使用此功能，只需在“Disassembly（反汇编）”视图中右键单击并选择“View Source（查看源代码）”。 



图4.21 源代码/汇编代码混合视图
教程: 该屏幕截图显示了 <sinewave_int.c> 的 main() 函数的开头部分。 

（4）内存查看器
默认情况下不会打开内存视图，但是可通过转到菜单“View -> Memory（查看 -> 内存）”查看。 

通过此屏幕可访问一些有用的功能：内存可通过多种格式进行查看，可填充任意值，也可保存至PC主机中的二进制文件或从中加载，此外还可以查看所有变量和函数，而且每个内存位置都有上下文相关的信息框。



图4.22 查看内存

教程: 该屏幕截图显示了分配在内存中的变量 volatile short output[16]。其他所有变量均为本地变量，因此分配在堆栈中。 

（5）管理断点
作为任何调试器都会拥有的最基本功能，CCSv4 中的断点添加了一系列选项，帮助增加调试进程的灵活性。 

· 硬件断点可从 IDE 直接进行设置； 

· 软件断点仅受到设备可用内存的限制； 

· 软件断点可设置为无条件或有条件停止； 

· 除了停止目标之外，软件断点还可执行其他功能：文件I/O传输、屏幕更新等。 




图4.23 断点选项

要设置断点，只需在源代码或反汇编视图中双击代码行即可。硬件 

或软件 

断点的图标会指示其状态和放置位置。 

注意：在优化代码中，有时无法将断点设置到C源代码中确切的某一行。这是因为优化器可能会将代码紧缩起来，从而影响汇编指令和C源代码之间的相关性。 

所有断点（软件、硬件、已启用、已禁用）都可在断点查看器中看到。 




图4.24 断点查看器

要配置断点，只需右键单击蓝点，或者在断点视图中右键单击并选择“Breakpoint Properties...（断点属性...）”。 

· 使用“Action（操作）”可以设置断点的行为，例如保持停止、更新一个或所有调试器视图、从文件中读取数据或将数据写入其中、激活或停用断点组等。 

· 使用“Skip Count（跳过计数）”可以设置执行断点操作之前通过的数目。 

· 使用“Group（分组）”可以对断点进行分组以进行高级控制。 

教程: 在第18行放置一个断点。该断点的属性将在下一部分中进行设置。 

（6）图形显示工具
CCSv4中提供了一个高级图形和图像可视化工具。它可通过图形形式显示数组，并且可采用多种格式。 
要添加图形，只需转到菜单“Tools -> Graph（工具 -> 图形）”，然后从各种显示选项中选择一个。 

· 基于时间的图形：“Single Time（单曲线图）”和“Dual Time（双曲线图）” 

· 基于频率的图形：所有 FFT 选项 

图形窗口中的顶部工具栏可控制多种功能，例如更新速率（冻结、连续、目标停止时或手动）、缩放、配置属性等。 




图4.25 图形工具栏

默认情况下，图形窗口会在目标停止时立即更新、使用自动缩放并以样本数显示X轴，以整数值显示Y轴。所有这些选项都可进行设置。 

注意：请记住，图形更新时所传输的数据量可能会影响目标硬件的实时操作。 

教程: 下面的过程显示了包含正弦波发生器输出内容的图形。 

· 在源代码窗口中，右键单击断点蓝点（已在上一部分设置）并选择“Breakpoint Properties...（断点属性...）”。 

· 在“Action（操作）”属性中，单击该属性值并选择“Refresh All Windows（刷新所有窗口）”。这样将刷新所有窗口，而不是将程序完全停止在该点。 

· 变量 output[] 包含 16 个正弦波发生器输出样本，因此整个缓冲区必须立即显示在图形窗口中。单击“Tools -> Graph -> Single Time（工具 -> 图形 -> 单曲线图）”，然后将选项配置如下： 
	属性
	值

	采集缓冲区大小
	16

	Dsp 数据类型
	16 位带符号整数

	Q_value
	15

	开始地址
	output


· 屏幕底部应该出现一个图形窗口。如果需要，可通过单击 


按钮更改图形属性。 

· 单击“Target -> Run（目标 -> 运行）”。该图形应该以 16 个样本为一组分批更新。 

· 要查看 output 数组的实际值，请单击“Watch（监视）”选项卡（应当在屏幕右上角部分），然后单击“New（新建）”。键入 output 并展开此数组以显示其中的所有值。这些值以 16 位带符号整数输出，因此可通过调整 Q 值使其标准化：在“Watch（监视）”窗口中选择所有值，右键单击并选择“Q-values -> Q-value(15)（Q 值 -> Q 值(15)）”。 




图4.26 正弦波示例
（7）图像显示工具
要显示图像，只需转到菜单“Tools -> Image（工具 -> 图像）”。 

屏幕底部将打开两个视图：“Image（图像）”和“Properties（属性）”。 

CCSv4 显示的信息既可以是来自PC主机中的文件，也可以是目标开发板中加载的图像。在属性页面中，只需将“Image source（图像源）”选项设置为“File（文件）”或“Connected Device（连接的设备）”即可。 

与图形查看器类似，需要设置其他所有属性才能使显示内容有意义。彩色障板、线条尺寸和数据宽度等几种选项会影响图像的正确显示。 

教程: 要显示加载至目标的图像，请执行以下操作： 

· 转到菜单“View -> Memory（查看 -> 内存）”打开内存视图。 

· 在地址框中键入有效的目标地址：0xC0000000 

· 将图像文件 <sample_24bpp.dat> 加载至 0xC0000000：单击内存操作图标 


旁边的三角形，然后单击“Load（加载）”。浏览至下面的目录，然后单击“Next（下一步）”。 C:\Program Files\Texas Instruments\ccsv4\c6000\examples 

· 键入与内存窗口中相同的起始地址，并将“Type-size（类型大小）”设置为 32 位。 

· 按下图所示设置属性： 




图4.27 图像属性

· 选择“Image（图像）”选项卡，然后右键单击并选择“Refresh（刷新）”。应该会显示下面的图像。 




图4.28 图像显示

另外还提供了其他一些调试器功能和视图。强烈建议您尝试一下所有这些选项，了解调试器的所有功能。 
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