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1、CCSv4简介 

因为 Code Composer Studio v4.0 (CCSv4) 现在是基于 Eclipse 3.2 IDE 开源软件框架的新版本，所以与所有旧版 C2000 Collateral 所基于的 Code Composer Studio v3.x (CCSv3.x) 相比，两者之间存在多处差异。本手册详细介绍了如何安装CCS，注册CCS许可证，以及如何将 C2000 Collateral 从 CCSv3.x 迁移到 CCSv4，并帮助用户开始建立第一个 CCSv4.0 程序。 

2、安装CCSv4

2.1 最低配置

•  1.5 GHz Pentium-compatible CPU

•  1 GB内存
•  300 MB 硬盘(精简安装)

•  DVD-ROM 光驱

2.2 建议配置

•  双核处理器

•  2 GB内存

•  2 GB 硬盘 (典型安装)

2.3 CCSv4所支持的操作系统
•  Windows XP

•  Windows Vista 
•  Windows 7 (具体支持的程度取决于CCS IDE的版本，请查阅CCS IDE的发布手册来确认是否支持Window7操作系统)

2.4 安装过程

1. 将DVD光盘插入到DVD光驱中。

2. 运行光盘中的“setup_CCS_4.1.0.02000.exe”。

3. 出现安装画面，点击Next
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4. 点击Next
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5.选择I accept the terms of the license agreement，点击Next
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6.根据您所使用的TI的平台，选择合适的版本，针对C2000，请选择Microcontroller Edition，点击Next
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7．针对C2000，请选择C28x 32-bit Real-time MCUs，点击Next
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8.按照默认的设置，点击Next，默认情况下，已安装XDS560、XDS100、Spectrum Digital、Blackhawk仿真器的驱动。
[image: image6.png]Code Composer Studio v4 Setup
Select Components

Select the components you want o install and desslect the components
ou do ot wank to nsta.

A Descrpton
¥DCtock, 5 s

0AIS
Emators
xossen
05100
Spectrum Digtal
Blackhank
Documentation

1,12.68 of space required to nstal selected configuration.
25,81 GE s avaleble on the current cive,





9．点击Next，开始安装CCSv4.
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10.点击Finish，完成CCSv4的安装。
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3、激活CCSv4

CCSv4可以在以下网址上下载：

http://focus.ti.com/docs/toolsw/folders/print/ccstudio.html 
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其中有两种免费的版本：

1. XDS100，限制许可证。这个许可文件是指在利用XDS100进行板级在线仿真时是完全免费的，XDS100可以针对所有C2000的芯片进行板上仿真。点击CCS-FREE，进行下载。
2．MCU版本，32K代码限制。对于所有C2000芯片，此版本只允许编译32K代码范围内的程序。注：此版本不包含DSP/BIOS。
3．其他有关CCSv4注册许可的详解，请参照附录A的相关内容。

4、在 CCSv4 中运行第一个C2000项目
4.1 选择工作区 
首次启动 CCSv4 时，将显示一个对话框，提示您选择工作区。该工作区是一个文件夹，用于保存特定个人计算机的所有 CCSv4 自定义设置。这些自定义设置中包括关闭 CCSv4 时的所有项目设置、宏和视图。例如，如果关闭 CCSv4 时您正同时处理多个项目，开着多个内存窗口和图形窗口，而且正在使用着多个监视变量，则当您重新打开 CCSV4 时，将显示与关闭前相同的项目和设置。 




关闭 CCSv4 时，工作区将自动保存。如果不希望覆盖当前工作区的设置，则可以通过转至以下菜单选项打开或切换到新的工作区：“File -> Switch Workspace（文件 -> 切换工作区）”。 

请注意，在 CCSv4 中，工作区不可移植，因为工作区中包含您个人计算机系统的特定数据。所以，您不能保存一个工作区，进行压缩，然后再发送给另一位用户。
4.2 运行CCSv4 cpu_timer project 
1． 打开“C2802x C/C++ Header Files and Peripheral Examples”（v1.26 或更高版本）附带的 CCSv4 cpu_timer 项目 

2． 转至“Project -> Import Existing CCS/CCE Eclipse Project（项目 -> 导入现有 CCS/CCE Eclipse 项目）”。 





3． 单击“Select root directory:（选择根目录:）”旁边的“Browse（浏览）”按钮，浏览到“<header file base>/DSP2802x_examples_ccsv4/cpu_timer”目录文件夹，然后选择“OK（确定）”。请确保已在“Projects:（项目:）”文本框中选中“Example_2802xCpuTimer”。请勿选中“Copy projects into workspace（将项目复制到工作区）”复选框。单击“Finish（完成）”按钮。
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4． 您现在位于 C/C++ 透视视图中，项目文件将显示在“C/C++ Projects（C/C++ 项目）”窗口中。 
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5． 为设备仿真设置目标配置选项 

· 在当前示例中，要设置仿真器目标配置，请转至“Target -> New Target Configuration（目标 -> 新建目标配置）”。 

· 请键入目标配置文件的名称，该文件的后缀为“.ccxml”。选中“Use default location（使用默认位置）”复选框，然后选择“Finish（完成）”。 
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· 在显示的窗口中，通过“Connection（连接）”下拉列表选择仿真器，然后在“Device（设备）”列表中选择设备。在本示例中，已经选中“Texas Instruments XDS100v1 USB Emulator”和“TMS320F28027”设备复选框。 
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· 然后，转至“File -> Save（文件 -> 保存）”。 

· 现在，转至“View -> Target Configuration（查看 -> 目标配置）”。 

· 在“User-Defined”下，将显示新的目标配置 .ccxml 文件，右键单击该文件。 

· 选择“Link File to Project -> Example_2802xCpuTimer（将文件链接到项目 -> Example_2802xCpuTimer”，将在工作区中的特定项目始终使用该目标配置。 

· 或者，选择“Set as Default（设置为默认值）”（该默认设置适用于：希望以后在所有工作区中打开的未指定目标配置的项目都默认使用此仿真器和设备 GEL 文件）。 
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· 在 Binaries 下 - 建立项目后，项目的 .out 文件位于此处。 

· 在 Includes 下 - 生成选项所引用的 Include 指令的所有目录都在此处列出。展开目录将列出这些目录中所有的 .h 和 .inc 文件，项目也可能不会使用这些文件。 

· 在 Debug 下 - 所有调试文件（包括 .map 和 .obj 文件）都位于此处。 

· 之后将列出所有源文件。如果有任意源文件包含函数、include 文件或结构，选择位于源文件旁边的“+”号，将列出该文件中包含的所有函数、include 文件和结构名称。双击函数名，将转到在源代码中定义函数、include 文件和结构的位置。 

6． 生成和加载项目 

· 将所有活动项目一次性全部加载到目标中

要构建项目，请首先连接到目标，将所有活动项目一次性全部加载到目标中，然后单击工具栏上的绿色昆虫图样按钮，即“Debug（调试）”。接着跳到下方的“重置 CPU”步骤。 





· 不自动连接目标
要构建项目，但不自动连接目标并将活动项目对象代码加载到设备，请转至“Project -> Build Active Project（项目 -> 建立活动项目）”。 




然后，选择工具栏上绿色昆虫图样按钮旁边的向下箭头，然后选择“Launch TI Debugger（启动 TI 调试程序）”，此时将位于“Debug（调试）”透视视图中。 




转至“Target -> Connect Target（目标 -> 连接目标）”，连接到目标设备。 




转至“Target -> Load Program（目标 -> 加载程序）”，然后浏览到“Example_2802xCpuTimer.out”（位于“/cpu_timer/Debug”目录中）。 

7． 重置 CPU 

依次选择“Target -> Reset -> Reset CPU（目标 -> 重置 -> 重置 CPU）”，重置设备。要重新启动程序，请依次选择“Target -> Restart（目标 -> 重新启动）”。 

8． 将监视变量添加到监视窗口 

· 如果“Example_2802xCpuTimer.c”尚未打开，请在屏幕的右上角，单击 C/C++ 小图标，切换回“C/C++”透视视图，然后打开源文件。此时，单击屏幕右上角绿色昆虫图样旁边的“Debug（调试）”小图标，切换回“Debug（调试）”透视视图。 




· 在“Example_280xxCpuTimer.c”中，在位于文件顶部的注释中向下滚动，直到到达“Watch Variables（监视变量）”。突出显示“CpuTimer0.InterruptCount”，单击右键，然后选择“Add Watch Expression（添加监视表达式）”。之后，请依次对“CpuTimer1.InterruptCount”和“CpuTimer2.InterruptCount”重复执行上述步骤。现在，这些变量将显示在监视窗口中。 





9． 启用实时模式以在监视变量发生变化时进行监视 

· 转至“Tools -> Debugger Options->Generic Debugger Options（工具 -> 调试程序选项）”。在打开的窗口中，向下滚动到“Realtime Options（实时选项）”，然后选择“Enable silicon real-time mode (service critical interrupts when halted, allow debugger accesses while running)（启用硅片实时模式(停止时关键服务中断，允许调试程序在运行时访问)）”。如果弹出一个对话框，询问是否允许实时切换，请选择“Yes（是）”。 




· 在“Watch”监视窗口的右上角，单击白色向下箭头，然后选择“Customize Continuous Refresh Interval…（自定义持续刷新时间间隔…）”。将持续刷新时间间隔更改为“1”（秒），替换默认值“5”（秒）。 




· 在监视窗口的右上角，单击暂停符号上以环形旋转的黄色箭头图标，启用持续刷新模式，让系统在程序运行时持续刷新监视变量。 




9． 运行程序 

· 选择工具栏上的绿色箭头图标，或者转至“Target -> Run（目标 -> 运行）”。 




· 观察位于监视窗口中的变量在 CPU 定时器中断时每秒增加一次。 
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· 祝贺您！您刚刚在 CCSV4 中运行完第一个 C2000 项目！ 

5、将C2000项目从CCSv3.3迁移到CCSv4 
使用 Code Composer Studio v4，用户可以将项目从 CCSv3.3 迁移到 CCSv4，而且用户可根据需要一次迁移一个或多个项目。通过这种方式，如果在一个目录中存在多个需要从 CCSv3.x 迁移到 CCSv4 的项目，则可以轻松地一次性迁移所有项目。 

· 要开始迁移进程，请转至“Project -> Import Legacy CCSv3.3 Project（项目 -> 导入旧版 CCSv3.3 项目）”，打开“Project Migration Wizard（项目迁移向导）”。 




5.1 将一个项目从CCSv3.3迁移到CCSv4 
· 在“Project Wizard（项目向导）”中，选择“Select Project:（选择项目:）”单选按钮，然后浏览到要迁移的 CCSv3.3 .pjt 项目文件。在下图中，已选中 Example_2802xCpuTimer.pjt 文件。然后单击“Next（下一步）”按钮。 
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· 请选择构建所选项目所需的“Code Generation Tool（代码生成工具）”的版本。 
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· 如果旧版项目中包含对 DSP/BIOS 的引用，则请将其删除，即使项目并不使用 DSP/BIOS，也请执行此项操作（有关详细信息，请参阅 C2000 Code Composer Studio v4 入门#应用 DSP BIOS 所引起的源文件缺失）。如果您要使用 DSP/BIOS，则请选择适用于项目的 DSP/BIOS 工具版本。默认条件下，虽然 C2000 示例不使用 DSP/BIOS，但由于 .PJT 文件中包含一个对“DspBiosBuilder”的空引用，迁移向导将选择默认的 DSP/BIOS 工具版本。单击“Next（下一步）”按钮。 
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· 取消选中“Use common root for all migrated projects（对所有已迁移项目使用公共根目录）”，使 CCS 自动确定项目所引用的所有文件的唯一公共根目录，然后单击“Finish（完成）”。（有关为项目迁移和已生成的 macros.ini 文件定义“公用根目录”的详细信息，请参阅 CCSv4 中针对 C2000 的可移植项目）。 
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祝贺您！您已经将一个 CCSv3.x 项目成功迁移到 CCSv4。您现在可以从项目文件夹中删除所有文件，无需保存 CCSv3.3 .pjt 文件,但下列文件除外： 

1. .cdtproject 

2. .cdtbuild 

3. .project 

4. 项目目录中的所有源文件和头文件（.c、.asm、.h、.inc、.cmd、.lib 等） 

5.2 将多个项目同时从CCSv3.3迁移到CCSv4 
· 在“Project Wizard（项目向导）”中，选择“Select search-directory:（选择搜索目录:）”单选按钮，然后浏览到要迁移的所有或部分 CCSv3.3 项目文件夹所在的目录。在下图中，选择的目录为：“C:/tidcs/c28/DSP2802x/v126/DSP2802x_examples/”。迁移向导随后将搜索所选目录下的所有旧版项目，而且这些项目也会显示在“Discovered Legacy Projects:（发现的旧版项目:）”框中。选中要迁移的项目，然后单击“Next（下一步）”按钮。 

· 下一步，选择构建所选项目所需的“Code Generation Tools（代码生成工具版本）”（与单个项目迁移相同）。 

· 如果旧版项目中包含对 DSP/BIOS 的引用，则请选择适用于项目的 DSP/BIOS 工具版本。默认情况下，虽然 C2000 示例不使用 DSP/BIOS，但由于 .PJT 文件中包含一个对“DspBiosBuilder”的空引用，迁移向导将选择默认的 DSP/BIOS 工具版本，单击“Next（下一步）”按钮。（与单个项目迁移相同） 
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· 下一步，选择构建所选项目所需的“Code Generation Tools（代码生成工具）”版本（与单个项目迁移相同）。 

· 如果旧版项目中包含对 DSP/BIOS 的引用，则请选择适用于项目的 DSP/BIOS 工具版本。默认情况下，虽然 C2000 示例不使用 DSP/BIOS，但由于 .PJT 文件中包含一个对“DspBiosBuilder”的空引用，迁移向导将选择默认的 DSP/BIOS 工具版本，单击“Next（下一步）”按钮。（与单个项目迁移相同） 

· 在“Set Advanced Options（设置高级选项）”窗口中，选中“Use a common root for all migrated projects（对所有迁移项目使用公用根目录）”复选框。对于包含多个项目且其文件共享公用根目录的情况，请选中此复选框。 
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例如，下图显示了要迁移项目的目录文件结构。此示例中，要迁移的所有项目都位于“DSP2802x_examples”目录中的单独文件夹中。所有这些项目在 DSP2802x_common 和 DSP2802x_headers 目录下包含公用头文件、源文件和库，这两个目录又位于“v126”根目录下。 

因为所有迁移项目都使用“C:/tidcs/c28/DSP2802x/v126”根目录下的公用文件，所以指定的“路径”应为“C:/tidcs/c28/DSP2802x/v126”。同时也请选择一个唯一的“路径变量名”，代替键入整个路径的宏/替换名称。在此示例中，选择的是“COMMON_ROOT”。 

注：在指定工作区中，对某个特定路径只能定义一次路径变量名/宏。也就是说，不能将同一工作区中不同路径下的另一项目再次定义为“INSTALLROOT_2833X_V130”。而必须定义不同的路径变量/宏。您可以在下一页面中更加详细地了解从用户到用户，或从个人计算机到个人计算机传输项目时有关宏及其无用情况的信息：Portable Projects in CCSv4 for C2000（CCSv4 中针对 C2000 的可移植项目）。 

完成后，单击“Finish（完成）”按钮。 
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祝贺您！您已经将多个 CCSv3.x 项目迁移到 CCSv4。现在您可以从项目文件夹中删除所有文件，无需保存任何 CCSv3.3 .pjt 文件。 但是下列文件除外： 

1. .cdtproject 

2. .cdtbuild 

3. .project 

4. 项目目录中的所有源文件和头文件（.c、.asm、.h、.inc、.cmd、.lib 等） 

6、C28x闪存编程 
CCSv4 对 CCSv3.3 的一项改进是闪存编程器插件现在内建于 CCSv4 中。当调试针对闪存配置了源代码和命令链接器文件的项目时，不再需要仅加载符号，然后单独使用闪存编程器插件将代码写到闪存中。取而代之的是，只要加载正确的设备目标配置，如果 CCSv4 通过您项目中的命令链接器文件检测到闪存中有代码，在加载程序时，它会自动将代码写入闪存。 

要在 CCSv4 中设置闪存编程设置并将程序写入闪存，请执行下列操作： 

1. 首先确保已经为您的设备正确设置了您的目标配置。 

2. 转至“Target -> Launch TI Debugger（目标 -> 启动 TI 调试程序）” 

3. 在“Debug（调试）”视图中，转至“Tools -> On-chip Flash（工具 -> 片上闪存）” 

4. 配置闪存设置 – 也可以在此处擦除闪存。 

5. 然后，可以：单击“Debug（调试）”昆虫图标，或转至“Target -> Debug Active Project（目标 -> 调试活动项目）”，或转至“Target -> Load program（目标 -> 加载程序）”并选择要编程的 .out 文件。CCSv4 IDE 将自动编程或将代码加载到闪存和/或 RAM 中相应的存储位置，类似于基于 RAM 的项目代码自动加载到 RAM 的方式。 
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注：与 CCSv3.3 一样，源代码和链接器命令文件仍然需要预先针对闪存选项进行配置（有关如何操作的说明，请参阅安装包中 /docs 文件夹内的设备特定 C/C++ 头文件和外围设备示例快速入门自述文件）。

7、C2000 GEL文件迁移 
来自 CCSv3.3 的设备 GEL 文件仍然能够用于 CCSv4.0。不再支持用于处理项目（即生成项目）的调用以及用于向监视窗口添加变量的“WatchAdd()”函数。GEL 热菜单项目现在出现在“Scripts（脚本）”下拉菜单中。 

有关 GEL 文件的更多信息，包括如何加载 GEL 以及哪些 GEL 函数仍受支持，请访问 CCSv4 GEL Wiki 网页：GEL 

设备 GEL 中的寄存器 WatchAdd() 由“View -> Registers（查看 -> 寄存器）”替换 

C2000 设备 GEL 文件包括用于所有外围设备寄存器的“WatchAdd()”函数，允许用户在不使用 TI 提供的 C/C++ 头文件时将任何外围设备的寄存器快速添加到 CCSv3 中的监视窗口。因为 WatchAdd() 函数在 CCSV4 中不再有效，现在可以通过“Registers（寄存器）”窗口使用外围设备寄存器，该窗口可从“View -> Registers（查看 -> 寄存器）”访问。如果在调试时使用 TI 提供的 C/C++ 头文件（可从 TI 网站的设备产品文件夹下载），在头文件中定义的寄存器结构也可以如以前一样添加到监视窗口。展开这些寄存器结构可访问单独的位字段（例如将“AdcRegs”添加到监视窗口将显示全部 ADC 寄存器以及它们的位字段扩展）。 
8、Control Suite软件说明
8.1 Control Suite简介
Control Suite对于C2000微处理器来说是一个多钟软件的集合，通过Control Suite用户可以显著地减少开发时间，软件中包含了很多特性可以增强软件的可用性。Control Suite既是一个学习平台也是一个开发平台，能够适应不同的用户的开发经验和编程偏好。
8.2 Control Suite特性
Control Suite的主要特性如下：

1． Control Suite是所有C2000软件的一个集合体

2． 智能安装从而减少了版本之间的依赖性和兼容性的问题。
3． 软件安装之后会产生直观的生成文件组织结构
4． 用户可以选择三种不同的MCU编程方案

5． 对于用户的整个设计阶段均提供模块化的软件库和历程

6． 针对典型应用领域的应用软件库和程序框架，例如数字电机控制和数字电源。
7． 完整的系统开发套件，硬件和软件完全源码开放。

8． 丰富的说明文档提供原理及执行的细致描述。 
8.3 Control Suite当前版本中的组件
开发套件
•    Piccolo controlSTICK (TMDX28027USB)

–   With Piccolo F2802x
•    High Voltage Motor Control Kit (TMDSHVMTRPFCKIT)

–   With Piccolo F2803x

–   With Delfino F2833x

•    High Voltage Power Factor Correction Kit (TMDSHVPFCKIT)

–   With Piccolo F2802x

•    Low Voltage Motor Control Kit (TMDS1MTRPFCKIT and TMDS2MTRPFCKIT)

–   With Piccolo F2803x

•    LED DC/DC Lighting Kit (TMDSDCDCLEDKIT)

–   With Piccolo F2803x

芯片支持包
•    Piccolo F2802x, Piccolo F2803x, Delfino F2833x, Delfino C2834x

–   Bit Fields

–   Peripheral Examples

–   Hardware Developer's Package

库
•    电机控制库
–   For C28x core (on all C2000 28x microcontrollers)

•    数字电源库
–   For C28x core (on all C2000 28x microcontrollers)

–   For Control Law Accelerator (CLA)

•    数学库
–   Fixed-Point (IQMath)

–   Floating Point (fastRTS Library)

–   CLA

•    工具
–   Flash API (for all Piccolo and Delfino devices

· Boot ROM source code (for all Piccolo and Delfino devices)
8.4 Control Suite支持的芯片

Control SUITE 现在支持所有的Piccolo 和Delfino 芯片, 具体芯片列表如下
•    TMS320F28035

•    TMS320F28034

•    TMS320F28033

•    TMS320F28032
•    TMS320F28031

•    TMS320F28030

•    TMS320F28027

•    TMS320F28026

•    TMS320F28023

•    TMS320F28022

•    TMS320F28021

•    TMS320F28020

•    TMS320F280200

•    TMS320F28335

•    TMS320F28334

•    TMS320F28332

•    TMS320C28346

•    TMS320C28345

•    TMS320C28344

•    TMS320C28343

•    TMS320C28342

•    TMS320C28341
8.5 Control SUITE下载及安装
1. 登陆www.ti.com/c2000，点击control SUITE

2. 点击下面的图标
[image: image38.png]



3. 注册一个TI的账户即可免费下载Control SUITE
4. 双击下载的controlsuiteinstaller.exe文件,出现以下界面，点击Next
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5． 选择 I accept the terms in the License Agreement, 点击Next
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6． 选择安装的路径，默认放在C:\TI下，建议安装在此路径下。点击Next
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7． 选择要安装的开发套件，点击Next
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8． 选择所选用的芯片系列，点击Next
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9． 选择项目中所需要添加的库，点击Next
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10． 选择是否自动更新Control SUITE，点击Next
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11． 上图中，列出了要安装的文件立标，点击Install，开始下载和安装所选文件。
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12． 点击Finish，完成安装，进入 ControlSUITE界面。

8.6 Control SUITE的桌面

Control SUITE桌面允许用户轻松地访问C2000的各种开发平台和各个芯片的硬件、软件以及说明文档，同时Control SUITE还可以帮助用户在线查询有关芯片的用户手册（User Guide）、应用文档（Application Notes）和一些培训的教程。
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8.7芯片、开发套件、库
Control SUITE桌面，包含了C2000的芯片，一些开发套件和库文件。其中芯片（Device）、开发套件（Kits）和库（Libraries）中分别包含了该选项的概览、历程、说明文档、在线资源和一些其他的有用的内容。
其中在Devices下，有Piccolo F2802x、Piccolo F2803x、Delfino F2833x、Delfino C2834x等产品系列，其中每个产品下都有相应的历程。例如在Piccolo F2802x下，有Examples Projects项目栏，双击其中的任何一个历程，可直接打开对应的程序目录；也可以通过双击View all 35+ example projects，打开Piccolo F2802x所有的历程目录。
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9、附录A—CCSv4的注册
要使用 Code Composer Studio (CCS)，您需要有许可证，而要使许可证生效，则需要将其激活。CCS 中包含多种不同的许可证选项，可以在 CCSv4 许可页面上找到有关这些选项的说明。如果是免费的 CCS 许可证，可以在 CCS 中直接激活。对于大多数购买的许可证，将向您提供激活 ID，然后需要访问 www.ti.com/activatesoftware 来生成许可证文件。 
激活说明

运行 CCS 时，CCS 将检测您是否已经安装许可证文件。如果未找到许可证文件，CCS 将弹出一个对话框，说明如何获取要使用的许可证文件。此许可证对话框还将显示您的主机 ID（MAC 地址），在激活过程中可能需要使用主机 ID。 

注：如果您以前安装过 CCSv4 并且已经获得许可证文件，则只需通过此对话框指向该许可证文件，然后单击“Continue（继续）”。 

完成激活后，即可返回到 CCS。此时，标题栏应显示“Licensed（已授权）”字样。如果显示的是“Unlicensed（未授权）”字样，则在下一次启动 CCS 时还将显示激活对话框。 

要激活 CCS，可通过以下几种方法： 
9.1 30 天评估版许可证 

可对 CCS 进行为期 30 天的使用评估。此许可证可以激活 CCS 的所有功能，为期 30 天。只需在许可证对话框中选择“Evaluate Code Composer Studio for 30 days（对 Code Composer Studio 进行 30 天评估）”选项。 




9.2 90 天评估版许可证延期 

30 天评估使用到期后，将需要生成并安装许可证文件。可以生成一个 90 天的评估版许可证，延长评估期限，也可以生成一个永久许可证（请参阅下文）。 

选择“Activate a License（激活许可证）”选项，激活并安装许可证： 




请注意，如果希望生成并安装新的许可证，还可以在 CCS 主菜单中，通过“Help -> Licensing Option...（帮助 -> 许可选项...）”访问此对话框。 

· 第 1 步 - 生成许可证文件：选择要生成的许可证文件类型。选择一个主机 ID 并将其复制到剪贴板中。如果在购买 CCS 时向您提供了激活代码，则请选择“Register（注册）”。否则，请选择“Use Free Limited License（使用免费的有限许可证）”，生成一个免费的许可证，这样则可以使用低成本的 XDS100 仿真器，以及标准 EVM/DSP/eZdsp 开发板或模拟器内置的仿真功能。单击这两个按钮均将打开浏览器，并转到激活站点。请注意，您可能需要登录到 MyTI。如果您没有 MyTI 登录帐户，可以通过“SignUp（注册）”按钮创建。登录到激活站点后，可按相应步骤生成许可证，然后要求网站通过电子邮件将其发送给您。 

· 第 2 步 - 安装许可证文件：收到包含许可证文件的电子邮件后，请将许可证文件复制到本地计算机的某个位置。然后继续执行许可证对话框中的第 2 步，使用“Browse（浏览）”按钮浏览并选择您已经复制到本地计算机的许可证文件。此操作将安装许可证并激活 CCS。 

如果使用的是浮动许可证，则还需执行其他步骤才能在许可证服务器上安装许可证。有关更多详细信息，请参阅注册CCSv4浮动许可证主题。 
9.3在不访问 Internet的情况下进行激活 

如果要在不能直接访问 Internet 的计算机上安装 CCS，则需要记录下前面提到的主机 ID，然后使用可访问 Internet 的计算机，或者将主机 ID 提供给代表您访问 Internet 的其他人。如果您已经购买了 CCS，而且拥有激活 ID，则请转至注册页，然后根据上述步骤生成许可证。如果您希望激活免费的组合许可证，则可以使用链接。请确保输入您希望在其上使用 CCS 的计算机的主机 ID，如果您代表他人注册，请输入其电子邮件地址，这样可以将许可证文件直接发送给他们（或者发送给稍后可将许可证文件转发给相应人员的其他人）。收到许可证文件后，将其复制到需要激活 CCS 的计算机，然后在“Activate Code Composer Studio（激活 Code Composer Studio）”对话框中，指定文件路径，完成激活过程。

9.4浮动许可证 

在节点锁定式单用户方案中，许可证文件 (.lic) 存储在运行 Code Composer Studio 的计算机上（每台计算机一个 .lic 文件）。在浮动许可证方案中，一台服务器设置为许可证主机，其他的每台客户机都配置为根据需要“签出”许可证。 

本指南概述了特定于 Code Composer Studio 的管理细则，并且旨在对 Acresso 现已提供的《License Administration Guide（许可证管理指南）》（第 8 到 14 章介绍了设置和维护浮动许可证系统的通用细则）进行补充。 

要求 

· 《License Administration Guide（许可证管理指南）》 

· 许可证服务器计算机。目前我们支持 Windows、Solaris (Sparc) 和 Red Hat Linux（请参阅《License Administration Guide（许可证管理指南）》第 8 章“Selecting a License Server Machine（选择许可证服务器计算机）”）。lmadmin、lmgrd 和 lmtools 可执行文件（可从 Acresso 下载）对于 Solaris (Sparc)、Red Hat Linux 或 Microsoft Windows 均适用。 

· Texas Instruments 的供应商后台程序 (tidspssw) 

· 请注意：Code Composer Studio 和 tidspssw 供应商后台程序与 FLEXnet Publisher v11.4.1 一同生成。 

· tidspssw 供应商后台程序的可用情况如下（单击链接进行下载）： 

· tidspssw - Microsoft Windows 

· tidspssw - Red Hat Linux 

· tidspssw - Solaris (Sparc) 

· Code Composer Studio 的浮动许可证文件 

获取许可证文件 

· 使用激活代码在线注册以获取许可证文件。 

· 浮动许可证文件 (.lic) 为客户机提供多个许可证，但是许可证文件本身会锁定于一台物理服务器。当您在线注册以获取许可证文件时，请使用许可证服务器的 HostID。 

· 可通过运行 'lmhostid'（作为 lmtools 软件包的一部分从 Acresso 进行下载，请参阅《许可证管理指南》的第 89-91 页）获取服务器的 HostID。在 Microsoft Windows 系统中，通常将以太网地址用作 HostID。可通过在命令提示符窗口中运行 'getmac' 命令获取该地址。 

设置许可证服务器 

· 需要 tidspssw 供应商后台程序和许可证文件（见步骤 1），以及 lmadmin 或 lmgrd。 

· 请按照《License Administration Guide（许可证管理指南）》中的步骤将 lmadmin（第 8 章）或 lmgrd（第 11 章）设置为服务器进程。 

· 在 Microsoft Windows 系统中，应该将 tidspssw 供应商后台程序放在与 lmadmin.exe 相同的目录下，例如 C:\Program Files\FLEXnet Publisher License Server Manager。 

· 重要说明：请确保将 .manifest 文件与可执行程序一同从 zip 文件中解压出来。 

配置 Code Composer Studio 

许可证服务器开始运行后，需要先配置 Code Composer Studio 以连接服务器，然后才能获取许可证。可通过以下三种方式之一完成此操作： 

方式 1：licenselocation.txt（推荐） 

· 对于定义 Code Composer Studio 使用的许可证服务器，推荐的方法是创建 licenselocation.txt 文件。 

· 如果文件 ccsv4\DebugServer\license\licenselocation.txt 存在，可通过搜索该文件中的位置条目来获取许可证。 

· 该文本文件中每行包含一个位置条目。位置条目分为以下几种： 

1. port@host，其中 port 为端口号，host 为许可证服务器系统的主机名称。 

2. @host，其中 host 为许可证服务器系统的主机名称。因为未指定端口号，因此默认使用 27000 到 27009 之间的某个端口号。如果服务器与应用程序运行在相同的系统上，则 @localhost 始终有效。 

3. 包含三个 port@host 条目的逗号分隔列表，这三个条目表示三台服务器组成的冗余配置。例如，port1@host1、port2@host2、port3@host3 表示由 host1、host2 和 host3 组成的三台服务器冗余配置。 

4. 许可证文件的实际文本，以 START_LICENSE\n 为前缀，以 \nEND_LICENSE 为后缀，其中嵌入换行符 (\n) 为必需字符。 

· 如果 licenselocation.txt 包含多个条目，则按照从第一行到最后一行的顺序进行搜索。 

方式 2：环境变量 

· 可以通过环境变量指定许可证位置。按照与 licenselocation.txt 条目类似的方法指定位置，但有一点例外，即相对路径条目无法自动扩展，因此必须使用绝对路径。 

· 如果存在这些环境变量，则在 licenselocation.txt 和 DebugServer\license 文件夹中的位置之前优先搜索这些变量所指定的位置。 

· 在 Windows 中，以分号 (;) 分隔多个条目。 

1. TIDSPSSW_LICENSE_FILE 为 Code Composer Studio 覆盖由应用程序定义的许可证位置。 

2. LM_LICENSE_FILE 为所有启用了 FLEXnet 的应用程序覆盖由应用程序定义的许可证位置。如果使用多个启用了 FLEXnet 的应用程序，并且通过单个许可证服务器为所有这些应用程序提供服务，则使用此变量能够快速告知所有应用程序在何处搜索许可证。 

方式 3：Windows 注册表 

· 上面指定的环境变量可作为“合适的”环境变量或特殊条目而存在： 

· Windows 注册表： 

· HKEY_LOCAL_MACHINE\Software\FLEXlm License Manager 

安装期间进行自动配置 

如上文所述，Code Composer Studio 将会读取 ccsv4\DebugServer\license\licenselocation.txt 的内容以确定在何处搜索许可证（文件或服务器）。如果您的组织安装了多个 Code Composer Studio 副本，则很难确保所有客户机安装过程都进行了正确配置，以便从服务器签出许可证。 

为方便起见，可以创建一个包含服务器参数（即 9900@myserver.mycompany.com）的 licenselocation.txt 文件，然后在 Code Composer Studio 安装映像中创建一个 .\license 文件夹： 

\install_images\ccscore\license\licenselocation.txt 

在安装产品时该文件将自动安装到 ccsv4\DebugServer\license 文件夹中。组织内的用户再也无需设置许可证，而且屏幕上再也不会出现“Registration（注册）”对话框。 
