[FAQ] CCS/LAUNCHXL-F280049C: EMUPack 8.0.903.4与LAUNCHXL-F280049C不兼容

器件型号:LAUNCHXL-F280049C

工具/软件:Code Composer Studio

咨询问题:最新的CCS EMU pack V8.0.903.4包含了更新过的XDS100仿真器固件(升级到FW版本2.3.0.16),该固件与LAUNCHXL-F280049C不兼容。 

  • 如果您尚未安装此更新,则无需执行任何操作。
  • 如果您已安装此更新,则解决方法如下:

1) 点击此处下载先前版本的EMU pack(V8.0.803.0)

2)安装EMU pack,确保路径与CCSv#目录匹配,例如,CCS v8的默认安装路径为c:\ti\ccsv8。请注意,EMU pack安装程序的默认路径为C:\ti,修改并确保该路径包含\ccsv#子目录。

3)从可执行文件安装EMU pack后,您需要手动更新旧EMU pack中的XDS110固件

4)使用命令提示符进入CCS安装路径中的仿真目录,例如 C:\ti\ccsv8\ccs_base\common\uscif\xds110\

5)在命令提示符中执行以下代码行

6)重启设备

7)确认LaunchPad上的固件版本是2.3.0.15,通过在命令提示符中执行以下命令行来实现:

截至2019年3月21日,已修复此问题的1Q19 EMU pack已经发布到TI工具站点点击此处,并已合并到CCS更新中。

如果您没有开启自动更新,可以进入“帮助Help”菜单并选择“检查更新 Check for Updates”。当LP连接到主机PC并启用相关的CCXML时,LAUNCHXL-F280049M上的XDS110将在CCS内自动更新。

您可以通过以下路径(使用默认安装选项)在命令提示符中执行以下代码行来验证XDS110驱动程序是否为最新/正确的版本:C:\ti\ccsv8\ccs_base\common\uscif\xds110\

如果已更新,则 固件版本应为2.3.0.18。

1 个回复