TI E2E 英文论坛海量技术问答的中文版全新上线,可点击相关论坛查看,或在站内搜索 “参考译文” 获取。

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

[参考译文] BOOSTXL-EDUMKII:光传感器演示代码"boostxl_edumki_lightsensor_msp432p401r"在 msp432p4_sdk_3_40_01_02中、提供0 Lux 的恒定输出

Guru**** 245645 points
Other Parts Discussed in Thread: BOOSTXL-EDUMKII, OPT3001, MSP432E401Y
请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

https://e2e.ti.com/support/microcontrollers/arm-based-microcontrollers-group/arm-based-microcontrollers/f/arm-based-microcontrollers-forum/1133049/boostxl-edumkii-light-sensor-demo-code-boostxl_edumkii_lightsensor_msp432p401r-in-msp432p4_sdk_3_40_01_02-provides-a-constant-output-of-0-lux

器件型号:BOOSTXL-EDUMKII
主题中讨论的其他器件:MSP432P401ROPT3001MSP432E401Y

您好!

  我最近购买了 BoosterPack BOOSTXL-EDUMKII。 我已将其与 MSP432P401R Launchpad 配对。

  当我运行 SDK 随附的"simplelink_msp432p4_sdk_3_40_01_02"时、从文件夹"examples\nortos\MSP_EXP432P401R\demos\boostxl_edumki_lux sensor_msp432p401r"中、我可以看到光传感器的恒定输出量为0、无论光照度如何。 我还注意到、从我运行程序开始、LCD 上显示0值大约需要15秒。

  设置 GPIO 切换后、我看到线路#148占用了这15秒的大部分时间(OPT3001_getLux ())。 具体而言、大部分时间由 HAL_OPT3001.c 中的第94行消耗(RAW = I2C_READ16 (RESULT_REG))。 无论环境光有多大、这都会返回0x0000。 这是正常的吗?

  想知道其他人是否开箱即用地遇到了这样的问题。 我们非常感谢您的帮助。

谢谢、

Sameer

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    Sameer、您好!

    供参考:不建议在新设计中使用 MSP432P401R、仅为当前的设计提供实际支持。 如果这用于新的开发、则应考虑改用其他选项、例如 MSP432E401Y 或 TM4C。

    也就是说、这听起来可能是硬件问题。 您是否使用示波器检查了 I2C 线路?  确保它们被拉至高电平、交易看起来正常。

    此致、
    Brandon Fisher

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    Brandon、

      感谢您提供有关 MSP432P401R 的说明。 这不适用于新设计。 是的、我已经了解了逻辑分析仪上的 I2C 线路、它们被拉高、看起来正常。 此时、我怀疑 BoosterPack 存在硬件问题。 将不同的硬件连接到同一 I2C 上的 Launchpad 似乎可以正常工作。 这将排除 LaunchPad 硬件。

    Sameer

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好、Brandon、

     根据我完成的调试、您能否确认这是硬件问题? 我向 TI 支持发起了一个案例、以获取此电路板的 RMA、但他们希望我要求您确认这是硬件问题、然后再继续。

    谢谢、

    Sameer

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    Sameer、您好!

    您连接的另一个 Booster Pack 是否也是 BOOSTXL-EDUMKII? 它是否也运行相同的代码?  

    我看到您说过 I2C 线路看起来还可以、看到它们被拉高至少意味着它不是上拉问题、但您是否看到线路上的流量正在运行 OPT3001_getLux ()命令?  

    此致、
    Brandon Fisher

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    是的、两个 Booster Pack 都是相同的(第一个 Booster Pack 已使用3年)、运行相同的开箱即用演示代码。

    在最近购买的 BoosterPack 上、当 OPT3001_getLux ()命令运行时、我在 I2C 线路上看不到任何数据。 数据线仅保持高电平。 在 OPT3001_getLux ()函数内、行"raw = I2C_read16 (result_REG)"大约需要15秒、然后在原始变量中返回0x0000。

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    Sameer、您好!

    两个电路板的 TMP006器件不正确? 这将是我可以在旧板和新板之间看到的 I2C 总线上的唯一区别。  

    如果是、我可以放心地说 、这可能是新 Booster Pack 上的硬件问题。  

    此致、
    Brandon Fisher