This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

[参考译文] TUSB9261DEMO:连接到 SATA SSD 时、会持续复位

Guru**** 613395 points
Other Parts Discussed in Thread: TUSB9261DEMO, TUSB9261, TPS650061, TPS2560
请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

https://e2e.ti.com/support/interface-group/interface/f/interface-forum/890325/tusb9261demo-keeps-resetting-when-connected-to-sata-ssd

器件型号:TUSB9261DEMO
主题中讨论的其他器件: TUSB9261TPS650061TPS2560

您好!

我使用 TUSB9261DEMO 将2.5英寸1TB SATA SSD (5V 电源)连接到我的 Windows 笔记本电脑 USB 端口(USB 供电)。 我可以在 我正在进行的定制设计中使用 TUSB9261芯 片、因此我使用 TUSB9261DEMO 进行评估。

我最初没有遇到消费类 SSD (5V 电源)问题、但后来我切换到工业级 SSD (根据我的应用的要求、也是5V 电源)、这种情况会通过高速或超高速 USB 电缆发生故障。 我使用另一个 USB-SATA 转换器测试了此 SSD、它工作正常、因此 TUSB9261DEMO 出现问题。

连接工业 SSD 后 、TUSB9261DEMO 似乎会定期复位、大约每隔一秒左右、出现在 Windows 设备管理器中并消失。 LED D3、D6和 D8在每个复位周期短暂关闭、然后重新打开。 SSD 从未安装在 Windows 中。

我探测了 Vbus 5V 电源、我看到它在2-3 ms 内下降到4.2V、而使用消费类 SSD 时为200us (请参阅随附的示波器屏幕截图)。

我探测了所有其他电源(3.3V、1.8V、1.1V)、它们都是稳定的。

我探测 到 TPS2560 (U7)故障输出和 TPS650061 (U4) RST 输出、两者都始终处于高电平、因此看起来没有电源故障。

我探测 SATA_EN 信号、在每次复位时、它在60ms 内变为0V、然后返回0.8V (请参阅随附的示波器屏幕截图)。

我探测 TX 信号、并且在每次复位时都会发出数据。 SPI 时钟和数据信号也是如此。 我想这是 TUSB9261初始化。

有什么想法,有什么事情发生了,如何解决?

谢谢!

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好、Nicolas、

    工业 SSD 似乎会导致 VBUS 出现骤降、而 TUSB9261会中断这种情况、作为断开连接。 如果 TUSB9261看到 Vbus 超出标准 Vbus 值(~4.7-5.5)、它将断开主机的 USB 端口(请参阅 USB_VBUS 引脚)。 您能否从外部为工业 SSD 供电?

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好、Malik、感谢您的快速回答、

    您似乎是对的、我在 自供电模式下使用外部12VDC 电源为 TUSB9261DEMO 供电、而不是通过 USB 总线供电、这解决了我的问题、现在已正确检测到 SATA SSD。

    感谢您的支持!

    我还意识到我之前的消息中没有附加示波器屏幕截图、所以这里是这样的。