This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

[参考译文] DRV8245S-Q1LEVM:无法在 GUI 和 EVM 之间建立通信

Guru**** 614335 points
请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

https://e2e.ti.com/support/motor-drivers-group/motor-drivers/f/motor-drivers-forum/1267202/drv8245s-q1levm-cannot-establish-communication-between-gui-and-evm

器件型号:DRV8245S-Q1LEVM

大家好,我刚刚打开了此模块的包装并将其连接到我的 PC 和12V PSU,但无法让它与 GUI 进行通信 。
我尝试了每个可用的波特率(以及在连接时枚举的两个串行端口中的每个端口)-都没有成功、现在完全卡住。

就背景而言、我在 J7的引脚对上安装了6个链接、以连接 MSP430和 m all 之间的相应线路、当我将其连接到 USB 并将12V 连接到+Bat 时、以下 LED 将亮起:-
VM LED D3绿色
PWR LED D6绿色
3V3 LED D3绿色
nFault LED D2红色(大约4Hz 闪烁)

如果我按下复位按钮、红色闪烁会在按住该按钮时停止、然后在释放该按钮时恢复。

我尝试了0.5和1.0版本的 GUI、但可以两种版本都无法连接。

唯一(任何东西都起作用的间接成功就是我单击"File"->ProgramDevice"、它好像在这里连接到 MSP430并成功刷写(在这种情况下、Mode LED D5会闪烁)。 然后、它会报告刷写成功、而 GUI 尝试重新连接但失败(再次)。

我可以帮助您使用此 EVM 并让 GUI 与之通信吗?

谢谢

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    Ben、您好!  

     MD048 "A"版本存在一个微小的硬件问题该问题的补救措施是在 TP10和 R1的特定端之间焊接一个小导线连接、如下图所示。 此修复之后、在首先将 USB 连接到计算机并为 VBAT 电源上电之后、EVM 应该能够连接到 GUI。 请告诉我们、这是否解决了您的问题。 很抱歉给您带来不便。 谢谢。

    此致!  

    凯尔蒂

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    尊敬的 Keerthivasan:

    感谢您的答复-很遗憾、您提供的链接不起作用。 请仔细检查并重新发送?

    加油打气

    本  

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    好的-链接现在似乎可以工作、并且显示了一个图像。 我将在明天早上试一下、谢谢您