This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

[参考译文] TMS320VC5416:支持与 XDS 510 USB Plus 等效的 DSP 仿真器并支持 CCS 版本

Guru**** 1091410 points
Other Parts Discussed in Thread: TMS320VC5416
请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

https://e2e.ti.com/support/processors-group/processors/f/processors-forum/1131144/tms320vc5416-support-for-dsp-emulator-equivalent-to-xds-510-usb-plus-and-supporting-ccs-version

器件型号:TMS320VC5416

主席女士,

使用 DSP IC TMS320VC5416、早在使用 Code Composer Studio Ver 3.1为广播无线电开发 DSP 代码。 用于调试的仿真器是 SDX 510 USB Plus、现已停产。 由于 Airborn 无线电处于生产阶段、我需要您对以下问题的宝贵答复:

1) 等效于 XDS 510 USB Plus 并可支持上述 CCS 3.1版和 DSP IC 的任何其他仿真器。

2) 如果我需要将代码迁移到最新版本的 CCS (我希望将其迁移到 CCS 5.5版)、请提供支持 CCS 5.5和 DSP IC TMS320VC5416的仿真器。 此外、让我知道在将代码从 CCS 3.1迁移到 CCS 5.5期间可能遇到的所有挑战以及如何处理这些挑战。

感谢您的回复。

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好!

    [引用 userid="531983" URL"~/support/processors-group/processors/f/processors-forum/1131144/tms320vc5416-support-for-dsp-temulator-equivality-to-XDS-510-USB-plus-and-support-ccs-version"]1.) 与 XDS 510 USB Plus 等效并可支持上述 CCS 3.1版和 DSP IC 的任何其他仿真器。[/QUERP]

    CCS 3.1的选项有限。 支持 C54x 的 XDS510和 XDS560v1类探头已被大多数供应商停产。  

    [引用 userid="531983" URL"~/support/processors-group/processors/f/processors-forum/1131144/tms320vc5416-support-for-dsp-temulator-equivality-to-XDS-510-USB-plus-and-support-ccs-version"]2.) 如果我需要将代码迁移到最新版本的 CCS (我希望将其迁移到 CCS 5.5版)、请提供支持 CCS 5.5的仿真器以及 DSP IC TMS320VC5416

    CCS 5.5具有更多选项。 XDS100和 XDS560v2受到积极支持、两者都可与 C54x 搭配使用。

    [引用 userid="531983" URL"~/support/processors/group/processors/f/processors-forum/1131144/tms320vc5416-support-for-dsp-emulator-equivality-to-XDS-510-USB-plus-and-support-ccs-version"]此外,让我知道在从 CCS 5.5迁移代码时可能遇到的所有挑战以及如何处理 CCS 3.1]。

    请参阅以下链接:

    https://software-dl.ti.com/ccs/esd/training/CCSv5-FromCCSv3.pdf

    https://dev.ti.com/tirex/explore/node?node=ANA-2UvaDVeIvwRHD7a0Sw__FUz-xrs__LATEST

    请注意、虽然 CCS 5.5版本高于3.x、但它仍然非常旧且不受支持。 但是、这是支持 C54x 的最后一个版本。  

    谢谢

    Ki