This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

[参考译文] TIA-1.0042万:主板不工作

Guru**** 1123240 points
Other Parts Discussed in Thread: MSP-FET, LM5009, TINA-TI
请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

https://e2e.ti.com/support/tools/simulation-hardware-system-design-tools-group/sim-hw-system-design/f/simulation-hardware-system-design-tools-forum/1090584/tida-010042-board-not-working

零件号:Tida-1.0042万
主题中讨论的其他部件:MSP-FET,LM5009,TINA-TI

我对所需的固件进行了编程。但组装的设备无法正常工作。请建议解决方案。

能否有任何人来提供实时解决方案,以便我完成工作。

谢谢你。

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    你好,Kameswara,

    为了帮助您解决此问题,我需要在此处提供更多信息。

    您从TI.com复制了设计文件并重建 了电路板,对吗?

    主板是否正确通电? TP1和TP2的电压是否为10V?

    如果此操作有效,下一步是调试软件。 您是否使用了MSP-FET工具对主板进行编程?

    此致,

    Andreas

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好,先生,

    是的,我根据TIDA1.0042万提供的文件设计了PCB。

    我接通了电源,但仍有疑问。TIDA 1.0042万提供的指导不清楚。

    使用MSP430f5229lp ezfet lite模拟器连接到TIDA 1.0042万中的主控制器。

    当我连接Tida 1.0042万 bard J2的2个引脚2和3时,我得到3.3V电压。

    但我在TP1从未获得10 v,如何获得?

    可能是我的做法不正确。  

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    你好 ,Kameswara,

    好的,因此10V由 太阳能电池板的输入电压产生。
    您可以通过将15V至 22V的电源连接到输入连接器J6来模拟此情况。 然后,您还需要将 电池或负载连接到J5。 通过 此设置,您应该可以看到系统正在工作。 请按照设计指南3.2 .1下所述的测试设置进行操作。

    此致,

    Andreas

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    是的,先生,我这样做了。 我在CV模式下连接了电子负载,因为CC模式不适合另一位TI专家提到的情况。但当我连接时,输入在电池接线处或负载接线处没有获得12v电压。

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    你好 ,Kameswara,

    好的,输出接头处是否有电压,或者 其读数是否为0伏?  
    如果根本没有电压。 我认为软件正在关闭系统。 是否可以在调试模式下启动软件,并通过在其中设置断点来检查代码是否达到第353行?

    此致,

    Andreas

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好,先生,

    我在输出电压端子处获得0伏电压。

    现在,我的主板在我的实验室,明天早上我将检查代码。

    我之前运行过该代码,但我不确定它是否工作正常。如果可能,您可以分享一些用户指南或步骤,以CCS加载固件,以及TIDA 1.0042万中的闪存步骤,供独立使用。

    我的邮件ID是 oks1988@gmail.com

    谢谢您先生。

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    你好 ,Kameswara,

    首先,您需要下载TIDA-1.0042万固件并将其导入CCS。(Project -> Import CCS Project->选择Downloaded文件夹)
    之后,您需要将所需的调试器信号连接到TIDA-1.0042万板的连接器J4:

    Tida-1.0042万针脚:

    MSP430f5229lp ezfet lite模拟器引脚:

    现在,您应该能够在CCS项目中单击调试按钮并对设备进行编程。

    此致,

    Andreas

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    感谢您提供信息,先生。 我也这样做了。 现在我已消除了困惑。明天我将调试和检查代码,正如阁下所说的那样。

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    代码在此停止...

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    你好 ,Kameswara,

    这是正常的行为,在main()函数的开头有一个缺省断点。
    如果您按下绿色的RUN (运行)按钮,则应继续。 您可以在前面显示的第353行中添加另一个中断点,方法是双击代码窗口的左边框,查看您是否到达启用了面板和降压的代码。 作为替代方案,您可以使用单步选项逐行检查代码并观察SW正在执行的操作。

    此致,

    Andreas

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    按下绿色按钮后,其将运行很长时间,但仍在运行

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    你好 ,Kameswara,

    这是一个好的迹象,现在您需要在 代码的重要部分插入断点,以查看软件正在执行的操作。 第一个问题是它是否启用面板和降压转换器。

    此致,

    Andreas

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    很抱歉问这个问题...如果面板电压大于蓄电池电压,我会根据代码了解,当它满足线路时,降压已启用? 我将电子负载作为CV电源连接到电源。我是否需要为该过程连接真正的电池以便启用降压? 或者没有连接软件将检查。因为直到现在,在恢复调试后,程序仍在运行并且从未停止。

    要做什么?  

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    你好 ,Kameswara,

    正确,仅启用降压,连接到J6的输入电压高于蓄电池连接器处的电压。 因此,您需要将带15V至J6的电源和设置为12V的电气负载连接至蓄电池接头。

    您可以通过插入断点在每个点停止软件,并检查系统正在读取的电池或面板电压。
    如何执行此操作在Code composer studio用户指南的第7章中有说明: https://software-dl.ti.com/ccs/esd/documents/users_guide/index_debug.html

    此致,
    Andreas

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好,先生,

    我做到了,降压已启用。 但是,在那之后,它仍然在运行,在一个桥上它出来了。

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    你好 ,Kameswara,

    好的,此屏幕意味着代码中触发了某种异常。
    目前TP1是否达到10V? 如果没有此导轨,设计将无法工作。

    此致,

    Andreas

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好,先生,我在TP1收到的电压只有2伏,而不是10伏。

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    你好 ,Kameswara,

    好的,这就是为什么它不工作的原因。  

    您能否检查LM5009 (U6的引脚8)处的输入电压? 该电压应与连接到J6引脚2的面板电压相同,该电压必须介于15和22V之间。

    如果正确,请检查反馈分压器R36和R38。

    此致,

    Andreas

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好,先生/先生遇到此问题。未定义符号,正在进入挂起HW断点

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    你好 ,Kameswara,

    您是否使用了10V轨道?

    您的问题似乎是由未处理的监视程序计时器中断引起的。

    您是否可以尝试 注释第 315行中的Init_WDT()函数,如下所示:

    此致,

    Andreas

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    我曾尝试评论第315行,但主席先生,我的答复是相同的。

    先生,TP1处的电压为10 V。这是否与代码有关,以使电压在TP1处反射,或者没有任何代码,TP1应显示10V SIR。因为现在代码甚至未达到降压启用/面板启用

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    你好 ,Kameswara,

    我不是 此设计的原始作者,但 据我了解,在本软件 开始运行之前,TP1应该有10伏。 由于10V是为 栅极驱动器供电所必需的,因此可以启用和禁用降压,面板或负载。

    因此,如果没有10V,则无法启用或禁用任何功能。 您能否检查U6 (LM5009)引脚8和引脚4之间的输入电压。

    如果这不能帮助我必须在实验室里自己设置这个板。 但这将持续到下周。

    您也可以 尝试删除线路297中的初始PANEL_DISABLE呼叫,看看这是否有帮助。

    此致,

    Andreas  

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好,先生,让我看看您提到的LM5009。

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好,先生,  

    我检查了引脚8和引脚4之间的电压,它是20V (我将RPS设置为20V作为太阳能),但LM5009的输出仅与1.9 v相同。我检查R36和R38的值是否正确。  

    Dono Y LM5009未给出10V....

    我也承诺了297和315线路,但行为相同。

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    你好 ,Kameswara,

    在这种情况下,LM5009会出现与硬件相关的问题。 这意味着我们现在可以忽略软件,因为它不会影响LM5009行为。
    您可以检查 LM5009引脚上的其它电压和波形,并将它们与LM5009产品页上的TINA-TI模拟模型进行比较。 该型号可根据TIDA-1.0042万中使用的电路轻松调整。  
    另一个选项是更换LM5009,查看IC是否刚刚损坏。

    此致,

    Andreas

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    我想让我通过TP1绕过LM5009并检查主板和软件,给10伏的恒定电压。

    我想给您写个人电子邮件,这是不是您的问题? 您能否将测试邮件发送到 oks1988@gmail.com ,以便我可以询问一些问题。  

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    你好 ,Kameswara,

    好的,让我们通过电子邮件处理此问题

    此致,

    Andreas