This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

开发板EVM430-FR6043

Other Parts Discussed in Thread: EVM430-FR6047, EVM430-FR6043, UNIFLASH, MSP430FR6043

您好, 

我司最近購買一套开发板EVM430-FR6043, 依照TI官網上的指示與說明, 下載並安裝完成相關的軟體後, 接上開發中的氣體流量計, 進行掃頻測試時,出現錯誤訊息, 嘗試多種不同的參數設定,仍無法解決. 後來我們工程師將EVM430-FR6043开发板換成另一塊EVM430-FR6047(水中超声波检测应用)開發板, 並將電腦上軟體關於硬件的選項切換至水中應用, 掃頻測試即可正常運作, 顯示電腦軟體方面應無問題,應該是开发板EVM430-FR6043出了問題.

工程師描述,之前剛購買EVM430-FR6047開發板時, 也遇到類似的問題, 經詢問TI 論壇, TI工程師回覆並提供了一個更新的韌體(firmware), 韌體更新後,即可正常操作測試. 請問开发板EVM430-FR6043 是否也需要做類似的韌體更新 ? 哪裡可找到所需的韌體 ?

Thanks very much ~

 

  • user6243928 said:
    進行掃頻測試時,出現錯誤訊息, 嘗試多種不同的參數設定,仍無法解決.

    请问可以给出具体的错误信息吗?

    您现在烧录的是哪个例程呢?

  • 您好, 以下是錯誤訊息的截圖.

    另外, 請問您問的 "您现在烧录的是哪个例程呢?", 是指甚麼意思呢 ? 是指我們的設定檔內容嗎 ?

    以上問題還請您盡快回覆.

    非常感謝您~

  • 您现在图片没有正常上传,我这里看不到您的图片

    "您现在烧录的是哪个例程呢?",就是您现在板子内还是预设的程序或者您重新给板子烧录过程序?
  • 您好,

    不知何原因,圖片沒上傳成功. 再次上傳一次,請看下圖.

    目前我們沒給板子燒錄過新的程序,板子內應該还是预设的程序.

    另外,順便一提, 我現在要掃頻的範圍是410kHz~560kHz, 我司另一位工程師(使用EVM430-FR6047的那位工程師)認為問題應是出在目前板子內的程序無法滿足410kHz~560kHz的頻率範圍, 需要TI公司提供合適的韌體程序給我們使用,才能解決問題. 請問是否是這種狀況呢 ?

    非常感謝您~

  • sorry, 之前我用錯誤的方式,導致圖片上傳失敗.
    請看上面上傳成功的"錯誤訊息"圖片.
  • http://www.ti.com/lit/ml/slau765b/slau765b.pdf 

    的第11页

    请问您现在传感器参数中的频率是多少?

  • www.ti.com/.../slau720b.pdf

    的 6 Understanding the Design Center Frequency Sweep Tab

    The Frequency Sweep tool helps to determine at which transducer excitation frequency the ADC capture achieves the maximum amplitude. The frequency at which the peak amplitude is reached should be used as the new F1 parameter to achieve the strongest signal for the meter configuration. For the example in Figure 16, a value in the range of 920 to 1000 should be placed into the F1 parameter.
  • 您好,

    我思測試的傳感器工作頻率是500 kHz.

  • 那您试一下下面链接内的UltrasonicGasFR6043_02_20_00_12_windows_installer.exe

    software-dl.ti.com/.../
  • Susan 您好,

    1. 依建議下載及安裝,下列軟體:
    1.1 安裝 UltrasonicGasFR6043_02_20_00_12_windows_installer,執行後,Request Update→ Configuration Update Failed(訊息) 、掃頻時同樣出現錯誤訊息。
    1.2 安裝 ti_msp430driver_setup_1.0.1.1,執行後,Request Update→ Configuration Update Failed(訊息) 、掃頻時同樣出現錯誤訊息。

    2. 目前安裝軟體USS-02_20_00_18-windows-installer。

    是否有其他建議可提供,謝謝。
  • Susan,您好

    1. 圖片為現有EVM430-FR6043 Board。
    2. 依zhca933a.pdf說明 1-1 / 3 驱动程序,下載及安裝 ti_msp430driver_setup_1.0.1.1,執行後,點選Request Update→ Configuration Update Failed(錯誤訊息) 、掃頻時同樣出現錯誤訊息。
    3. 1.下載及安裝新版FW USSSWLib_Gas 02_20_00_19,執行後,點選Request Update→ Configuration Update Failed(錯誤訊息),掃頻時同樣出現錯誤訊息。

    4. 電腦與EVM430-FR6043 board仍無法溝通,是否有新版韌體(HW)可提供Update,謝謝。

  • USSSWLib_Gas 02_20_00_19是加载到板子上了? 使用默认配置F1 F2的值时是否可以正常使用?

    之前的客户就是因为GUI的某些更新可能与较旧的固件不兼容导致的。

    e2e.ti.com/.../805484
  • If you look under the "Advanced Parameters" tab, you will see 2 fields called "Signal Sampling Frequency (kHz)" and "ADC Over Sampling Rate." The product of these 2 values represents the actual sampling frequency, and needs to be between 68-80 MHz.

    这两个值的乘积代表实际采样频率,并且需要在68-80 MHz之间。

  • Susan Yang 您好,

    1.USSSWLib_Gas 02_20_00_19是加载到板子上了?
    →USSSWLib_Gas 02_20_00_19是T1網站名稱,下載的軟體是USS-02_20_00_19-windows-installer.exe,執行後,點選Request Update→ Configuration Update Failed(錯誤訊息)。

    2.使用默认配置F1 F2的值时是否可以正常使用?
    →默认配置是指軟體安裝後開啟時配置數值嗎?
    →安裝後開啟時配置數值,按F2,Request Update為灰色無法點選;按F1,Request Update可點選,訊息為Configuration Update Failed。

    3. 使用示波器接J5、J6連接傳感器時,示波器有顯示訊號;電腦連接EVM430-FR6043時,LED102/LED201點亮、LED202 持續亮→暗→亮,是否為板子內各模組無法正常運作,使電腦和板子溝通出現錯誤?

    4.顯示屏幕沒有顯示訊息,是否為正常狀況?

    5."Signal Sampling Frequency (kHz)"和"ADC Over Sampling Rate." ,这两个值的乘积代表实际采样频率,并且需要在68-80 MHz之间。
    →已確定是在68~80 MHz時,點選Request Update→ Configuration Update Failed。

    若有建議,麻煩請提供,我們將會再進行測試,謝謝。
  • user6243928 said:
    USSSWLib_Gas 02_20_00_19是T1網站名稱,下載的軟體是USS-02_20_00_19-windows-installer.exe

    这个安装之后在安装文件夹默认路径内含有相关的例程

    C:\ti\msp\UltrasonicGasFR6043_02_20_00_12\examples\MSP430FR6043EVM_USS_Gas_Demo

    将例程导入IAR/CCS之后会对板子debug或者烧录生成的hex文件

    您现在是这样操作的吗?

    user6243928 said:
    .顯示屏幕沒有顯示訊息

    屏幕是黑的?没有显示?能给出相关图片吗?

    请问您是在何处购买的板子?

  • Susan Yang 您好,

        

    安裝CCS9.2.0.00013_win64後,出現錯誤訊息,無法操作,錯誤訊息如下:

         

          

    Mouser 購買編號:595-EVM430-FR6043、開發板及套件 MSP430  ULTRASONIC GAS FLOW METER EVM

           

    若有新的建議,請提供給我們,謝謝。

  • user6243928 said:
    安裝CCS9.2.0.00013_win64後,出現錯誤訊息,無法操作,錯誤訊息如下:

    那您直接使用Uniflash来烧录下面路径的txt试试

    C:\ti\msp\UltrasonicGasFR6043_02_20_00_12\image

    综上,建议您先烧写一下,若还是不行的话,请您去英文版E2E发帖,并将工程师的回复反馈给mouser

  • 您现在进展如何了?

    请您尝试下面的操作

    Click Load Configuration, go to the mtr_gui_config in the Ultrasonic Gas Demo Application for MSP430FR6043, and select one of the example configurations. The default folder is: C:\ti\msp\<ultrasonic_gas_demo_application_version>\examples\mtr_gui_config

    Click Request Update. The Design Center shows a message to indicate a successful update.

  • 我试了一下,拿到板子,直接开机连接GUI的话,屏幕是不亮的,之前信息错误,很抱歉