由于中秋节假期,帖子审批以及工程师回复将会有所延迟,敬请谅解。

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

[FAQ] Linux 和 MAC 上的 UniFlash/CCSv9.1.0/CCS Cloud 中出现 MSP430 器件自动检测错误

Other Parts Discussed in Thread: UNIFLASH, MSP430FR2310, MSP430FR2311, MSP430FR5962, MSP430FR5964, MSP430FR5992, MSP430FR5994

器件型号:  UNIFLASHMSP430FR2310MSP430FR2311MSP430FR5962MSP430FR5964MSP430FR5992MSP430FR5994

MSP430 的某些器件支持文件存在问题,这将影响 UniFlash 和 CCSv9.1.0 的某些用户。

如果这些器件的用户此前已有 .ccxml(目标配置文件),则该文件可能会在 Linux 和 Mac 上的最新 UniFlash 和 CCSv9.1.0 中损坏。 

  • msp430fr2310
  • msp430fr2311
  • msp430fr5962
  • msp430fr5964
  • msp430fr5992
  • msp430fr5994

此问题已在 CCS Cloud、CCSv9 和 UniFlash 的最新版本中修复。新项目应该不会受到影响。如果您在上面列出的器件中已有 .ccxml 文件,则会受到此问题的影响。 

解决方法是通过重新选择器件来更新 .ccxml 文件,或创建新文件。