This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

[参考译文] LMK61E2:提问 LMK61E2BBA-SIAR 无时钟输出故障、紧急!

Guru**** 1139930 points
Other Parts Discussed in Thread: LMK61E2
请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

https://e2e.ti.com/support/clock-timing-group/clock-and-timing/f/clock-timing-forum/1232723/lmk61e2-questions-for-lmk61e2bba-siar-no-clock-output-failure-urgent

器件型号:LMK61E2

大家好、

客户在其设计中使用了我们的 LMK61E2BBA-SIAR、但现在客户的机器运行一段时间后、面临因无时钟输出问题而出现的高故障。 我们在 EVM 上验证了故障 IC、它在没有任何时钟输出的情况下显示了相同的行为。 下面我们捕获了与良好单元相比的输出波形和寄存器转储、请帮助检查这里有什么问题。 请帮助您尽早进行检查、因为现在此问题阻碍了客户的大规模生产。 谢谢。

良好的单元输出时钟波形和寄存器转储:

e2e.ti.com/.../LMK61E2_5F00_Good_5F00_Default-Register-Map-Dump-2_5F00_5_2D00_31_2D00_2023.txt

错误的单元输出波形和寄存器转储:

e2e.ti.com/.../LMK61E2_5F00_Failure_5F00_Configured-Register-Map-Dump-4_5F00_5_2D00_31_2D00_2023.txt

如有任何问题、请提供用于仔细检查的客户设计文件:

e2e.ti.com/.../61E2.rar

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    尊敬的 Jacky:

    感谢您提供详细信息。 我比较了这两个寄存器转储、这里显示了重要的差异:

    • 良好器件中的从器件地址为0x5A、糟糕器件中的从器件地址为0x02。
      • 如果 这样做是为了调试目的、那么您现在可以将其保留在独立状态。
    • R22和 R23 (OUTDIV_BY1和 OUTDIV_BY0):良好器件的总输出分频器值为46、而不良器件的总输出分频器值为460
      • 差异很大、坏器件 预计会产生10MHz 输出而不是100MHz。 根据数据表、10MHz 是最小输出频率、如果这是包括值或不包括值的下限、我不清楚。
    • 良好器件中的 R48 (NVMCNT)为3、不良器件中为5

    因此、在我看来、坏器件的编程次数比正常器件多、并且它同时具有不同的从器件地址和错误的输出分频器值。 可能是错误地编程了坏设备、或者有人意外地再次编程了它。 器件可能无法输出恰好为10MHz 的频率、并且不会生成任何波形。

    您可以尝试对坏设备进行以下更正:

    • 将 R22的值设置为0x00
    • 将 R23的值设为0x2E

    让我们了解它是否能够按预期产生100MHz 输出。

    此致!

    Evan Su

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好、Evan:

    当我们尝试在 GUI 默认设置中更改为10MHz 时、请忽略输出频率设置。 即使我们设置为100MHz 或10MHz、仍然没有上面捕获到的波形输出。

    请帮助检查是否有其他有关此故障的线索、时钟输出缓冲器阶段好像有一些问题、但我们进行了 FA 初始测试、没有发现任何异常。

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    尊敬的 Jacky:

    感谢您提供的信息。 我在原理图中没有看到任何问题、输出 LVDS 端接看起来正确、OE 引脚被拉至高电平。 我想问一些问题、以便更好地了解情况:

    请帮助检查此故障是否有任何其他线索,看起来时钟输出缓冲阶段有一些问题,但我们进行了 FA 初始测试,没有观察到异常。

    由于寄存器看起来迄今为止正常、因此输出驱动器可能有问题、或者寄存器映射的深层次存在问题:

    • 是否有多个器件以相同的方式发生故障?
    • 客户是否访问或配置了任何未在 TICS Pro 中公开的寄存器? 数据表中有一些寄存器、但隐藏在 TICS Pro 中、可能会引起问题。

    此致!

    Evan Su

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好、Evan:

    请参考下面我的评论:

    我想问一些问题、以便更好地了解情况:

    我们在 EVM 上验证了故障 IC、它在没有任何时钟输出的情况下显示了相同的行为。

    您是否已将损坏的器件从客户电路板物理转移到 EVM? EVM 应具有正确的电路板设计、因此如果坏器件在安装到 EVM 上后继续出现故障、则问题应与特定器件有关。

    [Jacky]是的、我们只需将客户的故障 IC 回路焊接到 EVM 上来验证其功能、它也没有正常输出。

    请帮助检查是否有其他有关此故障的线索、时钟输出缓冲器阶段好像有一些问题、但我们进行了 FA 初始测试、没有发现任何异常。

    由于寄存器看起来迄今为止正常、因此输出驱动器可能有问题、或者寄存器映射的深层次存在问题:

    • 是否有多个器件以相同的方式发生故障? [Jacky]是的,到目前为止,客户报告了50个试点运行中的4个故障。
    • 客户是否访问或配置了任何未在 TICS Pro 中公开的寄存器? 数据表中有一些寄存器、但隐藏在 TICS Pro 中、可能会引起问题。 [Jacky]客户仅配置了数据表中列出的寄存器、但我将再次检查它们。

    谢谢。

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好、Evan:

    我们另一个发现、对于故障器件、R66寄存器回读值为0xCA、显示锁定 PLL 丢失错误。 以下是客户的完整配置表和代码、请帮助再次检查是否有任何问题触发此错误:

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    尊敬的 Jacky:

    感谢您提供注册信息、我会查看它并尽快与您联系。

    此致!

    Evan Su

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好、Evan:

    添加另一个问题、我们发现、当我们得到一个全新的 LMK61E2BBA IC、并且只读 R48寄存器而没有任何写入时、默认情况下显示为0x01、而不是0x00。 您能帮助检查这是否正常吗? 默认情况下、我们是否有一次性出厂 EEPROM 写入?

    谢谢。

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    尊敬的 Jacky:

    我查看了120 MHz 配置、没有发现任何可能导致失锁的问题。 我将与我的团队详细讨论这一点。

    出于好奇心、您是否可以要求客户读回(不要写入)故障器件上的以下寄存器?

    • R10 (DEV_CTL)
    • R42 (PLL_CALCTRL)
    您能帮助检查这是否正常吗? 默认情况下是否有一次工厂 EEPROM 写入?

    我会问这个问题。 如果需要在制造后对器件进行一次编程以实现 LMK61E2的默认配置、我也不会感到奇怪。

    谢谢。

    Evan Su

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好、Evan:

    请参阅以下寄存器值(为 IC 加电、不进行任何写入和配置的只读)、并检查是否有任何问题:

    •   R10 (DEV_CTL)- 0x00
    •   R42 (PLL_CALCTRL)- 0x00

    谢谢。

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

     尊敬的 Jacky:

    这些回读听起来并不正确。 根据我几个月前做的一些实验、R10的正确值应为0x01 (自动启动开启)、R42的正确值应为0x09 (标准 VCO 校准设置)。 不过、它们隐藏在 TICS Pro 中、我没有看到在代码中访问它们、因此修改它们没有意义。 R10的十六进制地址为0x0A、如果我不够清楚、R42的十六进制地址为0x2A;如果客户有时间、他们可以再次检查故障器件的回读、然后检查正常器件的回读。  

    但是、我今天早上看到了一封关于 ATE 测试的电子邮件、如果存在潜在的硬件问题、则应首先遵循该流程进行调查。 我在退货/FA 流程方面没有太多经验、如果我们要越过配置问题、那么我认为我们应该很快就结束这个线程。 让我知道情况如何。

    此致!

    Evan Su

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好、Evan:

    寄存器 R10 (0x0A)和 R42 (0x2A)值返回的故障器件没有问题、它们都是0x00。 我们还会检查良好的单位、它与您提到的值相匹配。 因此、对于故障器件、内部肯定存在问题、我们不知道它们发生故障的根本原因。 您还检查了客户的初始化寄存器设置且没有问题、下一步我们将重点介绍 ATE 测试结果和进一步的 FA 结果。 但是、由于我们仍需要确定故障的根本原因、因此我们将通过电子邮件进行离线沟通。

    感谢您的支持。

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    尊敬的 Jacky:

    感谢您的更新。 由于问题已移至电子邮件、我将关闭此主题、如果要支持的应用程序有新操作项、我很乐意提供帮助。

    此致!

    Evan Su