This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

[参考译文] MCT8316Z:电机驱动器似乎没有打开/执行任何操作?

Guru**** 1127450 points
Other Parts Discussed in Thread: MCT8316ZTEVM
请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

https://e2e.ti.com/support/motor-drivers-group/motor-drivers/f/motor-drivers-forum/1187377/mct8316z-motor-driver-seemingly-not-turning-on-doing-anything

器件型号:MCT8316Z

大家好、

我在 PCB 上使用 MCT8316ZT (硬件型号)来驱动 BLDC 电机。 我仍处于测试的第一阶段、但遇到了一些小问题。 问题是、我将 PWM 信号与方向一起馈送到电机驱动器中、但电机驱动器似乎什么也不做。 电机根本不会移动、进入系统的电流保持不变(0.02A)。

目前、我正在梳理数据表、以确保我的外部组件正确、并且我正在正确配置器件。 我还计划确认器件已正确焊接且所有器件均已正确连接。

但是、这是我第一次使用这样的器件、所以我 想问其他人是否有类似的问题?

随附了我的驱动器原理图。 我尚未展示如何连接转换、高级、模式和 ILIM。 我有简单的电阻器网络、可根据我要查找的规格对这些引脚进行偏置。  

此外、驱动器模型实际上是 SPI 变体、但我通过查看数据表确保用硬件变体引脚替代 SPI 引脚。

谢谢!

/resized-image/__size/320x240/__key/communityserver-discussions-components-files/38/Driver_5F00_schem.png

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    你好、Nivant、

    感谢您的提问!

    今天是 TI 假日、但我们的目标是在本周结束前提供响应。

    此致、

    Anthony

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    我有更新。 我探测 ILIM 电压、它指示电压大约为0.4V、我知道这低于该引脚允许的电压。 因此、电机驱动器没有拉电流是合理的。 我使用集成的3.3V LDO (AVdd)将 ILIM 引脚偏置到1.25V (AVdd/2 - 0.4)电压。 但是、我发现电机驱动器的3.3V LDO 输出电压大约为1.8V 而不是3.3V。我怀疑这是因为我使用的是5V 霍尔输入、因此损坏了内部 LDO。 我在另一篇文章中发现、有人建议高于 AVdd 的霍尔输入可能会损坏 LDO、因此会损坏器件。  

    也许您可以确认我的直觉是正确的?

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    你好、Nivant、

    我希望很快就这个问题获得您的反馈。 但是、我很难看到您发送的原理图。 您能否提供更高分辨率的原理图图片或 pdf、以便我更详细地了解一下?

    最棒的

    Robert

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    https://imgur.com/M4RInxn

    这是我的原理图。 但是、目前我将 NSleep 引脚连接到 Raspberry Pi 的3.3V 电压(没有原理图中显示的上拉电阻器)、并将 nFault 连接到外部3.3V 基准。 我这样做是因为我认为这是根据数据表唤醒器件的正确方法。 不过,我可能会错了。

    目前、我正在尝试测量内部3.3V 稳压器(AVDD)的输出、但我正在获取0V。 原理图中显示的5V_BK 信号(内部5V 降压稳压器)处的结果类似 我认为我没有正确打开器件? 也许您可以向我提供 一份我应该检查的事项列表、以确保器件已打开? 我的理解是、为电机驱动器提供 VM 电压(我使用的是29V)、通过外部电源将 NSLEEP 拉为高电平、并将 NFault 拉为高电平以避免测试模式、应该足以打开器件?

    谢谢。。。

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    你好、Nivant、

    在详细了解您的原理图和问题时、请查看 MCT8316ZTEVM (MCT8316ZT 评估板)设计文件 https://www.ti.com/tool/MCT8316ZTEVM#design-files 并比较您的原理图。 这是查看 TI 关于在系统中使用该器件来驱动电机的默认建议的最佳方法。  

    如果您有任何更新、请将其发布在此处。 如果没有,不用担心,我将在本周结束前再试一次,并就此向您回复。

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    值得一提的是、我上面提到的板(在这里我看到 AVDD 为0V)与我在有关该主题的第一条评论中提到的板不同。 因此、我现在有两个板、其中一个板实际上具有正确 的 AVDD 和 V_BK 电压、另一个板不具有正确的电压(我必须在开始时进行一些不正确的探测)。 问题(在我的末尾)是具有正确电压的电路板无法使用、因为其中一条 PCB 走线被破坏。 基本上、我有一个板为我提供正确的电压、因此我确信我的原理图/布局至少在功能上是正确的。 即使如此、我也希望有人能够浏览原理图...

    我已经查看了 MCT8316ZTEVM 的设计、并且没有看到任何与我的设计相关的问题。

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    你好、Nivant、

    请允许我再花些时间对您的原理图进行适当的审阅。 我觉得您的器件可能卡在睡眠模式、但我需要额外的时间才能完全审阅您的原理图。 请查看 nSLEEP 引脚周围的电路架构、以确保施加正确的电压。

    最棒的

    Robert

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    你好、Nivant、

    我也看不到您的原理图有任何明显的问题。 但是、我仍然担心您的 LDO 输出。  一种可能有所帮助的一般做法是、如数据表中所述、TI 建议组件的额定电压至少为器件/引脚正常工作电压的两倍。 如果 您怀疑设备可能已损坏、是否可以尝试用另一个设备更换设备?

    您能否向我发送 nSLEEP 和 AVDD 的波形以便我查看它们? 这可能有助于我们确定器件是否在启动期间退出睡眠模式。 此外、请查看数据表的 nSLEEP 部分:

    最棒的

    Robert

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    更新后、我焊接了一个新板、并能够获得3.3V 稳压器和降压稳压器电压。 它们均按预期运行。 这意味着器件正确退出睡眠模式、对吧?

    遗憾的是、我仍在向驱动器施加 PWM 信号、但什么也不能获得。 也就是说、电机不会转动、并且进入电路板的电流仍在0A 左右。 ILIM 电压大约为1.33V、这有点高、但仍在容差范围内(AVDD/2 - AVDD/2 - 0.4)。 我假设我的 ILIM 电压正常、我仍然应该让电机旋转? nFAULT 也保持低电平。 电荷泵电压为33V、而 VM 为28V。

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    你好、Nivant、

    很高兴听到3.3V LDO 和降压稳压器按预期运行。  

    当 AVDD 为3.3V 时、1.33V 的 ILIM 电压处于系统容差范围内。 由于 nFAULT 保持低电平、因此存在故障情况。

    您能否通过监控 PWM 引脚上的 PWM 信号来检查器件是否正在接收速度命令? 如果未收到速度命令、电机可能无法旋转。  

    此外、请参考数据表的第8.3.16节、检查器件提供的所有可能导致 nFAULT 变为低电平的故障条件和保护。

    最棒的

    Robert

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    抱歉,我说错了。 nFAULT 保持高电平、这意味着没有 FAULT 信号。 我在 PWM 信号上还有一个调试 LED、它会亮起、因此我知道驱动器正在获取 PWM 信号。

    提供更多建议。

    如果没有想到其他东西(老实说,我不能想到任何东西),我可以用显微镜检查所有焊点,并可能重做其中的一些焊点。 我怀疑 PWM 信号在某种程度上没有通过...

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    你好、Nivant、

    我会通过监控 PWM 引脚上的 PWM 信号来尝试确认您的怀疑、以查看器件是否正在接收速度命令、这有望缩小调试范围。 请仔细检查所有焊点、以确保整个电路板的连接性。

    最棒的

    Robert

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    更新:

    我开始意识到电路板上的焊接工作非常重要。 我在另一个电路板上重新焊接了另一个电机驱动器、它再次开始工作(内部稳压器输出电压、但 PWM 仍然不执行任何操作)。 我会在这里多呆一会儿

    我想知道 PWM 信号的电气要求是什么? 是否需要某种 PWM 振幅(3.3V 或5V)或类似的振幅?  

    谢谢

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    你好、Nivant、

    请参阅数据表电气特性表7.5、其中显示了 PWM 引脚和其他引脚的逻辑高电压和逻辑低电压:

    如果我已经回答了您的原始问题、请提交一个包含任何其他问题的新 E2E 主题、以便其他有类似问题的客户可以更轻松地找到答案。  

    此外、如果您可以帮助将此主题标记为已解决、我们将不胜感激。

    最棒的

    Robert

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    终于找到了问题。 我没有在霍尔传感器上使用上拉电阻器。 电机现在转动、但效率很低。 我将此帖子标记为已解决、并将通过互联网寻找有关如何更高效地驱动电机的解决方案。 目前、它以恒定转速转动、但噪声很大。