This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

[参考译文] UCD3138:需要固件授权

Guru**** 610675 points
Other Parts Discussed in Thread: UCD3138, UCD3138FW-HSFB
请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

https://e2e.ti.com/support/power-management-group/power-management/f/power-management-forum/1014026/ucd3138-firmware-authorization-is-required

器件型号:UCD3138

尊敬的专家

客户从我们的官方网站购买了 UCD3138的演示板、然后下载了该例程。 他发现编译需要授权。 要倾听 E2E 的回答、我们的工程师需要签署保密协议。但我不知道我们需要签署什么协议。 您知道怎么做吗?

以下是客户在 E2E 上的问题和答案:

在编译 UCD3138程序期间发生了以下错误:错误类型表示需要授权、如下图所示:

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    不应要求签署保密协议。  我认为系统拒绝权限、而不是 CCS。  您是否曾尝试使用编辑器(如记事本)打开这些文件?  如果您在读取编译器时遇到问题、并且权限被拒绝、可能请尝试在具有更多权限的位置(如文档文件夹)安装编译器。   

    您使用的是哪个版本的 CCS?

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    请参阅下面的响应。  我有一个发痒的触发手指、所以我回去编辑了它、但它在你编辑时不会发出另一条消息。

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    尊敬的专家

    我使用 CCS10.31版本、ARM 编译器工具版本为5.2.9  

    我从 TI 网页下载了固定的 SDK: UCD3138FW-HSFB — UCD3138硬开关全桥、 https://www.ti.com.cn/tool/cn/UCD3138_FW_SDK

    然后我构建了工作区,导入了 UCD3138FW-HSFB 项目,然后导 入了“”Build Project“,但失败了。  

    错误提醒它需要  ARM compilier Tool 版本是5.2.4, 但我没有找到版本5.2.4,但找到版本5.2.9,所以我不得不下载版本5.2.9  

    然后单击“”Build Project“”,但再次失败,并提醒“权限被拒绝”

     

    顺便说一下,我没有编辑此项目文件中的任何内容。

    请向我提供更多建议和解决方案。

     

    期待您的快速回复!

     

    谢谢!  

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    我建议您只 安装6.2版 CCS、其中包括正确版本的编译器。   

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    一个多星期以来、这种情况一直没有反应、所以我要假设它已经解决了。