This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

[参考译文] AM3517:PUT_CRED_RCU()看到 d92cf5d8和用法–1.

Guru**** 645850 points
Other Parts Discussed in Thread: AM3505
请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

https://e2e.ti.com/support/processors-group/processors/f/processors-forum/1080462/am3517-put_cred_rcu-sees-d92cf5d8-with-usage-1

部件号:AM3517
“线程:AM3505”中讨论的其它部件

您好,

我有一个运行4.19.96内核的 AM3505处理器。 我已经禁用了尽可能多的调试配置,但现在我的回归框架能够在两天内触发以下内核恐慌(200~300迭代):
[318.159324] 内核恐慌-未同步:cred: put _cred_RCU()看到 d92cf5d8的用法为-1  
[ 318.159324]  
[318.168998] --[结束内核恐慌-未同步:cred:put _cred_RCU ()在使用情况下看到 d92cf5d8–1.  
[ 318.168998] ——  

elixir.bootlin.com/.../cred.c

如果我启用了 CONFIG_DEBUG_Credentials,则不会发生错误。 我已经有一周的测试(1700次迭代)。

我认为这是因为添加调试会给内核带来延迟,但我想知道其他人是否看到并修复了这种行为。

谨致问候,
蒂姆

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    你好,蒂姆,

    请注意,AM35x 是较旧的部件。 我们唯一拥有的有关此部分的知识来源是您可以在 TI.com 上找到的宣传材料(例如,论坛和 https://www.ti.com/product/AM3505上的产品页面)。 由于这些部件没有 EVM 等,我们可以提供的支持将受到限制。 此外,此部件的 TI 软件太旧,我们无法支持。 由于您使用的是 Linux 内核4.19,因此它必须是非 TI 软件版本。

    在我的头顶上,我没有看到你们在我经历过的其他部分观察到的行为。 通常,我会向客户介绍我们的“调试嵌入式 Linux 系统”培训,但不确定该培训是否足够具体,可以帮助您完成调试过程:
    https://training.ti.com/debugging-embedded-linux-systems-training-series

    此致,

    尼克