This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

[参考译文] TMS320VC5410A:IEEE 1149.1 JTAG/仿真-无法运行

Guru**** 682950 points
Other Parts Discussed in Thread: CODECOMPOSER
请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

https://e2e.ti.com/support/processors-group/processors/f/processors-forum/631405/tms320vc5410a-ieee-1149-1-jtag-emulation---cannot-operate

器件型号:TMS320VC5410A
主题中讨论的其他器件:CODECOMPOSER

我们已确认我们的主板可以正常工作,因为我们已经通过 HPI 预先下载了代码,该代码可以按预期运行和运行。

我们已确认 Spectrum Digital XDS200调试器可以正常工作,因为我们针对 BeagleBone 对其进行了测试。

我们已确认 Spectrum Digital XDS200调试器已加载最新的1.0.0.8固件。

我们已使用示波器确认了 POD 和 DSP 之间的 JTAG 信号完整性。

我们已经确认,我们的 JTAG 电路与我们可以找到的 TI 参考设计相匹配,在这些设计中,不同的设计并不相互矛盾。

我们使用的是 DSP 支持的最新版本的 CodeComposer Studio (v5.5.0)。

我们已尝试使用 Win7计算机和单独的 Win10计算机。

 

我们的重现步骤为:

  • 将 XDS200 USB 调试器连接到主机
  • 在断电的情况下、将 XDS200 Pod 连接到目标系统
  • 在 CCS 中创建新的目标配置
  • 将连接设置为“Texas Instruments XDS2xx USB Debug Probe”
  • 将板或设备设置为“TMS320C5410A”。
  • 为目标系统供电
  • 在 CCS 中按“Test Connection”按钮。

我们在示波器上观察到 nTRST 在大约600uec 的持续时间内被驱动为低电平。 在此期间、就在 nTRST 被驱动为低电平之后、有100个 TCK 周期。 则 TCK 不会在大约520 μ s 的时间内切换。 然后 TCK 在另外10个周期内切换。 则 nTRST 被驱动为高电平。

我们从未看到 TDI 或 TDO 发生任何变化。

然后、CodeComposer 会报告-233错误、即 IR 和 DR 寄存器无法循环位、扫描路径似乎卡在一个或卡在零。

我们已确认,TDI 或 TDO 与接地或 Vcc 之间没有低电阻连接。

 

一切似乎都已正确配置、干净驱动、按预期运行,但我们从未能够在 CCS 和 DSP 之间建立连接。

使用干净的信号、已知良好的目标系统和已知良好的调试 Pod、我们还可以在哪里查找 JTAG 通信问题?

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。
    尊敬的 Thomas:

    我已将您的疑问转发给专家。 他们的反馈应发布在此处。

    BR
    Tsvetolin Shulev
  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    尊敬的 Thomas:

    在目标配置窗口中、您是否可以尝试将 JTAG TCLK 频率降低到较低的速度、以查看循环位错误是否在较低的频率下消失?

    仔细检查 JTAG 引脚是否在您的定制板上正确布线。 预期的信号是否正确连接到 JTAG 母接头? 如果使用通孔、请确保插头未安装在电路板的错误一侧...

    确认 TRST 上有一个下拉电阻器、EMU1/0上有一个上拉电阻器。

    XDS200是比 VC5410A 更新的仿真器。 我以前没有将它们配对在一起...您可以尝试其他任何仿真器吗?

    选择 CCSv5.5是正确的、CCSv5.5是支持 C54x 的 CCS 的最新版本。

    请参阅以下资源:
    http://processors.wiki.ti.com/index.php/Debugging_JTAG_Connectivity_Problems_legacy

    XDS560仿真器技术参考- http://www.ti.com/lit/ug/spru589a/spru589a.pdf

    希望这对您有所帮助、
    标记

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好 Mark。 感谢您的回复。 然而,我们仍然没有成功。

    1. 将时钟减慢至1MHz。 结果无变化
    2. 连接器安装正确、并验证了与 C5410A 上预期引脚之间的连接
    3. 有关 TRST 上的下拉电阻的说明。 根据 DSP 数据表、我们有一个外部470欧姆下拉电阻器。 我们在一些在线论坛上看到 XDS200使用集电极开路输出、因此无法将 TRST 拉至高电平。 这似乎得到了确认、因为我们没有观察到 TRST 升高。 因此、我们移除了470欧姆下拉电阻、并在仿真器 TRST 输出上放置了1千欧的上拉电阻。 当我们这么做时、TRST 将从高电平开始、然后被拉至低电平、然后再次变为高电平。 在 TRST 升高之前、我们观察到~10个时钟周期、在 TRST 再次升高之后、有~100个时钟周期。 最后、由于 POD TRST 输出上的外部1k Ω 上拉电阻、我们再次添加了470ohm 下拉电阻、并观察到 TRST 永远不会变为高电平。 在所有这些变化的情况下、原始误差仍然存在。
    4. 您还会建议什么其他仿真器? BTW -我们在 Code Composer 中安装了 c54xx 驱动程序、支持 XDX2xx USB 仿真器仓体。

    -Thomas Shafer