This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

[参考译文] AFE7422EVM:将 AFE 设置为模式4时、不会发生 LMK 锁定和#39;t

Guru**** 1131400 points
Other Parts Discussed in Thread: TSW14J57EVM, AFE7422, AFE7444, AFE7222
请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

https://e2e.ti.com/support/rf-microwave-group/rf-microwave/f/rf-microwave-forum/1100431/afe7422evm-lmk-lock-doesn-t-happening-when-setting-afe-into-mode-4

器件型号:AFE7422EVM
主题中讨论的其他器件: TSW14J57EVMAFE7422AFE7444AFE7222

您好!

我将 AFE7422EVM 与 TSW14J57EVM 配合使用。

为了启动电路板、我使用 了 TI AFE74xx 启动视频。

实际上、我只观看了第一和第二个视频、并在第三个视频中进行了堆叠: 如何使用内部 PLL 在模式4中配置 AFE74xx DAC

我们已成功将  AFE7422EVM 设置为 TX 模式4并创建了两个音调(如视频中所示)。

但我们无法设置 AFE7244EVM 以使其 LMK 锁定-当我们单击"设置模式"按钮将 AFE 设置为模式4时、它应使 LMK 锁定 LED 亮起、但这种情况并非如此。

实际上、AFE7422EVM 上的所有 LED 均关闭、D12 PWR 和 D11 USB PWR 除外。

默认情况下、所有跳线均已设置-正如在启动视频中所述。

我们已通过 J36上的示波器监控了 LMK SPI CLK -这里没有任何信号。 因此、FTDI 根本不会向 LMK SPI 发送任何单个时钟。

请帮助解决此问题。 我们拥有的电路板是全新的、我们甚至无法进行最简单 的启动测试。 帮助我们了解正在发生的情况?

我还在这里阅读了类似的主题: https://e2e.ti.com/support/rf-microwave-group/rf-microwave/f/rf-microwave-forum/953857/afe7444evm-led-d7-lmk-locked-doesn-t-light-up-after-set-mode/3560387?tisearch=e2e-sitesearch&keymatch=afe74xx%20lmk#3560387

我可以看到、这些问题仍然存在、并且不会再次出现。

此致、

Eugene Kim  

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好、Eugene、

    问题似乎是由于某种原因 GUI 未连接到 USB。  

    在 AFE74xx GUI 中、USB 状态(GUI 右上角)旁边是否有绿灯?

    您能否确保在 GUI 安装过程中安装 LabVIEW 运行时间?

    您是否以管理员身份打开了 GUI?  

    此致、

    Vijay

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    尊敬的 Vijayendra:

    我在装有 Windows 10的新 PC 上安装了 AFE74xx GUI。 LabVIEW 和 Python 都已安装。

    我已经再次检查了 SPI、现在我可以在使用 LMK 寄存器进行一些操作时看到 SPI 时钟:

    但在按下"设置模式"后、LMK 锁定 LED 仍然熄灭。

    这就是我在按下"设置模式"按钮后看到的内容:

    在按下"Run Complete Startup Sequence"后、GUI 会显示以下内容:

    另外、在按下  "Run Complete Startup Sequence"(运行完成启动顺序)后、我看到警报 LED 亮起:

    如果您需要检查或测试其他内容、请告诉我。

    请帮助解决此问题。

    此致、

    尤金

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好、Eugene、

    由于 LMK SLCK 显示了清除 SPI 活动、 因此 EVM 控制软件应向 LMK 发送正确的 SPI 配置。  

    您能否检查板载直流/直流和 LDO 输出电压? 尤其是 LMK 3.3V、因为我们看到了 LMK PLL 锁定问题。

    我们可以验证的另一个信号是122.88MHz 板载晶体输出。 这是 LMK 的振荡器输入、对于 LMK PLL 锁定至关重要。  

    可探测 Y1的引脚4或5以验证这一点

    此外、您在 EVM 上的电源插孔上获得的电压和在此电源上设置的电流限制是多少?

    此致、

    Vijay

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    尊敬的 Vijayendra:

    EVM 由5.6V 电源供电、这是正常情况:

    我已经检查了 EVM 上的一些内部电压、我想说所有这些电压都存在。

    对于在 PP1测试点测得的 LMK 电源(+3.3VCLK)而言尤其如此-它很好:

    板载振荡器 Y1也在运行-这是我在其输出端看到的结果(引脚#4 OUT_N):

    但是、当我将示波器放置到 LMK 输入引脚时、我会看到振幅较低的信号:

    这是否正常?

    此致、

    尤金

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    尊敬的 Vijayendra:

    此外、我无法理解为什么振荡器的 CMOS 输出时钟驱动 LMK 的 OSCINn (引脚44):

    在 LMK 数据表中、指定的值超出了 CLKINp (引脚43)上的值:

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好、Eugene、

    我已经在其中一个 EVM 上测量了板载振荡器的电平、这些电平与您的测量值非常相似。 您测量的电平是可以的。

    关于 OSCin 引脚的第二个问题、我们将与时钟团队进行核对、并分享他们的回答。

    此致、

    David Chaparro  

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    尊敬的 David:

    也许您可以告诉我、在将 LMK 输出加载到模式4中时、我还可以在哪里检查它的时钟?

    我仍然认为问题在软件中。 它看起来没有配置 LMK。

    此外、我无法使用"低电平"选项卡读取寄存器值这是我从0x03读取的值、其中 ID_DEVICE_TYP[7:0]应为:

    这些是 LMK 输出、我可以在其中看到运行时钟:

    C424 = DCLKOUT6N = CLK0_M2C_P

    C254 = DCLKOUT4N = DCLKOUT4N

    C240 = FPGA_CLK1P = FPGA_CLK1_P

    C427 = DCLKOUT10P = GBTCLK1_M2C_P

    所有频率都相同、大约为307MHz:

    这对于 Mode4是可以的吗?

    如果您需要检查其他内容、请告诉我。

    此致、

    尤金

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好、Eugene、

    在您之前的一个回答中、您在按下设置模式按钮时显示了日志、我注意到它不正确。 按下设置模式按钮时、您应该会收到如下所示的日志。 是否可以再次尝试以确保按钮正常工作?

    另一个要尝试的操作是通过"Advanced"选项卡对 LMK 进行编程。 在快速入门选项卡中选择模式4后、您可以前往高级选项卡、然后按下下图中突出显示的"LMK 配置"按钮。 这应针对模式4配置对 LMK 进行编程。

    此致、

    David Chaparro

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    尊敬的 David:

    实际上、这就是我在脚本窗口中按下"设置模式"按钮后看到的所有情况:

    您说的日志不正确,我在按下“运行完成....”按钮后看到。

    这是正常的吗?

    当然、这是我逐步执行的操作:

    1.将所有组件连接到 EVM

    2.为 TSW 加电

    3.为 AFE 加电

    4.打开 HSDC Pro、设置 DAC TX 模式4、将数据速率设置为737.28M、创建两个音调:5m、2,10M、按"创建音调"、按"发送"

    5.在菜单中打开 AFE GUI:Script->Launch Window、Script -> Start Recording

    6.在 AFE 模式选择中、选择模式4并按"设置模式"

    我是否错过了任何内容?

    我尝试转到"Advanced"选项卡并按"LMK Config"、但 在执行此操作后没有明显的变化。

    这是 Advanced (高级)选项卡的屏幕截图:

    我们可能正在使用不同的 GUI 软件版本?

    我看到以下内容:

    这是好吗?

    此致、

    尤金

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    尊敬的 David:  

    我也执行了与这里的人相同的测试: https://e2e.ti.com/support/rf-microwave-group/rf-microwave/f/rf-microwave-forum/953857/afe7444evm-led-d7-lmk-locked-doesn-t-light-up-after-set-mode/3560387?tisearch=e2e-sitesearch&keymatch=afe74xx%20lmk#3560387

    使用"低电平"选项卡、我将0x4写入0x16E 寄存器(PLL2_LD_TYPE)、并且我看到锁定的 LED LMK 已开启。

    但是、当我读回寄存器时、值是0x0

    因此无法读回 LMK 寄存器。 这是正常的吗?

    此致、

    尤金

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好、Eugene、

    您面临的问题似乎是由 AFE7422安全文件夹中包含的 GUI 版本引起的。 我们正在更新此文件、但可能需要一些时间才能刷新文件夹。  

    我同时授予您访问 AFE7444安全文件夹的权限、该文件夹包含 GUI 的工作版本。 安装此版本之前、请确保卸载之前的版本并删除 AFE74xx 文件夹、该文件夹位于以下位置: C:\Users\Public\Documents\Texas Instruments 和 C:\Program Files (x86)\Texas Instruments

    请尝试一下、并告诉我这是否可以解决您的问题。

    此致、

    David Chaparro

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    尊敬的 David:

    我已经检查了所有相同的内容、但从 AFE7444安全文件夹下载并安装了 AFE GUI。

    首先、该 GUI 的所有版本与 AFE7422中的版本相同。 构建日期也相同。

    我已经将 AFE7422安全文件夹中的 Setup_AFE74xx_EVM.exe 与 AFE7444安全文件夹中的 Setup_AFE74xx_EVM.exe 进行了比较、而二进制比较工具显示文件是相同的。

    因此结果也是一样的。

    您能否检查 AFE7444是否包含正确版本的 GUI?

    此致、

    尤金

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好、Eugene、

    当您从 AFE7444文件夹安装 GUI 时、您是否首先删除了我上一篇文章中提到的两个文件夹? 我在 PC 上进行了测试、发现在 AFE7222文件夹中安装版本时、我遇到了与您相同的问题。 要安装工作版本的 GUI、我首先必须删除这两个文件夹、然后安装工作版本的 GUI。

    此致、

    David Chaparro

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    尊敬的 David:

    我确实删除了这两个文件夹。 我无法删除   C:\Users\Public\Documents\Texas Instruments 和 C:\Program Files (x86)\Texas Instruments 文件夹、因为我还安装了 HSDC Pro、但删除了:

    C:\Program Files (x86)\Texas Instruments\AFE74xx 文件夹

    C:\Users\Public\Documents\Texas Instruments\AFE74xx 文件夹

    要再次检查、我有另一台从未  安装过 AFE74xx 的笔记本电脑、并在此笔记本电脑上重复上述操作。

    这是安装前的文件夹:

    因为您可以检查 C:\Users\Public\Documents\或 C:\Users\Public\Documents\中没有 Texas Instruments 文件夹

    安装已从此处下载:

    在安装时、系统会询问:

    NI LabView RTE 已在主设置过程中下载并安装:

    USB 驱动程序已成功安装。

    第一次启动 AFE 软件时安装了 Python 2.7.2:

    这是设置和 AFE 软件首次启动后的文件夹:

    这是按下设置模式按钮后的结果:

    AFE EVM 上的所有 LED 均熄灭。 因此没有任何变化。

    也许您可以向我发送 您认为我的电子邮件中正确的安装程序?

    此致、

    尤金

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    您好、Eugene、

    我已在新 PC 上测试了 AFE7444文件夹中的安装程序、未发现任何问题。 我将通过电子邮件联系我测试过的安装程序。

    此致、

    David Chaparro

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    尊敬的 David:

    您通过电子邮件向我发送的文件字节到字节与我从 AFE7422和 AFE7444安全文件夹下载的文件相同。 这三个文件之间没有任何区别。  

    我已迁移到从未 安装过 AFE 和 HSDC Pro 的新 PC。 我对从安装到 HSDC/AFE 设置的所有过程进行了屏幕截图。 我将发送到您的电子邮件的视频链接。

    请帮助您了解我们的错误行为?

    此致、

    尤金

  • 请注意,本文内容源自机器翻译,可能存在语法或其它翻译错误,仅供参考。如需获取准确内容,请参阅链接中的英语原文或自行翻译。

    尊敬的 David:

    我已经解决了。 问题出在我使用的操作系统语言中。 我一直尝试用俄语或乌克兰语在操作系统 Windows 7或 Windows 10上工作。 现在我安装了英文版 Windows 10、一切都正常。

    我认为问题会导致 AFE GUI Python 脚本中的路径、该脚本不支持除英语之外的任何 Windows 本地化。

    我希望这可以在接下来的 GUI 版本中解决、因为重新安装完全正常工作的操作系统并调整操作系统以使 AFE GUI 正常工作并不是很方便。

    此外、这些信息可能对使用非英语版本 Windows 与 AFE GUI 配合使用的其他客户有所帮助。

    此致、

    尤金