This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

TMS470R1B1M在IAR IDE环境下程序烧写?

Other Parts Discussed in Thread: TMS470R1B1M

我现在用的是TMS470R1B1M,编程环境是IAR6.4版本,用J_LINK仿真器。在调试的时候连接正常,可以实现程序功能,但是退出仿真状态,重新上电后,硬件上没有功能,感觉是程序没有烧写进去,请专家指点如何将程序烧写到硬件里面!谢谢!

  • Hi Rui,

      请您检查一下调试器的设置,应该在project options中,是否将程序下载到flash调试还是只是到RAM又或是仅用到了Simulation功能?

      或者可以查看一下工程的链接文件(IAR的链接文件应该是*.dr吧),看一下是否将代码映射到了RAM?

  • Hi,Renton:

    在Override default选项的下面我选择的是

    $TOOLKIT_DIR$\examples\TexasInstruments\Configuration_Files\B1M_Files\tms470r1b1m_lnk_flash.icf目录文件,我在我的整个文件中没有找到您说的*.dr的文件。

    在以上的配置情况下,我的软件还是不能写入到CPU中,一直处在仿真阶段。

    详细信息请查看附件。

    请赐教!谢谢!

  • Hi,Renton

    我的配置是Options > Debugger > Dowenlond >Vweify download \Use flash loader

     

    在Override default .board file选项的下面,我选择的是

    $TOOLKIT_DIR$\config\flashloader\TexasInstruments\FlashTMS470R1B1M.board目录文件。

     

    在link选项中,我的链接文件设置Linker> Config>Override default

     

    在Override default选项的下面我选择的是

    $TOOLKIT_DIR$\examples\TexasInstruments\Configuration_Files\B1M_Files\tms470r1b1m_lnk_flash.icf目录文件。

    我在我的整个文件中没有找到您说的*.dr的文件。

    在以上的配置情况下,我的软件还是不能写入到flash中,一直处在仿真阶段。请赐教!谢谢!

  • Hi Rui,

       没有看到您的附件。

       我这边暂时没有相关环境,稍后我会把环境建立起来查看一下再给您回复。

  • Hi Rui,

       请你先生成map文件来观察一下连接器的输出。

       生成map文件的方法:

       [Project]菜单->[Options]->选择[Linker]->选择[List]选项卡->勾选Generate linker map file.

       然后重新make工程,会生成map文件。

       这里可以观察到您的代码是如何分配到存储空间中去的。

       如果放在RAM上,那么掉电的确会丢失的。

       如果在Flash上,那么就不是程序掉电丢失的问题,很可能是boot过程出了问题。

  • 我也遇到类似问题,求解决方案,木有弄明白。

  • 工程左上角,你看看你选的ram,还是flash。应该选择flash。。。