我们将在春节假期期间对网站进行维护,可能暂时无法访问,同时工程师回复将有所延迟,敬请谅解.

This thread has been locked.

If you have a related question, please click the "Ask a related question" button in the top right corner. The newly created question will be automatically linked to this question.

DLPA3005: DLPC3479+DLPA3005+4710 投影异常

Part Number: DLPA3005
Other Parts Discussed in Thread: DLPC3479, DLP4710, DLP4710LC, CSD17309Q3

TI攻城狮,您好,

我司自研板卡 DLPC3479+DLPA3005,DMD是4710。

DLPC3479+DLPA3005此板已量产,出现了一个问题:DLPC3479+DLPA3005+4710

两个板卡+两个DMD+两个控制板+两个相机:

1. A控制板发命令给A光机,控制A光机投光,并产生触发信号,同时触发A相机和B相机拍照,完成后暂停一会;

2. B控制板发命令给B光机,控制B光机投光,并产生触发信号,同时触发B相机和A相机拍照,完成后暂停一会;

上述两步算一个完整过程,循环进行。

问题:

有的设备没有问题,一直正常。

有的设备在刚开始时都是正常,当进行一定时间后(多长时间不定,有时候时间长,有时候时间短),其中一个板卡不投光了,不断电情况下,USB接口改连到PC机上,用4710上位机软件,USB正常连上,但是操控不了光机投光。操作界面中点击各个界面中的get按键,都能得到光机信息,说明光机和电脑正常通讯,在触发界面点击Run Once,I2C信号能量到波形,点击一次出现一次,TRIGGER_OUT2也能量到触发波形,但是就是不投光。此时量3005的各路电压输出,发现VOFS、VBIAS、VRST这三路无输出,其他电压都正常。PROJ_ON、PAD_RESETZ、PARKZ(INTZ)也正常。

请问这种情况是哪里出了问题?还请帮忙分析分析!

  • 电源是15V/7A,一个电源给一套设备供电

  • 你好。从以上的描述来看,应该是A光机输出Trigger_Out2同时给A、B相机;B光机也一样的连接。建议你断开框图中绿色部分的连线测试一下。

    另外可以更新DLPC3479到最新版本固件:https://software-dl.ti.com/dlp/pico-fw-selector/

    控制板发送命令给光机投光时,可以在各个命令之间加一点点延时试试。

  • 谢谢回复,断开测试过,单光机测试,也有类似的情况,VOFS、VBIAS、VRST这三路无输出。控制板发送命令给光机投光时,可以在各个命令之间加一点点延时,需要加多长时间延时呢,加延时是其什么作用呢?请问下 新固件做了什么改动呢?

  • 控制板发送命令给光机投光时,可以在各个命令之间加一点点延时试试。

    -------应该有延时的,A光机被触发完后,不会收命令了,此时B光机触发,B光机触发的时候,A光机没有收任何命令,应该算是延时了吧,待B光机触发完后,A才又被触发。

  • 请问光机投图是通过外部信号触发还是free run模式?如果是偶发的不投图,建议你先测试TI官网上8.1.1版本最新固件。你点击上面的下载链接,会有一个软件的release note,里面有详细说明。

  • 通过USB发命令触发投图,应该与GUI软件中触发界面的Run Once 类似,间隔的一定时间发Run Once。是偶发的,有时候出现不投图。8.1.1版本最新固件下载了,升级固件后,不投光,之后3005自断电了,系统没工作

  • 如果v8.1.1版本软件开不了机,可能你的光机用的是DLP4710的DMD。你可以换DLP4710LC的DMD光机做一下试验。

    还有个思路就是每次run的时候都会发一些I2C命令给3479。可以试试在每条命令中间加一点延时,例如50或100ms,或者适当调整一下延时的长短。

  • 您好,目前我做了这个实验:PC GUI软件通过USB连板,在Advanced里面的 illumination界面,将RGB LED Curennt 的蓝光设置为620【620 对应多大电流呢?】,然后用录屏软件循环点击 Run Once【点击一次后,间隔10秒再点击,10秒点击一次算延时了吗?】,运行一段时间后,仍然出现上述情况,VOFS、VBIAS、VRST这三路无输出,直流稳压电源变为了0.06A,此时不再投光,重上电可以投光。

     RGB LED Curennt 的蓝光 steps 设置为620,投光时,直流稳压电源15V/1.9A,投光结束后为15V/150mA。

     RGB LED Curennt 的蓝光 steps 设置为1023,投光时,直流稳压电源为15V/4.9A,投光结束后为15V/150mA,电压在投光的那一小段时间,电压跌落到9.5V,之后恢复到15V,这个有没有影响呢?是不是瞬时电流太大,瞬时电流供不上导致?直流稳压电源是30V/20A的,设置为15V/20A,steps 设置为1023,整机瞬时电流超过了20A吗?

  • 你好。软件设620,对应灯的电流在10.1A左右。如果设1023,理论上三颗LED灯最大电流会到16A。在每次run的时候,前端可能会发送一些I2C命令给3479,例如下面的命令。可以尝试在这些I2C命令之间加一点延时。你还可以把LED灯的电流设低一些,看看run的过程中会不会有问题。

  • 问题找到了,H MOS管 CSD17309Q3 坏掉了。

        用1023 测试,电流16A老化测试,长期这样测  CSD17309Q3 损伤了,但是还没有彻底坏,所以投一段时间后,出现了上述情况。在分析问题反复测试的过程中,有一次上电彻底不投光了,后面发现是CSD17309Q3彻底坏了,GS间阻抗只有67Ω,找一个正常的板对换,目前是测试了一天(将近有20小时了),还没出问题。之前非常容易出问题(几分钟、10多分钟、1小时、最长6小时)。

        

  • 为啥MOS管容易坏掉呢,R G B通道的 MOS管也有的板坏了,这个坏,会造成上电闪一下不投光。大电流投光,MOS管并不热,测温枪测试过,40度左右,室温15度,温升25度

  • 如果MOS管本身物料没有问题,可以测量一下电感到3005 SW脚之间的电流波形,看看是否有很大尖峰。

  • 以下是 ILLUM_HS_DRV_Q 处的波形: